1.    3 Weeks Ago #1
    Join Date : Aug 2015
    Posts : 37
    Duh Windows 9

    Super high speed internet but actual browser speed is terrible


    My desktop has a external network card that connects at 520 mb, using comcast internet with a dl of 150 and ul of 30
    I tried chrome and internet explorer and they both are quite laggy, my laptop works just fine

    The desktop is actually closer to the router than my laptop is

    Where should i start troubleshooting
      My ComputerSystem Spec
  2.    3 Weeks Ago #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,030
    Win 10 Pro (1703)

    Hi, do both use the same DNS?
    Is there a difference in ping results to the same server?

    When you're using your browser is general resource use on your desktop low?

    Is your laptop using Wifi, and your desktop ethernet? If so, how does the laptop perform using an ethernet connection?

    If you try a network speed test, are the results similar?
      My ComputerSystem Spec
  3.    3 Weeks Ago #3
    Join Date : Aug 2015
    Posts : 37
    Duh Windows 9
    Thread Starter

    Same DNS, same ping, no other resources aside from browser, both are on wifi 5hz, speed test is about the same for both
      My ComputerSystem Spec
  4.    3 Weeks Ago #4
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,030
    Win 10 Pro (1703)

    History: was the desktop behaving ok until recently.. i.e. did something change?
    If so, has there been an upgrade or update (including driver)?

    What is the Windows build?
    Windows key + R, winver
      My ComputerSystem Spec
  5.    3 Weeks Ago #5
    Join Date : Oct 2014
    Posts : 2,462
    W10 Pro + W10 Preview

    Open CMD (ADMIN) and copy paste the following....then restart computer.

    netsh winsock reset
      My ComputersSystem Spec
  6.    1 Week Ago #6
    Join Date : Aug 2015
    Posts : 37
    Duh Windows 9
    Thread Starter

    Quote Originally Posted by dalchina View Post
    History: was the desktop behaving ok until recently.. i.e. did something change?
    If so, has there been an upgrade or update (including driver)?

    What is the Windows build?
    Windows key + R, winver

    I havent installed or changed anything in the machine, it does have automatic updates, i just checked and the wireless driver was updated 2 mths ago, not sure how i missed that before

    Right at this moment internet is working fine, but if problem happens again i will roll back driver
    Build is 15063 674 version 1703
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved CPU not running at full speed even at high performance power mode
I've notice that on windows 10 and 8.1, task manager would show the my max cpu core speed is 2.3-2.4 ghz. However, my Core 2 Quad q8400 is rated at 2.66 ghz. I tried changing the power settings in windows and try lowering my cpu temperature, but my...
Performance & Maintenance
Solved Windows 10 slow WiFi speed, high ping in games
Hello, I have been having extremely high ping in online games like BF1 and Titanfall 2 (>500 with spikes to over 1000, pretty much unplayable), and slow WiFi speeds. I have already updated my wireless drivers and disabled location and automatic...
Network and Sharing
HTML5 connectivity speed much lower then net speed
Hi I have this nasty issue and would like a solution or suggestions 1 desktop 3 laptops on the same network. Network speed download 6Mb (not much but stable :-)) desktop and 2 laptops on windows 10. 1 Laptop on windows 7. All pcs are fully updated...
Network and Sharing
To speed up mouse scrolling speed in Firefox in Linux VirtualBox
I was told by somebody here with VIP badges that I should not post here how to make Firefox run more smoothly in a Virtual Machine in Linux. It should be in a Linux forum. So I moved it there.
Virtualization
Solved High Ping while running speed test on Firefox
Hey Guys, Can anyone else confirm this for me. Firefox updated to version 40 recently and ever since when I run a speedtest I get a very high Ping. I went from 10-15ms to over 150ms testing my local ISP servers. My download and upload speeds are...
Browsers and Email
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 02:37.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums