Page 1 of 4 123 ... LastLast
  1.    28 Sep 2017 #1
    Join Date : Aug 2016
    Posts : 110
    win10

    Why Would/How Could Ports Refuse to Open?


    Not sure where this belongs but it certainly could be a networking question.

    I port forward on the router so's web traffic can access my IIS installation on one machine on my LAN.

    But the ports never open on this machine. No traffic gets in. No port checker reports the ports as open.

    Other machines on the LAN I can forward to without a problem. So it's not the router

    So it's not the ports on the router, the 'wan' port. So it must be the ports on the local machine.

    Where are these ports? In ROM? or in RAM? How many are there?

    I wonder if it could even be a hardware problem, see.

    Unlikely, because port checkers report port 80 as being closed. But it can't be closed if my browser traffic is working, and it is.

    But I wonder anyway.

    What processes in win10 can influence whether a port is open or not?

    In case it was IIS I have 'upgraded' my win10 installation with that upgrade where you go to the web and download from MS and then run it and choose upgrade - keep files and apps.

    It didn't help. So now I wonder about it. It carries on, takes so much time, as though it is a total reinstall of win10 and that's what I thought it was. But is it?

    Looks like it has left some part of the OS behind that interferes with the ports.

    What part of the OS returns 'pings' ? Refuses pings? I got a message one time said the ping was refused.
      My ComputerSystem Spec
  2.    28 Sep 2017 #2
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,035
    Windows 10 Pro Build 1703

    Hi abrogard.

    There are thousands of ports, they are virtual. Traffic through them is controlled by Firewall. As well the port accepts or rejects protocols. (TCP or UDP).

    What firewall product are you using, there is windows firewall or the firewalls bundled with AV products or stand alone products.

    https://www.howtogeek.com/howto/2860...rt-in-windows/

    http://www.tomshardware.com/faq/id-3...s-windows.html

    Likely the easiest thing to do is shut off all firewalls and test. Then enable and go from there with settings. I would not recommend normal usage with no firewall.


    Ken


    Ken
      My ComputerSystem Spec
  3.    28 Sep 2017 #3
    Join Date : Aug 2016
    Posts : 110
    win10
    Thread Starter

    Thanks for the comment. Yes, I've tested with all firewalls down. Doesn't help. That's Avira and Windows and router.
      My ComputerSystem Spec
  4.    28 Sep 2017 #4
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,035
    Windows 10 Pro Build 1703

    Are all the computers on a homegroup?

    Any chance that when you set troubled device up you set it on a public network, should be private. If you click on network icon in systray and the Open Network and Sharing and finally Advance Sharing Options. See how it is set.

    Have you tried a Windows Network Reset on troubled device? Start => Settings => Netwrok and Internet => scroll to bottom of right hand side.

    Reset network will cause you to forget wireless passwords and you may have to re-install communication software for things like VPN.

    I would also uninstall Avira for test purposes.
      My ComputerSystem Spec
  5.    28 Sep 2017 #5
    Join Date : Aug 2016
    Posts : 110
    win10
    Thread Starter

    Interesting ideas, thanks. Network seems to be set as private.
    I've a cut and paste of network properties I can show you here if it helps at all:
    Name: Wi-Fi
    Description: 802.11n USB Wireless LAN Card
    Physical address (MAC): 20:e2:16:00:11:84
    Status: Operational
    Maximum transmission unit: 1500
    Link speed (Receive/Transmit): 600/65 (Mbps)
    DHCP enabled: No
    IPv4 address: 10.0.0.13/24
    IPv6 address:
    Default gateway: 10.0.0.138
    DNS servers: 8.8.8.8
    DNS domain name:
    DNS connection suffix:
    DNS search suffix list:
    Network name: TelstraDADEF5
    Network category: Private
    Connectivity (IPv4/IPv6): Connected to Internet / Connected to unknown network
      My ComputerSystem Spec
  6.    28 Sep 2017 #6
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,035
    Windows 10 Pro Build 1703

    I should add, when you type ipconfig are you getting a valid IP address. I'll assume you are using static IP on troubled box so it always that ip address.
      My ComputerSystem Spec
  7.    28 Sep 2017 #7
    Join Date : Aug 2016
    Posts : 110
    win10
    Thread Starter

    yes. 10.0.0.13 is the local IP for this machine.

    and the static web IP always comes up the same when i look in the router or 'what is my ip' etc, so that's alright.
      My ComputerSystem Spec
  8.    28 Sep 2017 #8
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,452
    windows 10

    Can you see it ok on the local network?
    Check on the pc what ports are in use port 80 may be locked post result from this portable app CurrPorts: Monitoring TCP/IP network connections on Windows
    Get rid of avira in lot of cases its hard to disable a firewall stopping a icon doesnt stop it as it wil run as a service
    From the router forward ports 79-81 if your using port 80 for udp+ tcp some router are a bit of a mess
    Set windows fire wall inbound and out bound same as win8 Opening port in Windows 8 Windows 10 Firewall | My Tec Bits
      My ComputerSystem Spec
  9.    28 Sep 2017 #9
    Join Date : Aug 2016
    Posts : 110
    win10
    Thread Starter

    Yes i can see it on the network. currports shows that the ports i've forwarded are not open. i just did the exercise again - opened a port on the router and then checked everything including currports and it's not open.

    i would say the router is fine. it forwards without problems to another computer on the lan.
      My ComputerSystem Spec
  10.    28 Sep 2017 #10
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,452
    windows 10

    can you post currports results
      My ComputerSystem Spec

 
Page 1 of 4 123 ... LastLast


Similar Threads
Thread Forum
Sometimes Certain Windows Refuse to Come to the Front
Hello all, I just upgraded to Windows 10 recently, and so far (for the most part) it's working great! The only issue I have is that some windows won't focus and stay on top when I alt-tab to it or click it, like it did in all other versions of...
General Support
Shortcut to Open Device Manager with Ports Branch Expanded?
Is it possible to create a shortcut to Open Device Manager with the Ports branch expanded?
Drivers and Hardware
Taskbar icons refuse to group
Win10 pro 10240 Classic Start Menu Until recently the pinned icons and active programs would combine so that there was only one icon per program. Now the pinned icons and active ones are separate -- and filling up space. I checked the taskbar...
General Support
Solved Refuse driver updates in Windows 10?
I just installed the leaked Windows 10 build 10051. Before this I had 9926 installed. I have a game called DayZ Standalone, it refused to launch on 9926. A friend said that updating to 10051 allowed him to launch the game. So I did a clean install....
Windows Updates and Activation
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:59.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums