Windows 10: Cannot access SMB shares via Windows VPN

  1.    24 Sep 2017 #1

    Cannot access SMB shares via Windows VPN


    Hi,

    I have set up a VPN on my server at home. I am not using a domain.
    I can ping IP's on the network I am connected to and access things like my router using a local IP address.

    I can't however access any of my mapped drives.
    I've tried allowing all SMB rules in windows firewall

    Help appreciated

    Thanks
      My ComputerSystem Spec

  2. bro67's Avatar
    Posts : 4,895
    Mac OS High Sierra 10.13.5
       24 Sep 2017 #2

    What are you using to do the VPN handling? You should not need to share files, if you are directly accessing the machine. If you want to use FTP to access those folders only for FTP, you have to set them up that way.
      My ComputerSystem Spec

  3.    26 Sep 2017 #3

    Same for me with Android device and Raspberry Pi. Without vpn no problem with SMB, with vpn no access to Pi.
    Curious whether a solution exists.
      My ComputerSystem Spec

  4. bro67's Avatar
    Posts : 4,895
    Mac OS High Sierra 10.13.5
       26 Sep 2017 #4

    PiKo said: View Post
    Same for me with Android device and Raspberry Pi. Without vpn no problem with SMB, with vpn no access to Pi.
    Curious whether a solution exists.
    There is. You have to map the folders for VPN, depending on what you are using for VPN.

    How to Access Network Resources Over a VPN PDF handout that also explains it. http://facilities-intranet.anu.edu.a..._using_vpn.pdf
      My ComputerSystem Spec


 

Related Threads
I've been dealing with this issue for hours now and have tried everything I can think of. I have a Windows 10 Home PC that I have an incoming VPN connection on. I can connect to it, but if the firewall is enabled, I can't ping it or access the...
Cannot Access Windows Network Shares in Network and Sharing
Three machines: Surface Pro 4 - fully updated Surface Pro 3 - Windows 10, fully updated Lenovo X220T - Windows 8.1 Fully updated All three machines can see all available network devices, including each other. All three machines can...
Solved Can't access Samba shares on 10049 in Network and Sharing
I just reinstalled after I was having issues. Everything seems to be working smoothly, except that I can't access the shares on all but one of my other computers for some reason. Most devices that aren't running either some flavor of Windows or...
Since I updated to 10041 I can not get to my 8.1 notebook shares. No problem with access to the notebook from my Vista system and 10041 can access Vista and Mybooklive shares as before. When trying to access the notebook I get a Windows Security...
Can't access network shares in Network and Sharing
Before the upgrade to 10 I was on 7 and logged in with a local account with all computers having the same usernames and passwords and sharing worked flawlessly. After the upgrade I am now logging in with a Microsoft account and sharing does not...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:03.
Find Us