I only get a fraction of the bandwidth that other users get.

Page 1 of 2 12 LastLast

  1. Posts : 22
    Windows 10

    I only get a fraction of the bandwidth that other users get.

    This is quite a strange issue for me and I'm trying to pinpoint the problem.

    Lately, I've been experiencing bad download speeds and lag-spikes. So I ran a test on Speedof.me and sure enough, I'm only getting 10 - 20Mbps results. Sometimes the upload speed even exceeds the download speed which makes no sense to me.

    Meanwhile, on another computer, no problem! 80Mbps download done easy.

    The issue seems to be picky about when it does this as well - for example when downloading with Steam, suddenly I get 22MB/s! But only for that Steam download, for some reason.

    Now I'm no novice with a computer. I checked everything I know of:

    • Connected to the router and ensured no strange QoS settings were inside. Nope, QoS totally disabled.
    • Also checked that said Router has good advanced configuration for the wireless bands.
    • Checked my computer's network adapters to ensure everything's fine. (I keep QoS thoroughly disabled, so that's not the culprit).
    • Tried connecting to the same band (2.4Ghz band) as the other computer was - nope, still bad DL speed. Re-connected to the 5Ghz band I use afterwards.
    • Tried removing all of my Firewall and HOSTS file rules just in case they had anything to do with it for some weird reason (they really shouldn't) - nope, still bad DL speed.
    • No, this system isn't running anywhere near capacity. It's not an overloading issue.
    • All of these tests were done while the rest of the users were idle - so the network isn't just overloaded.

    Does anyone have any idea what the issue might be? Is there a Group Policy setting buried somewhere that could throttle your network connection or something? I've already checked under "Administrative Templates >> Network", but all of them are simply in the "Not Configured" state, so they haven't been messed with I presume.

    This just makes absolutely no bloody sense to me.

    Any help is appreciated.

      My Computer

  2. Posts : 22
    Windows 10
    Thread Starter

    Just verified that it is indeed a network issue with this computer by directly connecting via ethernet and getting the same results. Something is clearly throttling this computer to 20Mbps max. All other devices continue to have no problems.

    If I can't figure out what it is I may just try reinstalling Windows.
      My Computer

  3. f14tomcat's Avatar
    Posts : 55,592
    Multi-boot Windows 10/11 - RTM, RP, Beta, and Insider

    Just a real s.w.a.g - have you tried uninstalling and re-installing the drivers for your network card?

    I only get a fraction of the bandwidth that other users get.-2017-08-25_12h33_17.png
      My Computers

  4. Posts : 22
    Windows 10
    Thread Starter

    The way I handle drivers is I usually just let DriverBooster do a scan and update for all of them after doing a clean install of Windows and self-installing the GPU and sound drivers (it's a third-party tool that just scans and updates all drivers so that I don't have to go through the long process of doing every single one individually).

    My network card is one of those old Intel Centrino cards, so I can go to Intel see if there's a driver update. The Intel Driver Update Utility should detect if it needs one. That being said, I just recently redid this system, and the network adapter should be only be up to one version behind if at all.

    My main fear is that perhaps one of the Windows 10 Privacy tools that I use on my system (many of which are listed here) may have messed with something that shouldn't be messed with.

    If I redo my system again I'm considering just not using those anymore. I'm already using the LTSB version which roots out some of the bloat and nonsense as it is. The privacy tools are for the paranoid but they appear to trade system stability for the result.
      My Computer

  5. Posts : 22
    Windows 10
    Thread Starter

    Well, the utility didn't find any update. I'm gonna try reinstalling the adapter.

    The driver for mine is here: Download Intel® PROSet/Wireless Software and Drivers for Intel® Centrino® Advanced-N 6230

    This computer is really old. They don't even make a version of this driver intended for Windows 10 and this computer came shipped with 7.

    I really don't think this is going to be the issue though, because the ethernet was having the same problem and it's a totally different driver. See here:

    It's really getting to be about time for me to get a new computer, honestly.
      My Computer

  6. Posts : 22
    Windows 10
    Thread Starter

    Confirmed - it's not the drivers. Reinstallation of network adapters/drivers didn't resolve anything.
      My Computer

  7. f14tomcat's Avatar
    Posts : 55,592
    Multi-boot Windows 10/11 - RTM, RP, Beta, and Insider

    AlexanderM13 said:
    Confirmed - it's not the drivers. Reinstallation of network adapters/drivers didn't resolve anything.
    Worth a shot. Sorry that wasn't it.
      My Computers

  8. Samuria's Avatar
    Posts : 6,698
    windows 10

    Make and model of router you wireless card is now old n type modern routers are AC. If there are no driver's for ten there could be a driver problem. How do you connect to Wi-Fi Intel normally has its own software which turns off Windows connection. Are other PC's using n or AC type connection
      My Computer

  9. Posts : 22
    Windows 10
    Thread Starter

    The router is AC-capable (ASUS RT-AC66R flashed with AsusWRT-Merlin firmware), but I have it configured to use N-Only as no devices on the network support AC anyway.

    The not having Windows 10 version would make sense to me IF this happened with Windows 10 before. But I was using Windows 10 with this adapter just fine since Windows 10 released, so that wouldn't make much sense in this case.

    The only thing that's different than my last install is that I used more of those privacy tools. I'm considering stopping doing that though, as it seems to mess with too many system settings and services, which has caused random bugs and made troubleshooting difficult.

    Overall though, yeah the system is from 2011 and none of it's hardware was made with Windows 10 in mind, naturally. Windows 8 wasn't even out yet back then. It's overall just time for a new computer as it can't really keep up with any modern games anyway - I've just been using the very latest software, OS, and drivers in attempt to squeeze every last bit of performance out of it possible. It actually runs Overwatch and other games on an Nvidia 560M, which of course is way below the listed minimul requirements for those games. Not to mention I do video rendering and stuff on this system and have for years...

    I think some issues might just be spawning from hardware wear-and-tear because I've been using this laptop nonstop almost 24/7 for the last 7 years. Perhaps I've squeezed just about every ounce of life there is in the hardware.
      My Computer

  10. Posts : 22
    Windows 10
    Thread Starter

    I'm just gonna reinstall Windows.

    This time I'll still use my HOSTS file because that should be able to be safely used to block things without causing any problems, but I won't tinker with services,registry keys, and group policy anymore (except disabling OneDrive).

    I'm almost certain it has to be one of the privacy tools, as the way they work is by simplifying the process of deleting services, disabling services, changing group policy settings, and modifications to the registry. I figure too much of these kinds of changes can start to cause "general weirdness" in the system, as it's just too heavily modified from it's intended stock settings.

    The hosts should block most telemetry and the likes anyway, even though some have said that some Windows processes ignore the hosts file.

    But all in all I figure I prefer to have a stable system than an unstable one all for the sake of my tinfoil hat. I'm the kinda person that needs to learn to stop being paranoid and stop trying to fix things that aren't broken, I guess.

    Well, I plan to have a seperate Linux system for communications and browsing anyway - which are the main things I'm concerned with being eavesdropped on. I don't really care if the NSA wants to watch me play games or something - enjoy.

    I just have a hard time not fiddling with things. The last time I was here it was because I actually deleted the file association for ".exe" from the registry and no programs could run anymore, all because I was trying to fix a minor GUI nuisance.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:58.
Find Us

Windows 10 Forums