1.    16 Aug 2017 #1
    Join Date : Sep 2016
    Posts : 16
    Win 10

    Invalid Argument


    HI guys

    Ive got an issue with KODI and windows 10.

    Everything was A ok until a couple weeks ago when i started getting Invalid Argument VIA smb and a shared folder.

    Basically, everytime i try to access the shared folder i get the error from any device.

    So far ive tried :

    Running windows 7 (worked)
    Re-formatting and installing win 10, worked until yesterday when updates were installed. Updates were :
    KB4034674
    KB4034662
    KB4022405
    KB4035543
    KB890830
    & some driver updates.

    Can anyone help me out as this is my main media server.

    Cheers
      My ComputerSystem Spec
  2.    16 Aug 2017 #2
    Join Date : May 2015
    Central IL
    Posts : 4,232
    Mac OS Sierra

    If it is in Kodi, that is a Kodi issue, not a Windows problem. Kodi has had issues with Samba for a very long time. There is an ongoing thread in their forums about breaking their own software.
      My ComputerSystem Spec
  3.    16 Aug 2017 #3
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,451
    windows 10

    Are you running it as a stanalone program or as an app from the app store?
      My ComputerSystem Spec
  4.    16 Aug 2017 #4
    Join Date : May 2015
    Central IL
    Posts : 4,232
    Mac OS Sierra

    Quote Originally Posted by Samuria View Post
    Are you running it as a stanalone program or as an app from the app store?
    It does not matter where it came from, the fact is that the Kodi Foundation has known about this problem for a very long time and will not fix it.
      My ComputerSystem Spec
  5.    17 Aug 2017 #5
    Join Date : Sep 2016
    Posts : 16
    Win 10
    Thread Starter

    I've found the issue and it was with Windows, hence the post here.

    The updates block which ever service smb uses in the windows firewall. Allowed it through and it's all good again
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Invalid registry
Hi Can anyone offer advice as to the message I get when trying to open photo from desktop, only just happened? Thanks for looking 111795
General Support
Solved E:\ The directory name is invalid
I am running Windows 10. I had a USB stick in the computer. After an update-restart, I ejected the USB drive, and now my computer is slow after idling and there was a nagging message that asserts itself. First it was something about what do you...
General Support
Invalid MS-DOS
Ive just done an update, and i can no longer delete anything or move anything on my desktop. So if i wanted to tidy up my desktop and put shortcuts into a folder i can no longer do this. I can no longer delete anything either. The message that comes...
General Support
Invalid MS-DOS Function
Hello, Could somebody please help, I have various files throughout my hard drive which error "Invalid MS-DOS Function" if I try and move or delete them however they "work" normally if I try and use them. I ran a check disk which returned no...
General Support
Solved Cortana/Windows Search Issue: default directory, crumb argument error?
I'd like to be able to search for the term "maxthon" and have the shortcut I keep in my Links folder (Users > Coaxsist > Links) show up as the first result so that I may hit return to select that result, follow the shortcut and run the program. This...
Performance & Maintenance
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:18.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums