1.    15 Aug 2017 #1
    Join Date : Aug 2017
    Posts : 3
    Windows 10

    Ethernet connection recognized for 1 second every 30 seconds


    hi all and thanks for reading...

    windows 10 machine, up to date, wireless is fine, though ethernet says disconnected when it is connected, and every 25-30 seconds the ethernet connection flashes 'identifying' for 1 second then goes back to disconnected. it's a Dell Inspiron 24, with a Realtek PCIe GBE Family Controller installed, and drivers up to most up to date available (June 2017). Windows 10 all up to date. have tried the same ethernet connection on another machine and it is fine there. Something about this specific machine. wireless is ok so I can still post here thankfully!


    Any guidance is very gratefully received...
      My ComputerSystem Spec
  2.    17 Aug 2017 #2
    Join Date : Jan 2014
    Central West NSW Australia
    Posts : 803
    7 and 10 on various machines

    Hello and welcome chriswin mate have you tried the dell support site for the Ethernet driver (LAN) as I never fully rely on Windows updates either in 10 or 7 to update drivers from specific manufacturers.
    Drivers Downloads | Dell Australia
    I would be inclined to use the detect product option and then look for a LAN driver.

    Having said that I have found the Dell support site rather convoluted but just persist and contact them if you have to.
      My ComputerSystem Spec
  3.    03 Sep 2017 #3
    Join Date : Aug 2017
    Posts : 3
    Windows 10
    Thread Starter

    hey thanks a lot ICIT2LOL for the suggestion - I like to think I have all drivers up to date - have done so through dell rather than windows. thanks for reading!
      My ComputerSystem Spec
  4.    03 Sep 2017 #4
    Join Date : Jan 2014
    Central West NSW Australia
    Posts : 803
    7 and 10 on various machines

    No problems mate it is just that for many years I think (and they still do) many think that the Windows feature is the best thing and to some extent 10 now is fairly good - but I still prefer it from the horses mouth as it were


    Edit: I should have added mate if the machine is out of warranty then maybe it would be an idea to fit a PCI Ethernet card they are really inexpensive and really easy to fit and I don't know how you feel about that but if you want my opinion that is what I would do and I rally do like TP-Link stuff see this
    TP-LINK - Gigabit Ethernet PCI Network Adapter Card 101000 Mbps - TG-3269 - Newegg.com as you can see not expensive and there are plenty of other brands in the Newegg site including quite a few Intel ones if you just Google Newegg and search for Ethernet cards
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
4g lte mobile broadband usb-dongle recognized as a ethernet cable
4g lte mobile broadband usb-dongle recognized as a ethernet cable. can anyone provide support. ill gladly answer follow-up q's
Network and Sharing
New Ethernet Cabling, no connection
Hi, I just had ethernet cabling done in my house from the router under the floorboards into my room which evidently doesn't work. Stupidly I didn't get the guy who did the job to check it and I don't want to call him out if it's just a software...
Network and Sharing
Ethernet connection question
With Windows 7, There was a place to check if you wanted the computer to search for a Ethernt connection before connecting to wifi. I can't find that in W10, and am having difficulties getting the Ethernet connection to work. I am starting a...
Network and Sharing
Belkin USB Control Center drops connection after 5 seconds
Hi. I have TWO Dell Inspiron 15 laptops that are set up just about the same regarding hardware and software. I also have a HP G7 laptop. I have a Belkin AC1200FE router that has a USB port to plug in a printer so I can print from any computer on my...
Network and Sharing
Solved Device connection sound is heard every 15-20 seconds
I have a very annoying thing that seems to have popped up in the last 2 days or so. I installed Win 10 on my custom built computer about a week ago and it has been working just fine. Then about two days ago I started getting the sound that it...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:27.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums