1.    10 Aug 2017 #1
    Join Date : Aug 2015
    Posts : 3
    Windows 10 pro

    Equivalent or alternative to the "netdiag" command for Win10


    the "netdiag" command is not available in Windows 10. Is there any equivalent available?
      My ComputerSystem Spec
  2.    10 Aug 2017 #2
    Join Date : Aug 2016
    S/E England
    Posts : 4,520
    10 Home x64 (1709) (10 Pro on 2nd pc)

    Apparently netdiag was last seen in Windows XP. Since then we've had the Troubleshooters and netsh....
    Windows Vista includes the Network Diagnostics Framework (NDF), a set of technologies and guidelines that allows a collection of troubleshooting tools to assist users in diagnosing, and where possible, automatically correcting networking problems.
    https://technet.microsoft.com/en-us/.../ff625276.aspx
      My ComputersSystem Spec
  3.    10 Aug 2017 #3
    Join Date : May 2015
    Central IL
    Posts : 4,250
    Mac OS Sierra

    There are other solutions available. What are you trying to fix or look at?
      My ComputerSystem Spec
  4.    11 Aug 2017 #4
    Join Date : Aug 2015
    Posts : 3
    Windows 10 pro
    Thread Starter

    Thank you Bree & bro67. In answer to the latter's question, the issue is that my Synology NAS does not show "network" in Windows explorer. Neither does it when I search by name or IP address. The same when I try to map it to a network drive from Windows explorer. As a workaround, I was able to use the map network feature from within the Synology set of commands. As I had tried what seemed to me to be all the relevant windows "commands" with no obvious problems being shown, I thought the netdiag command might reveal something. So this is not an urgent issue as my network is functional

    I should add that I am running Windows 10 (most recent update) using static IP addresses with homegroup and netbios over TCP/IP disabled so that the PCs on my network are connected through WSD discovery. I arrived at this point through a rather tortuous, lengthy and frustrating process of searching the internet and trying various suggestions to fix what appears still to be a widespread Windows 10 problem where network devices do not show up on a LAN or do so erratically with no apparent rhyme or reason.
      My ComputerSystem Spec
  5.    11 Aug 2017 #5
    Join Date : May 2015
    Central IL
    Posts : 4,250
    Mac OS Sierra

    Then make sure you keep smbv1 enabled in Windows Features and disable smbv1 with the following two items in Command Terminal. sc.exe config lanmanworkstation depend= bowser/mrxsmb20/nsi
    sc.exe config mrxsmb10 start= disabled

    Make sure that the Computer Browser Service is changed to automatic. On the NAS, in File Services, make sure that in SMB, that you do not have it checked as Master Browser and in advance, that SMB2 is lowest, SMB3 is highest.

    I have a DS216+2 and only time I had issues was dealing with the problems that Microsoft threw out there when they told everyone to disable SMBv1 from Windows Features, which meant using the IP.
    Last edited by bro67; 12 Aug 2017 at 14:34.
      My ComputerSystem Spec
  6.    12 Aug 2017 #6
    Join Date : Aug 2015
    Posts : 3
    Windows 10 pro
    Thread Starter

    The SMB 1.0/CIFS windows feature is enabled and I'm reasonably sure always has been. Could you please confirm I need to use Power Shell with your instruction for then disabling it i.e. to past into the text that starts with "sc.exe ....." I have to admit to sticking with Command Prompt thus far with WIndows 10!

    On SMB and the the NAS - it is presently set to SMB3 max, SMB1 min. I assume I should not change the minimum to 2 until after disabling SMB1 on the PCs.

    On the the Master Browser, I should explain that my path to "fixing" this issue seemed to consist more of a series of workarounds than what I would consider real fixes. One of the earlier such "fixes" that produced an improvement related to Master Browser voting. The problem would either re-appear or get worse when the Master Browser function was voted off one device onto another. After a series of experiments, it seemed clear that having the NAS as Master Browser resulted in a stable network listing on all devices. Consequently, I disabled the Computer Browser service on the two PCs and two laptops on the network in order to prevent any changes. Probably not the most elegant way to bring that about, but it was simple and worked!

    As far as I can tell, it was disabling the Computer Browser service that caused network discovery to change from Netbios to WSD. And that, along with a number of other suggested fixes I had come across, was what set me on the course to disabling TCP/IP on the network cards.

    Thanks again for for responding to my posts.
      My ComputerSystem Spec
  7.    12 Aug 2017 #7
    Join Date : May 2015
    Central IL
    Posts : 4,250
    Mac OS Sierra

    Just use Command Terminal for those two entries and leave SMB1 checked in features, along with making the change to Computer Browser. Otherwise you will still have a broken OS. It is bad enough that people are getting upset that the latest ISO from Microsoft is no longer including IE11 installed and you have to do that on your own if you want to use it.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Context menu now has "Powershell" instead of "Command Prompt"
So I updated to the CU over a week ago, and I noticed an odd change. The "Open command prompt here" option in the shift+right-click context menu has been replaced by "Open Windows Powershell here" instead. Powershell does not work with the apps I...
General Support
Command Line Option For Changing "size of text, apps" etc.
I currently use a macro to change the size of text, apps, and other items from 150% to 100% and back to 150%. When at 100% I can run Sysinternals' "BGinfo.exe" - Background Info - to update the info on the desktop's background. BGinfo.exe works...
Customization
CmdPrompt "timeout" from Win7 replaced by "sleep" in Win10?
In DOS batch scripts under Windows 7 there was a function "timeout" which stops the execution for n seconds. This command seems to be replaced by "sleep" in DOS batch scripts under Win10. Is this true? Peter
General Support
Solved Excel error when opening documents "problem sending the command..."
The full error reads: There was a problem sending the command to the program. This is actually an older Excel problem that appears to have returned with my upgrading to Windows 10. This error is presented whenever I try to open any excel file...
Software and Apps
Adding "ctrl+F" command to Internet Explorer context menu
Greetings all. How do I add the keyboard shortcut command "ctrl+F" to the Internet Explorer context menu? I know where I need to go in the registry to add an item to the context menu of Internet Explorer, but I don't know how to add a keyboard...
Customization
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:57.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums