1.    27 Jun 2017 #1
    Join Date : Jun 2017
    Posts : 5
    Windows 10

    Relaktek PCIe GBE Family Controller randomly disconnects


    I am using a Realtek PCIe GBE Family Controller on my motherboard for ethernet, and it randomly, with no rhyme or reason, disconnects from the network, at least once every few hours. It works again when I disable and reenable it, but it's extremely aggravating whenever it happens. I've tried using multiple versions of the driver, and I have tried disabling any sort of "Green" and "Energy Efficient" features (including "Advanced EEE"). Nothing has changed what's going on. I'm currently running 10.16.323.2017, but I've also run 10.1.505.2015 and 9.1.406.2015 versions of the driver.

    I've also unchecked "Allow the computer to turn off this device to save power."
      My ComputerSystem Spec
  2.    27 Jun 2017 #2
    Join Date : May 2015
    Central IL
    Posts : 4,254
    Mac OS Sierra

    What Gateway are you using (model and manufacture)? Also have you tried changing cables between the computer and gateway, different Ethernet Port, remove hardware and driver in Device Manager and let windows load default? Green/Energy needs to be disabled, since it will cause the gateway to not send a new lease for that IP related to the MAC if your computer goes to sleep or you leave it powered off for a long time.
      My ComputerSystem Spec
  3.    27 Jun 2017 #3
    Join Date : Jun 2017
    Posts : 5
    Windows 10
    Thread Starter

    Quote Originally Posted by bro67 View Post
    What Gateway are you using (model and manufacture)? Also have you tried changing cables between the computer and gateway, different Ethernet Port, remove hardware and driver in Device Manager and let windows load default? Green/Energy needs to be disabled, since it will cause the gateway to not send a new lease for that IP related to the MAC if your computer goes to sleep or you leave it powered off for a long time.
    I'm using an ASUS gateway. I've removed the driver and reinstalled it before. The cable works fine with other hardware --- in fact, all the hardware works perfectly fine under Linux. It's only when running Windows that this problem occurs.

    And the Green/Energy-Efficient features have been disabled the whole time, as well as power mangement features. And I've only got one ethernet port on my MSI B350 motherboard.
      My ComputerSystem Spec
  4.    27 Jun 2017 #4
    Join Date : May 2015
    Central IL
    Posts : 4,254
    Mac OS Sierra

    What is the model of your ASUS gateway? The cable can be culprit with Windows. The Windows drivers are a bit finicky. That is why you have to rule out everything. I would check on the MSI support forum to see if anyone else is having the same issue with that motherboard and Windows 10.
      My ComputerSystem Spec
  5.    27 Jun 2017 #5
    Join Date : Jun 2017
    Posts : 5
    Windows 10
    Thread Starter

    Quote Originally Posted by bro67 View Post
    What is the model of your ASUS gateway? The cable can be culprit with Windows. The Windows drivers are a bit finicky. That is why you have to rule out everything. I would check on the MSI support forum to see if anyone else is having the same issue with that motherboard and Windows 10.
    It's an ASUS RT-AC1200. I've also used a few cables.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
realtek pcie gbe family controller win10 can't connect after upgrade
hi i'm using genune windows 10 home(not pirated version) my default version of realtek pcie gbe family controller is 9.1.401.2015 .,i upgraded it to 10.8.311.2016 awhile ago after that i can't use lan on my laptop, when i rollback to my default...
Network and Sharing
Ethernet connection on USB 3.0 randomly disconnects
Long time with this issue and very frustrated My laptop is a Dell XPS 13 running Windows 10 64-bit. I just upgraded from Windows 8 hoping that would solve my issue but it did not. I even re-imaged my PC and the issue remained so I think it must be...
Network and Sharing
WOL realtek pcie gbe family controller
So I want to use wakeup on lan. I have searched google for answers of how to do this. I have done the power options on the ethernet adapter in device manager and went into BIOS to allow WOL (I couldn't find the option). I am using this app called...
Network and Sharing
Wireless Disconnects Randomly
So i have been having a queer issue with my wireless adapter, it is a NETGEAR A6200 WiFi Adapter. After downloading windows 10 i re downloaded drivers and updated them just in case but i am having a reoccurring issue of the adapter itself being shut...
Network and Sharing
Wi-Fi Disconnects Randomly (Not directly related to 10)
So, firstly I would like to say that I'm sure most of you have at least heard of this issue if you have never directly dealt with it yourself. This did not just start happening after I upgraded to Windows 10; in fact, it followed me from 7 to 8 to...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:04.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums