Windows 10: "Ethernet" doesn't have a valid ip configuration

Page 1 of 2 12 LastLast
  1.    26 Jun 2017 #1

    "Ethernet" doesn't have a valid ip configuration


    So i decided to move on wired network connection for some reason and i can't make it work. To sum it up, i have a router that has 2 ports which offer 10mbps apparently and other 2 with 100mbps. I tried all 4 with a laptop and they work as expected ( same cable used ). Now, the same router, same ports, same cable, the ports that offer 100mbps won't be recognized by my pc, the ones with 10mbps will be. I have a Z270 Tomahawk mobo with Windows 10 Pro 64-bit installed on a SSD. I tried a bunch of stuff to fix the issue, including resetting the router, the network settings, the UEFI, reinstalling network drivers, none worked.
    At this point i don't know what to do, i'm sticked with my wireless adapter and i can't game on it, only connectivity issues in games. Hopefully i'll find the answer here, thanks.
      My ComputerSystem Spec

  2.    26 Jun 2017 #2

    Welcome to the forum. With a network cable plugged in open a CMD prompt then type

    Ipconfig /all

    Post results
      My ComputerSystem Spec

  3.    26 Jun 2017 #3

    Click image for larger version. 

Name:	Screenshot (13).png 
Views:	4 
Size:	235.5 KB 
ID:	141314
      My ComputerSystem Spec

  4.    26 Jun 2017 #4

    You dont get an ip you get default one starting 169 if its a known good cable and router port its either a faulty network card or its not getting an ip as its no negogiating the correct speed. Open a admin cmd prompt then type these cmds after reboot and try again

    netsh advfirewall reset
    netsh advfirewall set allprofiles state ON

    netsh winsock reset catalog
    netsh int ip reset c:\resetlog.txt

    netsh int ipv4 reset
    netsh int ipv6 reset
      My ComputerSystem Spec

  5.    26 Jun 2017 #5

    Hello and thanks for your response,

    I did every command above and, unfortunately, none solved the issue, nada. I repeat myself, the same cable worked in the same router port at 100mbps, with my pc it doesnt want ti cooperate. I'm going to try to run linux, see if it's a hardware issue or not.
    I also want to point out that i dont have any network card.

    I also want to add that, at some point, during this day, after plugging in the cable to my laptop, unplugging from router, replugging in different ports etc, i managed to make it run on my computer, i can't remember the exact procedure as i did everything randomly, but after a restart everything goes back to as it was.
      My ComputerSystem Spec

  6.    26 Jun 2017 #6

    Ok, so, i ran linux and, at first, it didnt want to connect, then i manually added the ip, netmask and gateway and it did connect, running however only at 10mbps, tho with the same cable, the same router port i ran at 100mbps on my laptop. Imgur: The most awesome images on the Internet
      My ComputerSystem Spec

  7.    26 Jun 2017 #7

    What setting have you got for the network often setting it to full duplex will give this problem if its set to auto speed try setting to 100 meg
      My ComputerSystem Spec

  8.    26 Jun 2017 #8

    Hello and thanks for your response,
    I tried twice actually to run it at custom speed, 100mbps full duplex. Then, i re-enabled the network connection but it was still having issues. I even went to the UEFI and enabled from there, in the NIC settings, ipv4 and ipv6 support and custom 100mbps full duplex setting. Still no solve.
      My ComputerSystem Spec

  9.    26 Jun 2017 #9

    Full duplex will casue it youdont want that as it sends and recieves both at the same time most routers cant keep up with it
      My ComputerSystem Spec

  10.    26 Jun 2017 #10

    Ok, i'll proceed in the morning, as soon as i wake up, thanks.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
I did a clean install of windows 10 after updating killed my Ethernet connection. I am still able to use a usb wifi on my desktop. I have tried so many things that I could find online and nothing has worked. I would love some help with this ...
Dear Tenforums users, I have recently encountered some problems wth my relatively new Lenovo IdeaPad laptop; whenever I try to connect to the internet using ethernet it tells me that "Ethernet doesn't have a valid IP configuration" I have the...
I have looked at almost every post on the forum and have tried different steps to correct my issue with no luck. I have a wired connection to my modem and its green light on both ends of the connection. In Network and Sharing it says Unidentified...
So I have been able to use my pc fine until the internet loses connection, so I troubleshoot and It says: The default gateway is not available, I had this error a few days ago and managed to fix it by setting my ip to obtain automatically, I tried...
Hello. I have been trying to fix this for the last 4-5 hours with no luck. I swear the computer was working fine just a few days ago. This evening, there's a yellow warning triangle above my internet icon. Setup: Centurylink DSL connected...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:49.
Find Us