Windows 10: Creators Update destroyed Network Discovery on wired LAN

Page 6 of 7 FirstFirst ... 4567 LastLast
  1.    14 Sep 2017 #51

    Update from my post of 7 hours ago, I can't say for sure they weren't missing after I forced my router to be the Master Browser, but now my network printer is missing. This is a shared printer that was always available before this trouble began. I don't use the printer over the network very often, but it is essential for my daughter, who is in college, to be able to access it. I hope it will remain available to her from the programs she prints with. I may have to try disabling the Master Browser to see if that will bring the printer back, or at least revert to letting my computer be the Master Browser.
      My ComputerSystem Spec

  2.    15 Sep 2017 #52

    Router with USB memory stick fixed problem


    Stuck old USB memory stick in my wireless router and network discovery started working on multiple PCs.
      My ComputerSystem Spec


  3. Posts : 82
    Win Pro 10x64 1709 16299.19
       15 Sep 2017 #53

    Sounds weird. Was this USB empty?
      My ComputerSystem Spec

  4.    15 Sep 2017 #54

    Sounds more like a monitor or video card thing. Perhaps your Windows or video card config switched to single monitor mode and you might need to activate the second monitor again. From the desktop, right click in an empty space and choose "Display Settings." That'll bring up the display dialog. Or you might need to go to your video card software. If it only shows one monitor, one is unplugged or completely dead. (Happened to me once!) If it does show "Monitor1 and Monitor2," make sure both are activated. If this doesn't help, call back.
      My ComputerSystem Spec

  5.    15 Sep 2017 #55

    ozstar said: View Post
    Sounds weird. Was this USB empty?
    Umm others in this same post stated the same thing. I just followed their recommendation and it worked for me.

    USB drive was not empty. Had a few files.
      My ComputerSystem Spec

  6.    15 Sep 2017 #56

    LLin La said: View Post
    Sounds more like a monitor or video card thing. Perhaps your Windows or video card config switched to single monitor mode and you might need to activate the second monitor again. From the desktop, right click in an empty space and choose "Display Settings." That'll bring up the display dialog. Or you might need to go to your video card software. If it only shows one monitor, one is unplugged or completely dead. (Happened to me once!) If it does show "Monitor1 and Monitor2," make sure both are activated. If this doesn't help, call back.
    Doubt it. I have a number of high end Dell and HP office PCs with Windows 10 in a simple network at my house. No server involved. Been using them for a long time. Never had a network issue until the latest round of updates.
      My ComputerSystem Spec

  7.    02 Jan 2018 #57

    I know this is an old thread, but I am still having this issue. I'm on 1709 build now, Homegroup works fine, can see all computers, but I can't see them on the network again. I can access them in the address bar by typing the computer name. I tried stopping and stopping the Service that was mentioned, but that did nothing. Any resolution to this (And its the Hardwired computer that is giving the issues, it doesn't even see itself on the network)
      My ComputerSystem Spec

  •    02 Jan 2018 #58

    Hey sparky1996,
    I didn't read back to see what service you're referring to, but try starting these two .... Function Discovery Provider Host and Function Discovery Resource Publication. If starting them gets then PCs to show up in File Explorer > Network, then you might want to change their startup type to automatic.

    Note: Since you can access them by \\COMPUTER_NAME ... you could just map network drive - Map Network Drive in Windows 10 Network Sharing Tutorials
      My ComputersSystem Spec

  •    03 Jan 2018 #59

    No Change all these months . . .


    Eagle51, the problem for me anyway is not even being able to map the drive. It doesn't see it! I have just "auto'ed" the two "Function" services (they WERE on Manual but they were actually running anyway), so I'll see if there's any change but I doubt it. I have been through reinstalling SMB v1, doing the Master Browser switch and just about everything suggested in this forum.

    To reiterate since this is an older thread, I was successfully running Freenas and Win10 Pro communicating back and forth as far as shared folders and such. Sometime last summer that went away. I had upgraded Freenas about the same time the Win Update occurred. Over a month, I rolled back Freenas and Win and THOUGHT I had blocked Win Update. It was working again but I goofed and it automatically updated (Win) and everything went away again. Since then, I've been hoping either Redmond or Freenas would figure it out. Nah! Microsoft denies there is a problem and nothing they offer solves anything.

    I have found a workaround although a little inconvenient. FileZilla FTP sees the Freenas directories from my Win10 machine so I transfer files back and forth that way. I've given up on a Microsoft correction but one would be nice!
      My ComputerSystem Spec

  •    03 Jan 2018 #60

    Hey LLin La,
    I'm not that familiar with FreeNas, but you should check it's config to see what Samba version it's using. I think it has like a Min & Max Samba version it can use. Basically, you need to try and match what Samba versions FreeNas and Win10 are using. As far as SMBv1 on Win10, you probably only need the SMBv1 client (if at all).
      My ComputersSystem Spec


  •  
    Page 6 of 7 FirstFirst ... 4567 LastLast

    Related Threads
    Hi, I am currently struggling with the following problem: I have a Windows 10 Pro computer that has wired internet connection to the office network. And on top of that I need the computer to ALSO connect to my Sonoff Relay (ESP8266 Soft...
    Iím running Windows 10 Pro 64 bit, fully patched with 16Gb RAM; I performed a full wipe clean install just 25 days ago. Other than this issue, everything is working perfectly on this computer. This system is not on a domain, and there is no group...
    For a long time I have had a very stable wired network of four PCs (and a fifth if I choose to add it) until the recent Win 10 update. Suddenly my network and workgroup have collapsed. One exception is my wife's PC, which I can see from my main...
    I just installed (yesterday) the latest W10 update that installed Version 1511 (OS Build 10586.3) and my home network consisting of five W10 PC's has been "destroyed." I do not use Homegroup. Instead, I have always set up all the drives/folders as...
    Network Discovery not working ? in Network and Sharing
    Hi Forum :) I am facing a problem that my PC running Windows 10 cant see other PC's/Devices on my network. Idk. if it have something to do with i cant make/join a homegroup. I was told to remove a file in...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    © Designer Media Ltd
    All times are GMT -5. The time now is 02:24.
    Find Us