Creators Update destroyed Network Discovery on wired LAN

Page 5 of 7 FirstFirst ... 34567 LastLast

  1. Posts : 5
    Windows 10
       #41

    Windows 10 needs a lot more than better interface and prettier design. User experience will not be significantly improved unless they improve the system as a whole. I mean, when you have to learn how to remove duplicate files, it says something. I am getting Vista flashbacks. Not to mention my boosting adventures when I tried to become a gaming streamer. At least Macs are easier to handle this way - when they break, they really break, factory reset and throwing it in the trash are the best and only solutions. Windows makes you want to keep it safe, fix it. And Windows 10 is like an abusive partner to me in this regard.
    I desperately hope for something more substantial.

      My Computer


  2. Posts : 7
    Windows 10 Pro
       #42

    Disable the Master Browser

    Good news for now! I just ran across this article by googling "Master Browser" and so far so good. I can see my Freenas folders again! A quick registry change and rebooting (bringing up Freenas first) then Win10 switched it. If it stays, we'll see. I have saved the registry key if I need to re-apply it as well as the pre-"Master Browser" key if I have to revert.
      My Computer


  3. Posts : 11
    Windows 10
    Thread Starter
       #43

    Craig Fergusson said:
    Windows 10 needs a lot more than better interface and prettier design. . .
    I desperately hope for something more substantial.
    The only fix that worked for me was to revert to Windows 7. My network is restored to me. My legacy software will install and run. And my taskbar isn't clogged by Cortana. Win-Win.
      My Computer


  4. Posts : 7
    Windows 10 Pro
       #44

    Follow up: I read the posts on ditching the Realtek (or other brand) NICs and purchased two Intel NICs (matching pair for my two boxes! See below for results) As I reported, the fix linked above worked. I did everything I knew how to block Windows Update from giving me the Creator's Edition again. Sadly, I got a notice yesterday that "an update had been installed!" Yep, they snuck 1703 back on me and I'm back where I started. I am showing the Freenas (and other workstations) in the Network but all the folders are empty. But I can ping, IP Scanner see the IP, router sees it . . . everything but Windows!!! For those interested in alternate network connection substitute, I did try something else. I enabled FTP on the server and then installed Filezilla on my Win10 box. Last night I successfully transferred 26GB of data from Freenas back to my Windows machine without a hitch. I was averaging 20MB/s with 5 simultaneous connections with my new Intel NICs. In the greater world, I don't know if that's good or bad but I was only getting KB/s with my replaced cards with 2 simultaneous connections, would show a few errors mainly because of watchdog errors which meant reboots. As I said, the Intel cards were much faster, not one error(!) and I'm pleased with everyone but Microsoft! My experience with Win10Pro has been good up until the Creator's Update. Don't want to step back to 7. And I know it is inconvenient to not be able to drag and drop with a Samba connection but at least I can operate until Microsoft gets their act together. (Like that's ever going to happen!)
      My Computer

  5. Stigg's Avatar
    Posts : 430
    Windows 10 Pro
       #45

    I thought I would re-visit this thread to see if there has been a fix found yet.
    So, is disabling the Master Browser the only solution?
      My Computer


  6. Posts : 7
    Windows 10 Pro
       #46

    Well, MB disable was working with the edit. Now, back to same old . . . should've disabled Update!
      My Computer

  7. Stigg's Avatar
    Posts : 430
    Windows 10 Pro
       #47

    LLin La said:
    Well, MB disable was working with the edit. Now, back to same old . . . should've disabled Update!
    Hmm! So, it only fixed it temporarily. That's strange.
      My Computer


  8. Posts : 2
    Windows 10 Pro
       #48

    Strangely, this problem didn't seem to affect me after the Creators' Update was first installed (Win 10 Pro). However, yesterday, the "2017-09 Cumulative Update for Windows 10 Version 1703 for x64-based Systems (KB4038788)" was installed, and then I could only see one computer on the network from my desktop computer. I couldn't even see the desktop computer I was trying to view the network on, even though it is a wired connection to the router. I could only see my Surface 3 tablet over WiFi. Even that disappeared after I finished updating the Surface. Using the workaround of making the router the Master Browser did the trick, for now. I can see everything I should see from both computers now, but who knows how long that will last.

    Incidentally, I know an IT guy at the local public library, who says they have stuck with Windows 7, rather than upgrading to 10, precisely because he considers Windows 10 networking to be terrible. With what I've had to put up with on just my little home network, I'd have to agree, and I've worked with computers for 50 years, 40 of them as part of my job before I retired.
      My Computer


  9. Posts : 7
    Windows 10 Pro
       #49

    No problem . . .


    I've had the opposite effect with Windows 10 from its inception. I've been 100% pleased with it (except for the Metro Desktop!). I reverted back to the familiar Win 7 with Classic Shell. But whether it was officially Creators Update or the update you mentioned, it's been annoying (but surmountable) to this point. For convenience's sake, I just wish it had remained (networking) as it was.
      My Computer


  10. Posts : 145
    Win Pro 10x64 1909 18363.720 and vs 2004
       #50

    Hi,


    This morning Sept 15 after the update to Win 10 1703 x64, 2 computers had a black screen when starting.


    Came to the blue Windows Logo then went black but with a moveable cursor.

    I closed them down and restarted them. One has come up okay whilst the other is still the same.

    This one is a Dell T7500 Precision Desktop.

    I have unattached all USB boxes to it, but still no go.

    Where do I go from here?

    EDIT: Just rebooted and tried to get into safe mode with F8 but still went to black with cursor although this time heard the opening music.
      My Computer


 
Page 5 of 7 FirstFirst ... 34567 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 17:30.
Find Us




Windows 10 Forums