Page 3 of 6 FirstFirst 12345 ... LastLast
  1.    05 Aug 2017 #21
    Join Date : May 2015
    Central IL
    Posts : 4,221
    Mac OS Sierra

    I have given up on trying to figure out how to fix this mess that Microsoft has caused. I spent two days trying to fix their mistake with Network Discovery, that I just mapped our NAS shares that my wife needs on the desktop that I have to use for a genealogy program that the person who wrote it, only wrote a Windows version.
      My ComputerSystem Spec
  2.    05 Aug 2017 #22
    Join Date : May 2015
    Central IL
    Posts : 4,221
    Mac OS Sierra

    Quote Originally Posted by jetgraphics View Post
    Addendum: The latest scanner is advanced_ip_scanner.exe, not scanner25.exe.
    I also experienced another problem with Win10 CU (1703) - the inability to re-install my PVR software (Beyond TV) - even when using cmd.exe in administrator mode. I tried rolling back to an earlier version, and the bug remained. Ditto, for the network discovery / master browser bug. This effectively ended my tolerance for Win 10. I have since re-installed Win7 on all machines and my problems are no more.
    It looks like Snapstream no longer updates Beyond TV, because they have gotten into a bigger market with education, healthcare and government.

    Next PVR, Kodi or Plex would be your best choices. I use Plex for our HDHomerun tuner that we have for watching Sub-Channels and the Cubs playing on one of the locals that is only in HD with OTA.
      My ComputerSystem Spec
  3.    05 Aug 2017 #23
    Join Date : Aug 2017
    Posts : 1
    Windows

    Quote Originally Posted by Eagle51 View Post
    Until MS fixes the Master Browser issue with 1703(Creators Update), here are a couple of workarounds that should work.

    1. If you have a router that has a USB port (and a USB stick) - Shut down all PC's, insert USB stick in the router (may need to reboot router), then start the other PCs. This should make the router the Master Browser.

    2. If you have a pre 1703 PC (1607,win7,win8) on your network - Shut down all PC's, start the pre 1703 PC first, then the other PC's. This should make the pre 1703 PC the Master Browser.
    It worked for me.
    After weeks trying to solve the problem.
    Many thanks
      My ComputerSystem Spec
  4.    05 Aug 2017 #24
    Join Date : Jun 2017
    Posts : 11
    Windows 10
    Thread Starter

    Quote Originally Posted by FRiver View Post
    It worked for me.
    After weeks trying to solve the problem.
    Many thanks
    I tried #2, but it didn't work for long. After a day or so, started dropping computers from the list.
      My ComputerSystem Spec
  5.    05 Aug 2017 #25
    Join Date : Oct 2016
    Charlotte, NC
    Posts : 439
    Win10 Home x64 - 1709

    I tried #2, but it didn't work for long. After a day or so, started dropping computers from the list.
    If you haven't already, on your Win10 PCs try the following ...

    Windows Services > Computer Browser
    Stop if running
    Set Startup Type to Manual

    Regedit > HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters
    MaintainServerList = No
      My ComputersSystem Spec
  6.    06 Aug 2017 #26
    Join Date : May 2015
    Central IL
    Posts : 4,221
    Mac OS Sierra

    I have not seen one fix for how Microsoft found a way to hack their SMB to allow the discovery services under SMB1 to work with SMB 2 & 3. I just enabled SMB1 to see what would happen, since having to enter the IP of our NAS on the network was getting old. Everything is back in Explorer for those devices on the network that have shares available.

    As slow as Microsoft is in fixing the problems that they create to cause everyone headaches. I would suggest that if you do decide to enable SMB1 to fix shares not being there, then enable a Firewall rule to block any outside the network access. Do this at your own risk if you do not have a good Gateway, or continue to map with the IP of the device.
      My ComputerSystem Spec
  7.    06 Aug 2017 #27
    Join Date : Aug 2017
    Posts : 7
    Windows 10

    Like many here, I have one Windows 10 (1703 CU) computer that shows no other computers in the network other than itself. All other computers (mix of Win10 and Win7) show the others in the Windows Explorer Network, including the misbehaving computer.

    Running ipconfig /all on all computers reveals the one difference I can identify between the problematic laptop and all the rest. NetBIOS over tcpip on the wireless adapter on the laptop shows disabled. On all the other computers it is enabled.

    My Network contains the following machines (each with shared folders that need to be accessed by the others):
    - NAS box running Samba (this machine is configured as the local master browser and is elected as such)
    - Windows 10 wired desktop (version 1703 CU)
    - Windows 7 wired desktop
    - Windows 10 (pre 1703 version) wireless laptop
    - Windows 10 (version 1703 CU) wireless laptop - this is the problem machine

    I have tried everything to enable NetBIOS over tcpip on the problem machine. Checked this option in the network adapter WINS tab, modify registry key to set this option on this interface, run the PowerShell wmic nicconfig, performed a network reset and reconfigured, etc. After all of these, ipconfig /all continues to report that NetBIOS over tcpip remains disabled on this NIC.

    The problems I see on this laptop are the following:
    - Shows only itself in the Network
    - Can connect (non-persistent) to other Windows computers by name; e.g. \\servernane in Network address bar and these then show up in Quick Access until Explorer is closed or machine is rebooted
    - Cannot connect to NAS server other than through IP address; it can't find it by server name
    - Even though the laptop appears in the Network on all other machines, it is NOT accessible by any of them via clicking on the laptop in the Network or by attempting to access it by IP address. It can be pinged from all other computers.

    The bottom line is that NetBios over tcpip is the only difference and nothing I have tried will enable this service on the problematic laptop.

    Any ideas other than those I have tried?
      My ComputerSystem Spec
  8.    07 Aug 2017 #28
    Join Date : May 2015
    Central IL
    Posts : 4,221
    Mac OS Sierra

    Hoopster you have done everything that I have done and that is why I ended up just going back to enable SMBv1. Even Samba does not always work in a mixed environment, but Microsoft should have thought of the whole Samba/CIFS thing when SMBv2 rolled out, which is now becoming to the point that it is at its end of life and SMBv3 is where the NAS manufacturers are at for those that are on the higher end.

    I guess that we could just all resort to using FTP/SFTP if Microsoft cannot get their game together.

    I just went and tried a fix for Master Browser, because my Synology NAS is set to be it. Now Windows 10 is stating too many connections. I may just end up give up and reinstall fresh.
      My ComputerSystem Spec
  9.    07 Aug 2017 #29
    Join Date : Aug 2017
    Posts : 7
    Windows 10

    Quote Originally Posted by bro67 View Post
    I ended up just going back to enable SMBv1.
    Supposedly, both SMBv1 and SMBv2/3 are enabled on the laptop. The PowerShell Get samba config applet shows TRUE for SMBv2 but SMBv1 is blank even though I have explicitly set it to true via PowerShell, registry edits, enabling in NIC properties, etc. Other methods show SMBv1 as enabled.

    I do not think Samba on the unRAID NAS is in any way the issue; especially since all other computers can access it without issue and see all public shares. It does not appear that the NAS is limited to SMBv1. Most samba issues from the NAS side (excellent support and community for unRAID) seem to be related to Windows credentials and authentication issues that need to be cleaned up from the Windows side.

    I have set the NAS as the local master browser as it has an excellent utility for doing so and will report which machine is the master browser.

    Click image for larger version. 

Name:	unRAID locam master.png 
Views:	43 
Size:	11.8 KB 
ID:	147623

    A reinstall of Windows on the laptop may be in order (what a PITA). What frustrates me the most is that this was all working last week even though Win10 CU has been installed on the laptop for a couple of months. Unfortunately, I discovered that System Protection was off on that laptop so I cannot just do a System restore to a working config. It seems that Windows version updates frequently mess with such settings.
      My ComputerSystem Spec
  10.    07 Aug 2017 #30
    Join Date : May 2015
    Central IL
    Posts : 4,221
    Mac OS Sierra

    I finally found the solution. Big headache of trying to find it, but the breakdown is at [SOLVED] Disabling SMB1 stops domain authentication - Windows Forum - Spiceworks

    You are leaving smb1 enabled in Windows Features under Programs and Features, since the Computer Browser Service is attached to that (Why Microsoft could not see that issue and leave CB to not get removed out of Services, shows proof that we are smarter than the idiots in India). Then just enter the following commands to disable the smb1 bugger:

    To disable SMBv1 on the SMB client, run the following commands:

    sc.exe config lanmanworkstation depend= bowser/mrxsmb20/nsi
    sc.exe config mrxsmb10 start= disabled

    Yep, works like a charm, just make sure if you have a NAS, that it is not set to be the SMB Master Browser, or it will break Windows, unless you feel like fixing Windows to not be the Master Browser, which to me is too huge of a headache.
    Last edited by bro67; 09 Aug 2017 at 02:53.
      My ComputerSystem Spec

 
Page 3 of 6 FirstFirst 12345 ... LastLast


Similar Threads
Thread Forum
Wifi network disconnects when wired network is attached
Hi, I am currently struggling with the following problem: I have a Windows 10 Pro computer that has wired internet connection to the office network. And on top of that I need the computer to ALSO connect to my Sonoff Relay (ESP8266 Soft...
Network and Sharing
Solved Network discovery will not stay on and Function Discovery wont start
Iím running Windows 10 Pro 64 bit, fully patched with 16Gb RAM; I performed a full wipe clean install just 25 days ago. Other than this issue, everything is working perfectly on this computer. This system is not on a domain, and there is no group...
Network and Sharing
Solved Wired home network has collapsed after recent Win 10 update
For a long time I have had a very stable wired network of four PCs (and a fifth if I choose to add it) until the recent Win 10 update. Suddenly my network and workgroup have collapsed. One exception is my wife's PC, which I can see from my main...
Network and Sharing
Home network discovery not working after latest W10 Update
I just installed (yesterday) the latest W10 update that installed Version 1511 (OS Build 10586.3) and my home network consisting of five W10 PC's has been "destroyed." I do not use Homegroup. Instead, I have always set up all the drives/folders as...
Network and Sharing
Network Discovery not working ?
Hi Forum :) I am facing a problem that my PC running Windows 10 cant see other PC's/Devices on my network. Idk. if it have something to do with i cant make/join a homegroup. I was told to remove a file in...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 09:24.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums