Windows 10: Can ping ipv6 but not ipv4 on LAN Solved

  1.    22 Jun 2017 #1

    Can ping ipv6 but not ipv4 on LAN


    I just moved into my business partner's home office and I am trying to get Dev (computer #1, Win10 Pro) to see DbServer's (computer #2, also Win10 Pro) Postgres Database to no avail so far.

    He has a Comacast router which seems to be using using IPv6 primarily. When I go to WhatisMyIP, I get a v6 address. Ok, I think finally time to get my head around IPv6.

    During debugging I ran an interesting effect which may or may not be the related to my connectivity problems.

    Dev can ping DbServer's v6 address but not its v4. DbServer can ping Dev's v4 address but not its v6. I can RDP into DbServer from Dev using either v6 or v4 just fine.
      My ComputersSystem Spec

  2.    22 Jun 2017 #2

    It's rare for most routers to use ipv6 on the LAN disable it on all PCs make sure all PCs are in the same workgroup and all have ipv4 IP in the same range make sure NetBIOS is running on all PCs
      My ComputerSystem Spec

  3.    22 Jun 2017 #3

    While looking around for the settings you want I noticed that DbServer was on a Public Network while Dev was correctly on a Private Network. The last time I moved this computer it defaulted to Public network then as well.

    My database access is working now. though interestingly, neither computer can now ping the others IPv6 address, just the v4 addresses.



    The IPv6/v4 ping pro
      My ComputersSystem Spec


 

Related Threads
A machine running 64-bit win10 belongs to one WorkGroup, connects to the LAN via EtherNet for speed but it must be available via wifi also, so both connections are open. For an Android device to access an app served by a webapp served on the win10...
Hello, I'm using windows 10 and have been having an internet connectivity problem (there's a yellow triangle for my Ethernet and wireless connection and it states Internet -secured, no internet). When I access websites, it states "DNS probe...
IPv4 and IPv6 Connectivity? in Network and Sharing
Hi, I did a clean install of my Win10 Home about a week ago and it all turned out for the good. However, tonight while nosing around my Network Connections I notice I am connected to the Internet by Ethernet (Realtek PCle GBF Family Controller)...
Hello all, I just bought a new computer and it connected to the internet fine. Today, right after an update from Asus Live Update, my internet stopped working. It says the wifi is connected but when I open a browser and search it says no internet. I...
I have a two PCs on the same subnet, hardwired into the same router. Every night they timeout and sleep, Every morning my KVM software Microsoft's Mouse without Borders complains (on each PC) that it cannot find the other PC. Both PCs have fixed...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:15.
Find Us