Windows 10: NAS and attaching a My Book drive to a router port

  1.    31 May 2017 #1

    NAS and attaching a My Book drive to a router port


    Don't know enough yet to answer my question.
    NAS's are something new to me so I'm trying to get up to speed (no pun intended).
    As I understand it a NAS would hang off of a router port, and have its own built in IP address so it can be accessed from the net or just use it locally (or both).

    I have also been checking out new routers, and see that the Linksys WRT1900AC, and higher have a rear USB 3.0 port. Since I don't have any USB 3.0 ports on my desktop (yet) it got me thinking. (bad thing on my part)

    Could I connect a My book to the router USB port, and would it be the same thing as a NAS ? I'm thinking not since it wouldn't have own IP address?

    Would I get good speeds using the My Book connected to the router since I don't have a USB 3.0 on my desktop?

    Lastly how good are speeds to a NAS verses connecting a drive to a USB 3.0 desktop port ?
    My current router an old Linksys DIR-615 specs indicates port specs are 10/100 so upgrading my router to a router with 10/100/1000 should increase transfer rates to the NAS or My Book ??

    P.S. You blokes across the pond have your in act together !
      My ComputerSystem Spec

  2.    31 May 2017 #2

    Most routers that have USB ports let you connect a hard drive and it shows as a shared folder so you can use it there is a fair chance the speed could be better than local but there are a lot of factors to the equation
      My ComputerSystem Spec

  3. Berton's Avatar
    Posts : 5,289
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       31 May 2017 #3

    Routers do have the ability to 'look like' a computer. Mine is a Gigabit Wireless with 4 Ethernet ports and 2 USB 2.0 ports. I haven't any need for the USB yet because of my setup I also have an 8 port Gigabit Switch [needed for 5 computers, workbench, 2 NAS Ethernet drives and 2 Ethernet printers (Inkjet and Laserjet). An advantage to the WDC MyCloud NAS drives is I can access files on them using versions of Windows, osMAC [formerly Mac OS X] and Linux computer whether Wired or Wireless. The computer part interprets the files as needed when accessed by any computer. The Wireless part of the Gigabit Router is 802.11b/g/n, am looking at the future in replacing with 802.11ac equipment as I now have 2 computers with that capability.
      My ComputerSystem Spec

  4.    01 Jun 2017 #4

    I will say one thing I visited the Newegg web site, and read all the reviews for the MY Cloud 4TB drive, and they aren't exactly glowing. Especially the latest (all the other are for 2016 or older) confused me about the subnet comments.
    WD 4TB My Cloud Personal Network Attached Storage - NAS - WDBCTL0040HWT-NESN-Newegg.com

    I'm not sure if that meant I would not be able access my data from within my own home with the first version,and that doesn't sound right to me. I have no way of knowing what version drive I would get it's all factory sealed.
      My ComputerSystem Spec


 

Related Threads
Hello I'm having a weird problem. Two day ago my customer inform me that cannot use shared drive at their office. This is my system environment to test this problem. https://www.uppic.org/image-1790_59152E66.jpg This check list that i passed...
All laptops but one can access the USB drive on \\tplinklogin.net. All other devices have no problem either, phones etc. The error message reads: 91964 The laptop has been away for over a month on another network and I suspect the access has...
Hi! I have a wired Ethernet connection between a PC and a Mac (is that the issue?), and when locally hosted servers (on PC) are hosted, I get issues, but mainly issues binding to ports. Is the issue that I am not using a router or something like...
Folks, There is something very odd going on with JUST ONE of my USB 3 ports (one of the two on the front panel) on my new system that has a "clean" install of Win 10 Pro. A few days ago I tried to use that port and Windows did not recognize any...
Hi guys, I just built a new PC: MSI X99A Sli Plus PSU Cooler Master V550 5820K DDR4 32GB Nvidia Quadro K2200 Samsung SM951 256 GB M.2 boot drive
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:36.
Find Us