1.    21 May 2017 #1
    Join Date : May 2017
    Posts : 2
    Win 10 Pro

    SMB1 disabled, SMB2 enabled; Can no longer access network shares


    Hey All,

    After the recent Wanncry attacks I disabled SMB1 protocol as per the cautionary suggestions from Msft et al. Now I can no longer access my network shares via File Explorer. I am still able to access the network device using IP address via browser. However, the unifying and familiar Explorer remains stubbornly broken. When I turn SMB1 back on everything works ok. Any ideas how to fix File Explorer access while remaining somewhat protected. Mucho thanks in advance.

    M.B.
      My ComputerSystem Spec
  2.    31 May 2017 #2
    Join Date : May 2017
    Posts : 2
    Win10 1703

    If you're system is up to date, there's no need to be concerned about Wannacry - as such there's no problem using SMB1 (despite all the comments about SMB1)

    I had the same problem - no shares visible on File Explorer - researched the issues related to disabling SMB1 - and quite frankly, it's only SMB1 on XP machines that will be (would have been before MS released a patch for XP) susceptible to a Wannacry attach. I suggest you reinstate SMB1 and enjoy accessing your network shares as before

    R
      My ComputerSystem Spec
  3.    31 May 2017 #3
    Join Date : May 2017
    Posts : 2
    Win 10 Pro
    Thread Starter

    I've heard the same from several sources and have reverted to smb1. Even so, I wonder why smb2/smb3 isn't enough to provide access to the networked resources. Thanks for the reply.

    m.b.
      My ComputerSystem Spec
  4.    31 May 2017 #4
    Join Date : Sep 2015
    Staffordshire
    Posts : 361
    Windows 10 Pro

    Been through this and enabled SMB1 again.
    Why it doesn't work? My findings were in this thread WannaCry - Page 2 - Windows 10 Forums
    When you disable SMB1 it uninstalls stuff needed by Workstation service, as said the exploit was patched back in March.
      My ComputersSystem Spec

 


Similar Threads
Thread Forum
Cannot Access Windows Network Shares
Three machines: Surface Pro 4 - fully updated Surface Pro 3 - Windows 10, fully updated Lenovo X220T - Windows 8.1 Fully updated All three machines can see all available network devices, including each other. All three machines can...
Network and Sharing
Disabled admin password, can no longer access computer
So, a while back I had a problem on the Windows 10 Home Edition where it would not let me change my lock screen. Since I didn't have the pro edition, I couldn't change the policy in the registry editor because of a lack of one, so I transferred all...
User Accounts and Family Safety
Solved W10 Sharing on LAN -- Need to REFRESH Network to access shares
Hi there Anybody got a solution to this I have a LAN with various computers of different OS'es sharing HDD's. If I just leave them idling (i.e nothing running - no sleep / Hibernate / HDD disconnects etc) I find if I try and connect to a...
Network and Sharing
Can't access network shares
Before the upgrade to 10 I was on 7 and logged in with a local account with all computers having the same usernames and passwords and sharing worked flawlessly. After the upgrade I am now logging in with a Microsoft account and sharing does not...
Network and Sharing
Builds 10158 & 10159 can't access many network shares
I have a number of network shares that Win 10 no longer has permission to access. This only occurred in builds 10158 & 10159. The weird thing is that all the shares that can't be accessed are on a single machine, however, there are shares on that...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:42.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums