Page 1 of 2 12 LastLast
  1.    16 May 2017 #1
    Join Date : Sep 2015
    Posts : 16
    Windows 10

    Can't connect to WiFi on Dell XPS Studio 1640


    My laptop is nearly 7 years old and came with Vista. I upgraded to Windows 7 Professional then to Windows 10 in August 2015. Now all of a sudden, it will not connect to WiFi, at home, or in a public place. My other laptop, iPad and Samsung Note 8 Tablet have no issues.

    Device manager says all is well and working properly with Intel Wireless Link 5100 adapter.
    I've performed an upgrade (keep files and apps) but to no avail.
    Executed certain commands in Command Promt, but no luck.
    Computer recognizes the router but after entering security key says "cant connect to this network."
    Even downloaded via other computer updated driver but when executing install, doesn't change the original.
    Can't run driver update from Intel due to no connection

    Is the Intel Wireless Link 5100 adapter an embedded chip on the computer with a driver being a part of the Windows 10 operating system, (2 separate things), or is the Wireless Link 5100 the driver itself? In other words, is a driver added to the embedded Wireless Link 5100 Adapter to make it work?
    Thanks
      My ComputerSystem Spec
  2.    16 May 2017 #2
    Join Date : May 2015
    Central IL
    Posts : 4,200
    Mac OS Sierra

    You need to go into Device Manager and remove device and driver then reboot and let Windows install the default driver. If you went to Creators Update as an upgrade, you may have to do a clean install with the Windows 7 Pro license when asked for it during install.
      My ComputerSystem Spec
  3.    16 May 2017 #3
    Join Date : Sep 2015
    Posts : 16
    Windows 10
    Thread Starter

    I had already tried that and it didn't work, but tried it again just to make sure, but still no success.
      My ComputerSystem Spec
  4.    17 May 2017 #4
    Join Date : May 2015
    Central IL
    Posts : 4,200
    Mac OS Sierra

    You need to install the latest Intel Proset driver for Windows 8.1 or the Windows 7 driver.
      My ComputerSystem Spec
  5.    17 May 2017 #5
    Join Date : Sep 2015
    Posts : 16
    Windows 10
    Thread Starter

    I'd already ran both the Intel

    Wireless_17.0.3_De164
    Wireless_19.50.1_PROSet_Win10

    But again, no luck. I assume these are self installed, but perhaps they are not the correct ones, or, I'm not doing something correctly.
      My ComputerSystem Spec
  6.    17 May 2017 #6
    Join Date : May 2015
    Central IL
    Posts : 4,200
    Mac OS Sierra

    That is the correct driver if Windows installed it. The package that shows on Intel's website does not necessarily mean that they have updated the driver. Especially for a older wifi card. If it is a mini-PCIe card. You should be able to swap it out for the 726x series. You will not get Bluetooth, but it will work. Now if you want something better, just disable the internal Wifi card and use a USB adapter for wifi. I doubt that it could run the internal 8000 series PCIe mini-cards.

    You may want to check to make sure that the card did not get disabled on the bios or the Fn key get pressed to turn off the wifi.
      My ComputerSystem Spec
  7.    17 May 2017 #7
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,451
    windows 10

    Can you connect to an unencrypted network old cards carnt understand new encryption but will connect to open networks or wep ones
      My ComputerSystem Spec
  8.    17 May 2017 #8
    Join Date : Sep 2015
    Posts : 16
    Windows 10
    Thread Starter

    I'll give these things a try a little later when I have more time.
    Thanks guys.
      My ComputerSystem Spec
  9.    19 May 2017 #9
    Join Date : Sep 2015
    Posts : 16
    Windows 10
    Thread Starter

    OK guys, nothing I seem to do works. In fact I've just completer a clean install of Windows 10 Pro, but the problem remains.
    Just to be clear;
    1 Throughout this problem, all the available networks are shown by clicking on the Wi Fi icon.
    2 After entering the security key, it says, "Can't connect to this network."
    3 I even tried pushing the button on the router. The computer says it's trying to get the settings from the router, then the
    Same message, "Can't connect to this network".
      My ComputerSystem Spec
  10.    19 May 2017 #10
    Join Date : Dec 2013
    Portsmouth Hampshire
    Posts : 1,825
    Windows 10 x86 14383 Insider Pro and Core 10240

    Click image for larger version. 

Name:	image.png 
Views:	2 
Size:	376.8 KB 
ID:	135596

    It is a Mini card adapter - deprecated because it is old now, but still should work unless it has a fault.

    It could have become unseated (unlikely), or the contacts could have corroded due to condensation or atmospheric deposits, or just a component on the adapter or on the motherboard may have failed.

    The simplest action is to remove the back of the laptop, and gently clean the adapter card's contacts using a pencil eraser, or with a Q-tip and electronic contact cleaner fluid.

    Youtube has plenty of videos showing disassembly, and the search has links to Dell service manuals that describe the process:

    Dell XPS Studio 1640 disassembly - Google Search
      My ComputersSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
connect to internet via ethernet and wifi but to network only on wifi
Hello. I have three Dell XPS PCs connected via a Verizon Actiontec router to each other and to the internet, all running Windows 10 (two preinstalled, one upgraded from Windows 7). All connect fine to the internet via Ethernet and wifi, but they...
Network and Sharing
Has anyone updated a Dell Studio 540 from Windows 7 to 10?
My daughter has a Dell Studio 540 running Windows 7 Home Premium 64-bit and she's been asking me if it's OK to upgrade to Windows 10. Since I live several hundred miles from her I didn't want to tell her to go ahead until I had a chance to check...
Installation and Upgrade
Can't connect to wifi any more. Wifi icon shows a red x.
Latitude E6520 running Windows 10. Was working fine and then 2 days ago the wifi dropped and won't go back on. When I boot up, the wifi icon shows black and white with the little asterisk. I can click on it and see my network, and my neighbors,...
Network and Sharing
Dell Studio 540 updated to Win 10 - Keyboard driver not working
Good Day. I have upgraded my old Dell Studio 540 from Win 7 to Win 10. Everything seems to be working fine except the keyboard no longer works. In Device Manager the keyboard is now "Unknown Device" and automated device driver update attempted to...
Installation and Upgrade
Connect your Windows app to Azure IoT Hub with Visual Studio
Source: Connect your Windows app to Azure IoT Hub with Visual Studio | Building Apps for Windows
Windows 10 News
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:51.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums