Windows 10: No internet access with wifi tethering (mobile hotspot)

  1.    15 May 2017 #1

    No internet access with wifi tethering (mobile hotspot)


    When I use wifi on my PC to connect to my router/modem, internet works fine.
    But when I connect to my Android phone's access point (tethering) I don't get internet access.
    You might think it's a problem with the Android phone, but other Android devices can connect to it and use the internet just fine.
    So it's only my Windows PC that doesn't get internet, or rather the combination of Windows PC+Android phone access point.

    Does anyone have any ideas? (BTW, I have the same problem on Windows 7. Also, tethering over USB works fine.)
    Last edited by centen; 17 May 2017 at 07:30.
      My ComputerSystem Spec

  2.    15 May 2017 #2

    When you connect from a cmd prompt type

    ipconfig /all

    post results
      My ComputerSystem Spec

  3.    16 May 2017 #3

    edit: it looks normal
    Unlike the working connection (router/modem) the "Connection-specific DNS Suffix" entry is blank. But I read elsewhere that that shouldn't be a problem...
    Last edited by centen; 18 May 2017 at 09:50.
      My ComputerSystem Spec

  4.    17 May 2017 #4

    I narrowed it down to the USB wifi adapter:
    I tried tethering with a new Windows laptop (built in wifi module), it works fine.
    But the same laptop does not work anymore if instead of the built-in wifi I use my TP-Link USB wifi adapter, TL-WN821N. (Same old problem: works fine when connected to the router, but when connected to the Android phone there's no internet.)

    So it all points to the TP-Link adapter being the problem. I tried installing an older driver but it didn't help.
      My ComputerSystem Spec


  5. Posts : 460
    Windows 10 Home x64 and Pro x86
       17 May 2017 #5

    Just a shot in the dark -

    I once had this problem when I added a new WiFi adapter last year. In my case, Bitdefender was blocking access through the new adapter. I temporarily removed BitDefender & the problem disappeared.

    I ditched Bitdefender permanently soon afterwards & the only explanatory note I can find now was that BitDefender had, without my noticing, been setting the new adapter up in Stealth mode and I had to set the Firewall, Adapter entry to Trusted. Just going on memory, I think it was setting Firewall, Adapter entry to Trusted that was the real solution and the Stealth mode note proved to be a red herring.

    Best of luck,

    Denis
      My ComputerSystem Spec

  6.    17 May 2017 #6

    I don't have an antivirus, but I did try to disable my firewall, it didn't help.
      My ComputerSystem Spec

  7.    17 May 2017 #7

    The IP is correct so should work from Cmd prompt type

    Tracert 194.119.131.66

    Post results
      My ComputerSystem Spec

  •    17 May 2017 #8

    It says "Destination host unreachable."
      My ComputerSystem Spec


  •  

    Related Threads
    I've never had a problem but all of a sudden my laptop cannot access my network to see other computers and printers through Wi-Fi. Ethernet connection sees the other computers. Internet works fine. It also shows the laptop when I pull up the...
    No internet access on my wifi in Network and Sharing
    My internet stopped working for all the softwares but Google Chrome. I searched some solutions online but I ended up making the situation worse and now I can't even connect to the wifi. Basically I put the password and it connects, but the wifi...
    First, Sorry about my English. I have a question. I use Win 10 Pro, when i use both Wifi( have Internet) and Ethernet( In Local have not Internet). Window can't not access internet although Wifi still work well. When i Disable Ethernet, Window...
    I have setup a WiFi Hotspot with MyPublicWiFi. Allowed Sharing in Local Area Connection *2. Everything seems to be in order as the Screenshot shows. But when I try to connect a mobile it gets connected to "MyPublicWiFi", no internet sharing from...
    Apologies if this has been addressed already but I haven't been able to find a post with this particular issue. Here's the background information: I have a Dell Vostro 3750 notebook which I upgraded from Windows 7 Home to Windows 10 using a...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 09:34.
    Find Us