1.    07 May 2017 #1
    Join Date : May 2017
    Posts : 4
    Windows 10 1703

    All browsers hang after Creators Update


    Hi,

    My PC was working flawlessly before Windows 10 Creators Update. A week or two after the update, my default browser (Opera) started to hang when loading a webpage and says "Not Responding" quite often. While letting the browser in the "Not Responding" state, I opened Edge, Chrome, Firefox, IE to check, but they all can't load any webpage and eventually hang all.

    I tried ping 8.8.8.8 and nslookup google.com, they seem to work from command line.

    Curiously enough, I am using a Wi-Fi connection and, if I disable the Wi-Fi network adapter, all the browsers come alive again instantly and say "The page cannot be displayed", which is normal. If I reconnect to Wi-Fi, all work great until the same thing happens again. Hang, disconnect wi-fi, works perfect, connect again and the cycle repeats.

    I tried to uninstall the Intel Wi-Fi driver and reinstalled it, but the problem persists.
    Any suggestion you can give me? This drives me nuts.

    Note that the network shares (from Windows Explorer), ping, traceroute, nslookup all work fine. Only ALL browsers hang until I mess with the Wi-Fi adapter. It doesn't matter which browser I use.
    When using LAN cable, I couldn't observe any issue, but I haven't tested much (a couple of hours).

    Other thing to note: It seems that other services (OneDrive, Nvidia updater, Steam) cannot connect during this phase, which is weird.

    Wi-Fi: Intel® Dual Band Wireless-AC 7260 Plus Bluetooth
      My ComputerSystem Spec
  2.    07 May 2017 #2
    Join Date : Oct 2014
    Trnava
    Posts : 2,869
    Windows 10.4 Home 1709 x64

    For starters, have you tried Network Reset?

    Reset Network Adapters in Windows 10 - Windows 10 Network Sharing Tutorials

    I have solved my WiFi problems by simply disabling everything, which is supposed to improve internet.

    To disable "IPv6/LMHOSTS Lookup/NetBIOS over TCP/IP", run CMD as admin and copy/paste:
    Code:
    netsh int ipv6 isatap set state disabled
    netsh int teredo set state disabled
    netsh interface ipv6 6to4 set state state=disabled undoonstop=disabled
    reg add "HKLM\System\CurrentControlSet\Services\Tcpip6\Parameters" /v "DisabledComponents" /t REG_DWORD /d "255" /f
    reg add "HKLM\System\CurrentControlSet\Services\NetBT\Parameters" /v "EnableLMHOSTS" /t REG_DWORD /d "0" /f
    wmic nicconfig where TcpipNetbiosOptions=0 call SetTcpipNetbios 2
    wmic nicconfig where TcpipNetbiosOptions=1 call SetTcpipNetbios 2
    Then uninstall all network protocols from network adapter except IPv4 and uncheck IPv6, like this:
    Attached Thumbnails Attached Thumbnails capture_08132016_123654.jpg  
      My ComputerSystem Spec
  3.    07 May 2017 #3
    Join Date : May 2017
    Posts : 4
    Windows 10 1703
    Thread Starter

    Haven't tried. I just uninstalled manually the adapter in Control panel and then used the Intel software to reinstall.

    What does "IPv6/LMHOSTS Lookup/NetBIOS over TCP/IP" really do?

    I do use IPv6. Do I have to uncheck it?
      My ComputerSystem Spec
  4.    07 May 2017 #4
    Join Date : Oct 2014
    Trnava
    Posts : 2,869
    Windows 10.4 Home 1709 x64

    IPv6 is usually the main cause of problems.

    Heres Why Your Internet May Be Dropping

    LMHOSTS Lookup/NetBIOS over TCP/IP are needed, if you use aDSL or use file sharing within a network.
      My ComputerSystem Spec
  5.    07 May 2017 #5
    Join Date : May 2017
    Posts : 4
    Windows 10 1703
    Thread Starter

    Ok, so it seems that I shouldn't disable LMHOSTS Lookup since my networks relies on network shares from different windows PCs.

    I will disable IPv6 and try it out in IPv4 only, but my other 4 PCs work fine with the same IPv6 IPv4 coexistence, all running Windows 10, but different network adapters. I don't know why this is the only one on which browsers hang.
      My ComputerSystem Spec
  6.    07 May 2017 #6
    Join Date : Oct 2014
    Trnava
    Posts : 2,869
    Windows 10.4 Home 1709 x64

    In that case try looking for a newer driver, maybe that one just is not compatible with CU.

    Driver Easy Free is good in finding drivers.
      My ComputerSystem Spec
  7.    07 May 2017 #7
    Join Date : May 2017
    Posts : 4
    Windows 10 1703
    Thread Starter

    Hm... Just found another similar thread on intel's forums: Intel dual band 7260AC for desktop hangs on Win... |Intel Communities
    Maybe a driver issue? I will try an older version instead a newer one.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Windows 10 Creators Update and Creators Update SDK are Released
Source: Windows 10 Creators Update and Creators Update SDK are Released - Building Apps for WindowsBuilding Apps for Windows :arrow: Windows 10 Creators Update version 1703 (build 15063) now available from Windows 10 Update Assistant. ...
Windows 10 News
All browsers hang when I boot or un-sleep
After I Start Windows 10 or wake up from sleep, browsers(edge, internet explorer, Firefox) hang. When I open the browser and click on a link nothing happens. To close the browser I have to use alt F4 or task manager. While this is happening,...
Browsers and Email
Windows hang on desktop after last Win 10 update
Hello PC hang when I load it after the last update. The desktop is showed and PC start to load item from the toolbar ( the one next the clock). 2 application are loaded then system is hanged. Cursor is displaying a small circle and that it ...
General Support
Browsers Hang, Freeze And Crash
I'm at the end of the rope on trying to solve this problem. I am using a Dell XPS-17 L702X laptop with 8GB of DDR3 RAM and two internal drives, 500GB each. I have 408 GB of free space on the OS drive, which is Drive C. I am running a clean...
Browsers and Email
Solved KB3081441 or KB3081444 Update Causing Shutdown Hang
I'm not sure which update it was, but both KB3081441 & KB3081444 installed on the August 19th and now my laptop doesn't want to turn all the way off on shut down. It will do a restart normally, but I have to hold down the power button to force it to...
Windows Updates and Activation
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 21:12.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums