1.    26 Apr 2017 #1
    Join Date : Apr 2017
    Posts : 4
    Windows 10

    Updates and Wired / Wireless Connection Issues


    First, some background, I've been a PC tech for years and currently work as a programmer. I've built and configured hundreds of machines and I know how to systematically observe and troubleshoot issues.

    I own three machines, an HTPC on WIN 10, my development machine on Win 7, and my wife's WIN 10 personal machine.

    Trials and tribulations began when after a forced update my HTPC would no longer connect to the internet... after an hour of jacking with the Realtek Gbe drivers for the motherboard and seeing tons of complaints and went to the local store bought a standalone card slapped it in the machine (new hardware should fix it, right?)... Wrong. Same issue. After more time and internet browsing and seeing a common thread (Realtek)... I determined the motherboard must be borked... I ordered a new one. Not an hour after I clicked "purchase" ... my wife called me. She couldn't connect to the internet. Huh... what a coincidence... checked her drivers... yes, Realtek... yes, she'd just gotten an update. Okay... so now... three adapters... all realtek... all stop working after a windows update... This is NOT a hardware problem...

    I looked into this... spending tons of time researching. Power management was a component and forced driver updates. I turned off power-management of the onboard NICs and that granted a little more stability.

    I was feeling really pissed because I had purchased $500 worth of hardware to fix Microsoft's introduced issue.

    The new motherboard had an Intel NIC on board. After a fresh install of windows... it worked. On my HTPC nothing would make it work right. I bought a standalone Intel NIC and ---STILL--- the disconnections persisted. Only after I completely reinstalled windows 10 did the problem go away after I turned off power management, and driver updates.

    Last night on my wife's machine which has been stable ever since the complete rebuild, I put a new GTX 1070 video card in there. The nVidia WHQL drivers would not install on her "old build of windows 10". I clicked okay on the update. On the new version the drivers installed. She played on it the rest of the night.... NO ISSUES.

    This morning... the machine was back at the login because an update had been pushed.

    And the connection issue is back.

    I will no doubt be boxing with this problem for another few hours. I have wasted hours and hours on this. Looking through forum posts with MS experts laying blame at the feet of drivers and bad hardware. I don't buy cheap equipment, I purchase for stability. After hours of screwing with computers at work, I don't want to come home and do my own tech support!

    This is super frustrating issue for non-technical users. Having to reinstall windows to fix corruption caused by a forced update is RIDICULOUS. Hours of time wasted because something was "fixed" that didn't need to be touched. With multiple machines, I can verify that this is not hardware or driver related. It's something related to the TCP stack in windows getting jacked and crashing.

    For people experiencing this issue it seems worst with the Realtek based cards, I was never able to achieve stability after the anniversary update. With the Intel NICs I was able to achieve stability by ripping out the stock Microsoft drivers ... this can be quite frustrating as windows slams another copy in almost before you can log out. It needs to be done in safe mode... However, Microsoft if you're listening ... disabling the MSI installer and the Repair functionality in while in SAFE MODE is perhaps the stupidest thing ever conceived.

    Anyways, there are utilities that will allow you to run MSI installers in safe mode... so that you can run the Intel driver installer if you get to the desperation point that I did where I couldn't flippin uninstall the drivers in regular mode.

    Bottom line a REAL solution for this issue needs to be published. Having the issue happen 5 times (3 times on one machine, twice on another) with various NICs means this is no driver / hardware issue. These are machines that run stably for months at a time and mysteriously and coincidentally stop working right after an update. I would like to add throughout all 5 incidents... the Windows 7 has NEVER had any such issues despite having similar hardware and even a Realtek NIC. Further the same hardware (like the purchased Realtek NIC) work fine on that Win 7 build but failed in both the Win 10 machines.

    It would be nice if somebody has gone through this and has the steps to reproduce a stable fix that DOESN'T INVOLVE A FULL REINSTALL.
      My ComputerSystem Spec
  2.    26 Apr 2017 #2
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,451
    windows 10

    Save the txt below as nic.cmd

    then right click and run as admin make sure all programs are closed as it will reboot

    netsh advfirewall reset
    netsh advfirewall set allprofiles state ON
    ipconfig /flushdns
    netsh winsock reset catalog
    netsh int ip reset c:\resetlog.txt
    ipconfig /release
    ipconfig /renew
    netsh int ipv4 reset
    netsh int ipv6 reset
    bitsadmin /reset /allusers
    reg delete HKLM\SOFTWARE\Policies\Microsoft\Windows\IPSec\Policy\Local /f
    reg add HKLM\SOFTWARE\Policies\Microsoft\Windows\IPSec\Policy\Local /f
    netsh interface ipv6 6to4 set state state=disabled undoonstop=disabled
    netsh interface ipv6 isatap set state state=disabled
    netsh interface teredo set state disabled
    netsh interface tcp set global autotuning=disabled
    reg add hklm\system\currentcontrolset\services\tcpip6\parameters /v DisabledComponents /t REG_DWORD /d 0xFFFFFFFF
    for /F "tokens=*" %%a in ('wevtutil.exe el') DO wevtutil.exe cl "%%a"
    shutdown -r
      My ComputerSystem Spec
  3.    26 Apr 2017 #3
    Join Date : Apr 2017
    Posts : 4
    Windows 10
    Thread Starter

    Wow, that's a +Kitchen sink I will try this if my last fix doesn't hold...

    (Removing the drivers ... twice + safe mode + diddling) seemed to get the drivers stable... or they have been for the last hour or so. Earlier today, wife said was disconnecting like every 5 minutes... she was ticked... I understand...

    Thanks for the reply!
      My ComputerSystem Spec
  4.    28 Apr 2017 #4
    Join Date : Apr 2017
    Posts : 4
    Windows 10
    Thread Starter

    Stability


    Well, the machine started doing the bogus self-disabling again. I ran the kitchen sink script (twice) and it didn't really make a difference.

    I notice the nic instability started happening after a patch for flash... (I think this is a coincidence)... I'm going to dig through the events and see if there's any clues.
      My ComputerSystem Spec
  5.    28 Apr 2017 #5
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,451
    windows 10

    Can you ge this on via usb or other see if it tells us anything

    Please download MINITOOLBOX and run it.
    Downloading MiniToolBox

    Checkmark following boxes:



    Flush DNS
    Reset FF proxy Settings
    Reset Ie Proxy Settings
    Report IE Proxy Settings
    Report FF Proxy Settings
    List content of Hosts
    List IP configuration
    List Winsock Entries
    List last 10 Event Viewer log
    List Installed Programs
    List Users, Partitions and Memory size
    List Devices (problems only)



    Click Go and post the result.
      My ComputerSystem Spec
  6.    02 May 2017 #6
    Join Date : Apr 2017
    Posts : 4
    Windows 10
    Thread Starter

    Apparent Resolution


    If nothing else, I am stubborn I took the following steps and it has remained stable since the last posting.

    1.) I disabled the existing l219-V (2) Intel adapter in device manager (I deliberately did not uninstall)
    2.) Downloaded Intel's 2.22 install CD and ran the installer
    3.) The installer created a new l219-V (2) #1 adapter (note the #1)
    4.) I went into the adapter settings and disabled everything to do with power saving / wake on lan, I turned on jumbo packets for performance
    Noted: that the adapter disabled and enabled quickly (when it's not stable it's very sluggish).
    5.) Disabled win 10 driver updates.
    6.) Uninstalled the old l219-V (2) adapter

    Something I should not have done is I moved the ethernet endpoint off the wireless router to my switch. I had seen the adapter negotiate once at 10/100 instead of 1 gig -- so I moved it. So, admittedly I don't know whether adapter voodoo fixed the issue or simply changing it to another ethernet port did. Honestly, since it's working and it's my wife's machine... quiet is much more attractive than knowledge / certainty.

    Hope this helps anyone else that experiences the issue.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Windows 10 Wired PC Updates - HughesNet Metered Internet Connection
I live in a very rural location where my only ISP choice is Hughesnet. As such, my data consumption is metered during the day, but available, almost free at night (2AM - 8AM). I can control Windows restarts in settings, but no way to control when...
Network and Sharing
Solved Laptop wireless speed much higher than wired
Did the anniversary update on my HP DV 6700 entertainment laptop, took over 2 days...... checked wired speed only 7mbs, but wireless 27 Mbps have a pc on same router and wired is 27mbps. have uninstalled / reinstalled network card from...
Network and Sharing
Losing wired connection
This has happened multiple times on my desktop which was upgraded to Win 10 so it is a real problem. The desktop is on a wired connection. At some point I will see that I have lost the internet connection. When this happens it doesn't...
Network and Sharing
Want to upgrade wired/wireless to match 1 gigabit speeds
I have 1 gigabit internet I upgraded to about 6 months ago and the upgrade was huge in real life performance especially bandwidth/ping. The speeds never get throttled and my house is full 4-5 people on 1 router. BUT..... My download speeds are meh...
Network and Sharing
Windows 10 wireless connection problem No Wireless Connections Availa
Turned on my computer this morning and my device can't find any wifi "Not connected no connections available" my other computers can connect to my modem no problem Wondering if anyone can direct to a link with a solve or give me some advice...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:02.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums