WSD vs Netbios Network Discovery

Page 1 of 2 12 LastLast
  1. sewing1243's Avatar
    Posts : 63
    Windows 10/64
       #1

    WSD vs Netbios Network Discovery


    What is the difference between WSD and Netbios?

    Is one preferred over the other?

    What kind of problems are associated with failing to use one or the other?
      My Computer

  2. lintek25475's Avatar
    Posts : 24
    Windows 10 Home
       #2

    I have to say this must be a question no one can answer in a straight forward way. Let's start with saying that Microsoft has introduced an undated (or a new version of) network discovery topology in Windows 10 that is not compatible with older Windows OS's. I never had issues with Windows 7 and Windows XP home networking. I don't remember having to deal with services called "Function Discovery...". Never had issues with my computers "not" being listed in Network Places either. Of course the so-called discovery method between W7 and XP was NetBIOS.

    In my mixed W10 (Home and Pro) and W7 network, WSD has problems maintaining the list of computer names in Network Places. Specifically, the computer name associated with the computer running W10 Home keeps disappearing after 30 minutes or so. The only way to make it reappear is to restart the "Function Discovery Resource Publication" service on the computer. This is a major pain. So I assume this is an undocumented bug. I don't know if Microsoft is aware or has addressed it.

    My solution was to disable the service and let NetBIOS take over as the discovery method for the computers on my LAN. Here's what I did: https://social.technet.microsoft.com...tpronetworking

    I would like to use WSD, but until MS fixes the service on W10 Home, I'll stay with NetBIOS. Is it true that MS is dumping Network Places in Windows 10? If so, what will replace it?
      My Computer

  3. sewing1243's Avatar
    Posts : 63
    Windows 10/64
    Thread Starter
       #3

    The more I investigate the worse it gets


    As I've dug deeper into this morass I've found that not only can no one seem to answer any questions, but Microsoft keeps changing things so often that I don't think they know how networking in Windows 10 works. During a recent Windows update they turned off SMBv1 (the the very feature that creates the Computer management service that populates the network folder in Windows File Explorer) and no one seems to know how they work/how to turn on the newer protocols, SMBv2 and SMBv3.
      My Computer

  4. Eagle51's Avatar
    Posts : 1,471
    Win10 Home x64 - 1809
       #4

    Hey sewing1243,
    Check the following link for the commands to check/disable/enable SMBv1 / SMBv2 / v3 - https://support.microsoft.com/en-us/...in-windows-and

    Here are the powershell (run as admin) commands for checking SMB stuff from that link.
    Note: I've tweaked them (FINDSTR) just to clean up the output. The following make NO changes to your PC.

    get-windowsoptionalfeature -Online -FeatureName SMB1Protocol | FINDSTR "FeatureName"
    get-windowsoptionalfeature -Online -FeatureName SMB1Protocol | FINDSTR "State"
    get-windowsoptionalfeature -Online -FeatureName SMB1Protocol-Client | FINDSTR "FeatureName"
    get-windowsoptionalfeature -Online -FeatureName SMB1Protocol-Client | FINDSTR "State"
    get-windowsoptionalfeature -Online -FeatureName SMB1Protocol-Server | FINDSTR "FeatureName"
    get-windowsoptionalfeature -Online -FeatureName SMB1Protocol-Server | FINDSTR "State"
    get-windowsoptionalfeature -Online -FeatureName SMB1Protocol-Deprecation | FINDSTR "FeatureName"
    get-windowsoptionalfeature -Online -FeatureName SMB1Protocol-Deprecation | FINDSTR "State"
    get-smbserverconfiguration | Select EnableSMB1Protocol,EnableSMB2Protocol | FORMAT-LIST
    sc.exe query mrxsmb10 | FINDSTR "SERVICE_NAME"
    sc.exe query mrxsmb10 | FINDSTR "STATE"
    sc.exe qc mrxsmb10 | FINDSTR "START_TYPE"
    sc.exe query mrxsmb20 | FINDSTR "SERVICE_NAME"
    sc.exe query mrxsmb20 | FINDSTR "STATE"
    sc.exe qc mrxsmb20 | FINDSTR "START_TYPE"
    sc.exe query browser| FINDSTR "SERVICE_NAME"
    sc.exe query browser | FINDSTR "STATE"
    sc.exe qc browser | FINDSTR "START_TYPE"
    sc.exe query fdphost | FINDSTR "SERVICE_NAME"
    sc.exe query fdphost | FINDSTR "STATE"
    sc.exe qc fdphost | FINDSTR "START_TYPE"
    sc.exe query fdrespub | FINDSTR "SERVICE_NAME"
    sc.exe query fdrespub | FINDSTR "STATE"
    sc.exe qc fdrespub | FINDSTR "START_TYPE"
    Get-ItemProperty -Path HKLM:SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters -Name SMB1,SMB2 | FORMAT-LIST -Property SMB1,SMB2
    Get-ItemProperty -Path HKLM:SYSTEM\CurrentControlSet\Services\LanmanWorkstation -Name DependOnService | FORMAT-LIST -Property DependOnService
    Get-ItemProperty -Path HKLM:SYSTEM\CurrentControlSet\Services\Browser\Parameters | FORMAT-LIST -Property MaintainServerList

    Note: If you have SMBv2 enabled you automatically get SMBv3. When I do a Get-SmbConnection it shows the Dialect/Protocol for my other Win10 PC as 3.1.1 and my Router/USB File Share as 1.5

    Note: I have to use SMBv1 Client, due to using my routers USB File Sharing.

    Here are the services I've found that seem to affect using WSD Discovery Method with SMBv2/v3
    Service | Default Startup Type | Startup Type For WSD
    =====================================================
    Function Discovery Provider Host | Manual | Automatic Delayed
    Function Discovery Resource Publication | Manual | Automatic Delayed
    SSDP Discovery | Manual | Automatic Delayed
    UPnP Device Host | Manual | Automatic

    Note: UPnP Device Host is set to it's default startup type and it' never running, so not sure it belongs in the list?

    Note: I've noticed the following with Function Discovery Provider Host running and starting the Function Discovery Resource Publication ... the Discovery Method changes to WSD from Netbios in File Explorer > Network. Now what that exactly means, well your guess is as good a mine :)
      My Computers

  5. lintek25475's Avatar
    Posts : 24
    Windows 10 Home
       #5

    Good stuff. I agree with it all. I don't mind which discovery method is used mind you. I just wished it actually worked. On my W10 Home computer, the FDRP service just dies even though the service displays it is running when I open services.msc. I know this by looking in Network Places on the other computers on my network. The W10 Home is not found in the list. When I restart the service, bam! It comes back. As for NetBIOS, that discovery method and using one computer (with the Computer Browser service on) to maintain the list in a mixed Windows network environment consistently works.

    I don't know where MS is trying to take us in terms of a home networking methodology, but I hope they get there soon and tell us what to expect. I hope it's not that HomeGroup crap either. Every update is causing me hours of frustration getting my file sharing to work again. I make changes and the updates seems to revert my changes to MS defaults. Mind-boggling.
      My Computer

  6. Eagle51's Avatar
    Posts : 1,471
    Win10 Home x64 - 1809
       #6

    Hey lintek25475,
    You don't need to worry about HomeGroup ... it has been deprecated and already removed in Insider Previews (starting with 17063). So, I expect HomeGroup will be gone in the upcoming Spring Creators Update (RS4) in a few weeks.
      My Computers

  7. lintek25475's Avatar
    Posts : 24
    Windows 10 Home
       #7

    Oh no. Guess what I just discovered. Like I said, it doesn't really matter which discovery method is used. Just want it to work. I know NetBIOS does. But W10 Home computer name disappears in Network Places when not using NetBIOS which means WSD is being used. So I performed another tweak.

    - Disabling NetBIOS over TCP/IP for all adaptor properties
    - Turn on Network Discovery from Advanced Sharing Settings>Network discovery
    - (This was the first additional tweak) On the W10 Home computer uncheck the box for "Turn on automatic setup of network connected devices"
    - Disable the Computer Browser service on all
    - Set FDRP (publication) and FDPH (provider) services to "manual"
    - (This was the second additional tweak) On the W10 Home computer I set HomeGroup Provider service from "manual" to "automatic"

    Now all the computer names are displayed and stable. But, you mention MS is going to get rid of HomeGroup. That's the thing which makes WSD stable in my mixed network environment.
    Last edited by lintek25475; 26 Mar 2018 at 19:03.
      My Computer

  8. Bree's Avatar
    Posts : 19,725
    10 Home x64 (21H1) (10 Pro on 2nd pc)
       #8

    lintek25475 said:
    ...you mention MS is going to get rid of HomeGroup....
    I'm afraid so. It's dead, starting with Insider build 17063.

    ...with today’s build you’ll start to see us retire the HomeGroup service...
    Announcing Windows 10 Insider Preview Fast+Skip Build 17063 for PC
      My Computers

  9. lintek25475's Avatar
    Posts : 24
    Windows 10 Home
       #9

    It never ends. I guess I will have to prepare for the worst "again".
      My Computer

  10. Eagle51's Avatar
    Posts : 1,471
    Win10 Home x64 - 1809
       #10

    Set FDRP (publication) and FDPH (provider) services to "manual"
    I've found those 2 need to be set to Automatic Delayed and yes it does take a few seconds for things to show up in File Explorer > Network.

    Granted I don't have a Win7 PC in the mix and I know it doesn't help you, but I just did a clean install (1709) on my son's laptop and it sees the other 2 Win10 PC's on my network using WSD and SMBv2/v3 ... So it can/does work ...

    Note: If I have time I'll disable Netbios and see what happens.

    1. Discovery Type shows as WSD
    2. Netbios is set to default for the adaptors
    3. SMBv1 NOT installed/enable
    4. FDRP and FDPH startup type set to Automatic Delayed and they are running
    5. SSDP startup type set to Manual and it is running
    6. Computer Browser startup type set to Disabled
    Note: Since it's tied to SMBv1 ... I don't think it matters what it's set to, when SMBv1 is not installed.
    7. HGP and HGL startup type set to Disabled
      My Computers


 
Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 00:59.
Find Us




Windows 10 Forums