Windows 10: windows 10 not showing computers in network in file browser

Page 1 of 2 12 LastLast
  1.    23 Apr 2017 #1

    windows 10 not showing computers in network in file browser


    this problem that windows has is really weird. i have 2 laptops running windows 10 pro (creators update) and a virtual machine running on one of them(windows server 2012 r2).
    after each restart one or two of these computers disappear from network folder. this problem happens for all these computers. the thing is i can ping all these machines from other computers on the network. I also can access them by typing their names in address bar like (\\computer1\ or \\computer2\ etc) but they are not appear in the network section. the image might help you to understand the problem better :
    Click image for larger version. 

Name:	cmp1.png 
Views:	7 
Size:	59.6 KB 
ID:	131586Click image for larger version. 

Name:	cmp2virtual.png 
Views:	7 
Size:	70.2 KB 
ID:	131587Click image for larger version. 

Name:	cmp3.png 
Views:	6 
Size:	94.3 KB 
ID:	131588

    as you can see on the first computer i can see all computers on the network. on the 2nd one(virtual) i have only see my Surface and on my surface i cannot see the other two.
    now I type the name of the computers in my Surface file explorer address bar and look at this :

    Click image for larger version. 

Name:	cmp32.png 
Views:	6 
Size:	112.2 KB 
ID:	131589

    first computer(Alienware) appears on the quick access area but still missing from network section
    is there any fix for this problem?
      My ComputerSystem Spec

  2.    23 Apr 2017 #2

    When windows looks for PC on a network it doesn't actually look it goes to the master browser which gives it a list. If it's out of date you don't see it this will happen if a PC is offline for a bit or its updated. It's all done via NetBIOS so pinging by name may update mb
      My ComputerSystem Spec

  3.    23 Apr 2017 #3

    pinging by name did not solve the problem. is there any way to update the master browser list?
      My ComputerSystem Spec

  4.    23 Apr 2017 #4

    Yes, force an election:
    NET STOP Browser
    NET START Browser
    Not sure it will help, though.

    Your email address can be seen in the attachment
      My ComputerSystem Spec

  5.    23 Apr 2017 #5

    If you run this tool on each pc it often does it and it shows which is MB normally that would be highest ranking ie a server NetBScanner - NetBIOS scanner
      My ComputerSystem Spec

  6.    01 May 2017 #6

    mQ573 said: View Post
    Yes, force an election:
    NET STOP Browser
    NET START Browser
    That is exactly what I've done to resolve what I believe is exactly the same key issue I have with the Creator's Update. I created it as a batch, and scheduled it to run with elevated privileges on startup, and then every 15 minutes thereafter. My home network and file shares are now working fine again with both post and pre Creators updates. I can't believe that Microsoft haven't released a patch to fix this yet!?!?
      My ComputerSystem Spec


  7. Posts : 5
    Windows 10x64 Pro
       20 May 2017 #7

    If you have the Creators Edition of Windows 10 I haven't found a solution for getting the master browser to work with an Oppo which accesses my shares via SMB. If I start another Windows computer running the anniversary edition and make it the master browser then my Oppo can see it. I don't want to have to fire up another computer because MS can't get this figure it out. I informed MS of the issue the moment CU was released but haven't heard anything at all yet. I think they only look at it from a Windows to Windows browser issue and not from Windows to device. People with WD TV and other devices are reporting the same problem.
      My ComputerSystem Spec

  •    04 Jun 2017 #8

    injaneb said: View Post
    this problem that windows has is really weird. i have 2 laptops running windows 10 pro (creators update) and a virtual machine running on one of them(windows server 2012 r2).
    after each restart one or two of these computers disappear from network folder. this problem happens for all these computers. the thing is i can ping all these machines from other computers on the network. I also can access them by typing their names in address bar like (\\computer1\ or \\computer2\ etc) but they are not appear in the network section...
    Yeah, I have exactly the same problem. I eventually managed to make my NAS's permanently accessible by adding them to 'Quick Access', but they won't appear in the 'Network' section.

    My other two machines (laptop and PC) don't have this problem.

    I reported the problem via the MS Feedback Hub.
      My ComputerSystem Spec

  •    04 Jun 2017 #9

    @flammobammo: Do you run that batch file on each of the PCs on your network?
      My ComputerSystem Spec


  • Posts : 1
    Windows 10 creators edition
       18 Jun 2017 #10

    flammobammo said: View Post
    That is exactly what I've done to resolve what I believe is exactly the same key issue I have with the Creator's Update. I created it as a batch, and scheduled it to run with elevated privileges on startup, and then every 15 minutes thereafter. My home network and file shares are now working fine again with both post and pre Creators updates. I can't believe that Microsoft haven't released a patch to fix this yet!?!?
    Please could you tell me precisely what you have done to fix this,I have tried everything to no avail I'm not sure about the batch and the elevated privileges you mention ,I would really appreciate any advice.

    my problem is identical if I start no1 pc up first, then start the 2nd pc the no1 pc shows all the available pcs on the network with the 2nd pc displaying none,and the same happens vice versa
      My ComputerSystem Spec


  •  
    Page 1 of 2 12 LastLast

    Related Threads
    Preface: I am running a laptop which I upgraded from windows 7 to windows 10. I also have a desktop that is still running windows 7. One of the hard drives on my desktop is shared, and I often-enough will copy files from my laptop to my desktop. ...
    Windows Network does not show computers, but I have a batch file that will load them and log in. I have used Credential Manager to set up accounts and if I try to log into a computer from "Run", it still requests a password. Both these issues are...
    Hello I recently upgraded the 3 machines on my home network to windows 10 home. I am having frustrating issues with the network at the moment and would appreciate any help available. Currently when I open up "this PC" and click on network,...
    As the title says. I can reach them by the quick access shortcuts I added before the upgrade but they don't show up in WE Network. Rebooting my WD MyCloud solves the problem until next time I reboot my Win10 c.
    Hi everyone! Just got an ASUS ZenBook UX305 and am having trouble mapping network drives as I can't connect to the devices via explorer (either in the list in Network under "computers" or my manually browsing to the device name or the IP...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 03:41.
    Find Us