Page 2 of 2 FirstFirst 12
  1.    18 Jun 2017 #11
    Join Date : Dec 2015
    Posts : 4
    Windows 10

    Well, for no apparent reason, after a couple of weeks of not appearing under 'Network', my NAS's have spontaneously reappeared as if nothing had happened...

    Weird.
      My ComputerSystem Spec
  2.    18 Jun 2017 #12
    Join Date : Apr 2017
    Posts : 5
    Windows 10

    Quote Originally Posted by HowardWoodard View Post
    @flammobammo: Do you run that batch file on each of the PCs on your network?
    Hi HowardWoodard, sorry I didn't notice this until now. No, I only ran it on the computer that I was trying to share from. Although please be aware that this fix worked great for a couple weeks after my post above, but then stopped again, and I became despondent about it and decided to wait a month for Microsoft to catch up before I came back on the forums again for help.
      My ComputerSystem Spec
  3.    18 Jun 2017 #13
    Join Date : Apr 2017
    Posts : 5
    Windows 10

    Quote Originally Posted by Badger300100 View Post
    Please could you tell me precisely what you have done to fix this,I have tried everything to no avail I'm not sure about the batch and the elevated privileges you mention ,I would really appreciate any advice.
    my problem is identical if I start no1 pc up first, then start the 2nd pc the no1 pc shows all the available pcs on the network with the 2nd pc displaying none,and the same happens vice versa
    Hi Badger300100,

    If you create a text file, but change the .TXT to .BAT, then anything inside that .BAT file, when double-clicked, will be executed. The contents of my MasterBrowser.bat file is:
    net stop browsernet start browser
    Then in the Cortana search bar, type 'scheduler' and load the Windows 10 Task Scheduler app
    From there, you can create a task to run your new batch file, with a whole bunch of different options.
    HOWEVER, this only worked for 2, maybe 3 weeks for myself, until Windows had another update, or something changed on my PC behind my back, and then my master browser routine to keep updating itself suddenly stopped working. I know it worked fine for weeks because I was using network-based music playing through the house, and then was devastated when it repeatedly wouldn't work anymore, and I had to go back to low quality streaming radio :-) I literally had not fiddled with any settings on my PC at all in this time, only security software (Comodo) and Windows updates, and potentially a VPN software update.

    Finally I though okay I've wasted enough time, Microsoft broke this as far as I'm concerned (originally first issue with Creators update), and hopefully enough people smarter and more knowledgeable than myself will get this sorted and post a solution, and I'll come back in a month when it is available. After an intensive several hours of google searching, trial and error, I've found my latest fix:
    - I removed my Master Browser scheduled task and deleted the batch file entirely
    - In 'Network Connections' - 'Change Adapter Settings', I right-click my connection and go to Properties
    - I had read somewhere on some forum ... that you need to make sure your 'File and Printer Sharing for Microsoft Networks' is checked.

    Now I've got absolutely no idea what 'File and Printer Sharing for Microsoft Networks' checkbox actually does, and Windows seems to have no descriptor at all, other than "Allows other computers to access resources on your computer using a Microsoft network". This is so vague, but someone on some forum somewhere suggested it should be checked, and mine wasn't. I checked it, and hit Apply, and it didn't fix it. I went back into the settings, and it was still unchecked, so I checked it again. I went back into the settings, and it was unchecked again, and so I thought okay, something funny going on here, it's not saving my checkbox tick. So I checked it again, hit apply, unchecked it, hit apply, then rebooted, then went back again, checked it, apply, reboot, and finally it remained checked. At least from memory I thought it did. And since then, it's worked perfectly, I can access the network shares on my Windows 10 Creators PC with the June updates.

    The weird thing is though, I go back now to look at that checkbox, and ..... drumroll .... it's unchecked. I still don't know what that checkbox ACTUALLY does, it's not checked, but mucking around with that checkbox fixed my issue.

    On another PC in my network, I ended up having to reinstall Windows after about 30 attempts of installing the correct graphics card driver, and then having Windows automatically destroy the driver with an incorrect one, and not being able to see the screen any more. After reinstalling Windows it all worked fine. I suspect that this PC is due for a Windows reinstall, but I've got too much software running just the way I like. Next year I'll either avoid upgrading Windows entirely, reinstall Windows after a format, or at least not upgrade on the bleeding edge, but wait for the guinea pigs to jump off the edge first.
      My ComputerSystem Spec

 
Page 2 of 2 FirstFirst 12


Similar Threads
Thread Forum
Other computers in network not showing; shows old network instead.
Preface: I am running a laptop which I upgraded from windows 7 to windows 10. I also have a desktop that is still running windows 7. One of the hard drives on my desktop is shared, and I often-enough will copy files from my laptop to my desktop. ...
Network and Sharing
Network not showing computers and Credintial manager not working
Windows Network does not show computers, but I have a batch file that will load them and log in. I have used Credential Manager to set up accounts and if I try to log into a computer from "Run", it still requests a password. Both these issues are...
Network and Sharing
Computers in network not showing up correctly Windows 10 Home.
Hello I recently upgraded the 3 machines on my home network to windows 10 home. I am having frustrating issues with the network at the moment and would appreciate any help available. Currently when I open up "this PC" and click on network,...
Network and Sharing
Computers/NAS not showing up in Network ->Windows Explorer after th2 u
As the title says. I can reach them by the quick access shortcuts I added before the upgrade but they don't show up in WE Network. Rebooting my WD MyCloud solves the problem until next time I reboot my Win10 c.
Network and Sharing
MyCloud NAS not showing up in Network computers
Hi everyone! Just got an ASUS ZenBook UX305 and am having trouble mapping network drives as I can't connect to the devices via explorer (either in the list in Network under "computers" or my manually browsing to the device name or the IP...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:06.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums