Page 1 of 2 12 LastLast
  1.    23 Mar 2017 #1
    Join Date : Mar 2017
    Posts : 5
    Windows 10 home

    network print nothing prints


    I have network printer. I wanted to print documents from command prompt
    so I gave command
    net use LPT1 \\<machine>\<printer share> /yes

    to link up network printer with LPT1

    then using print command
    print /d:LPT1 document.txt

    the printer pulls a paper, but it prints nothing

    How do I fix this?
    Last edited by essenbe; 23 Mar 2017 at 10:05. Reason: Remove link
      My ComputerSystem Spec
  2.    23 Mar 2017 #2
    Join Date : Oct 2014
    Posts : 164
    Windows 10 Enterprise

    how about trying the complete path: print /d:lpt1 c:\yourfolderhere\document.txt
      My ComputerSystem Spec
  3.    23 Mar 2017 #3
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,466
    windows 10

    lpt1 is normally a parallel port is your usb?
      My ComputerSystem Spec
  4.    23 Mar 2017 #4
    Join Date : Mar 2017
    Posts : 5
    Windows 10 home
    Thread Starter

    I tried full path but still nothing prints


    I typed full path of txt file and the printer pulls a paper but still not print anything.

    I use networked printer but you can use USB printer with LPT1 if you link USB printer with net use
      My ComputerSystem Spec
  5.    23 Mar 2017 #5
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,466
    windows 10

    Often the problem is the printer need to communicate back to the pc and it cant as you not attached are you using spooler?
      My ComputerSystem Spec
  6.    23 Mar 2017 #6
    Join Date : Oct 2014
    Posts : 164
    Windows 10 Enterprise

    Well, the good news is (maybe) is I can duplicate the problem. I'll keep playing with this and see if I can come up with anything. I tried access my shared printer and changing print directly instead of spooling BUT, since it is connected by USB it will not allow me to change that. Anyway, I'll keep plugging away...
      My ComputerSystem Spec
  7.    23 Mar 2017 #7
    Join Date : Oct 2014
    Posts : 164
    Windows 10 Enterprise

    Ok, I successfully got it to print. Now for my setup. Printer (HP 4000) connected to my Windows 10 computer via tcp/ip port as my computer doesn't have a physical lpt port to use. I then "shared" the printer and turned off spooling and told it to print directly to the printer.

    I then fired up my VMWARE and ran Windows 8.1 in a virtual window, typed in the net use lpt1: \\computername\sharename, then sent a print /d:lpt1 c:\test\printer.txt and received an error unable to initialize the printer.

    I went back to Windows 10 Computer and told it to spool like normal. Went back to the Windows 8 Virtual and tried printing again, and it worked! It actually printed the garbage I had in the text file.

    So it does work BUT, it would not print to my USB printer that is shared on my server (Windows 2012). But it would print using the shared printer on my Windows 10 computer. Hope this helps...let us know the outcome.
      My ComputerSystem Spec
  8.    24 Mar 2017 #8
    Join Date : Mar 2017
    Posts : 5
    Windows 10 home
    Thread Starter

    I disabled spool then I got unable to initialize error, I re-enabled spool, then still does not print anything.
      My ComputerSystem Spec
  9.    24 Mar 2017 #9
    Join Date : Oct 2014
    Posts : 164
    Windows 10 Enterprise

    How is the printer connected to the network? If it is connected directly to another computer on the network, is it connected via USB? If so, can you put the printer connected to the network via an ip address instead? That is how mine is connected when it worked.
      My ComputerSystem Spec
  10.    24 Mar 2017 #10
    Join Date : May 2014
    Cross Plains, WI
    Posts : 318
    Windows 10 Pro x64

    If the printer is connected via USB, printing to the LPT1 port isnt going to work as the LPT1 points to a physical parallel port. You said that the computer you are on does not have a parallel port on it, so you cant use this method. IF you want to print something via command line, you have to find out what virtual USB printing port it is connected to. You will do this by:

    Control Panel > Devices and Printers > (Printer you are trying to work with) > Right click and click on Printer Properties > Ports

    The port that is highlighted and checked would be the port that needs to be used. Replace LPT1 with that port and try again.
      My ComputersSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Solved Excel spreadsheet prints differently than what is on screen.
I keep my checkbook on an Excel spreadsheet. I have a balance column that I use formulas =sum(A1:A6) etc to keep a running balance. Everything looks fine on the spreadsheet. But when I ask for a print preview those cells it show the formula...
Software and Apps
Can't print from Windows using printer wired to Mac on same network
Windows 10 PC has Bonjour installed. I try to print, no error message appears but nor does printout.
Network and Sharing
IE11 print/print preview broken after installing 3rd party app
OK, this one is a twist on a very often reported problem on these forums: Internet Explorer 11 will not print and just shows an empty print preview page. (Edge works/prints fine). However in this case I know what caused the issue but not how...
Browsers and Email
Solved Print spooler chokes when attempting to print certain pdf files
The print spooler chokes on both of my Windows 10 machines when trying to deal with certain pdf files. For instance when I tried to print https://thebasscase.files.wordpress.com/2013/01/so-what.pdf via my browser (Chrome), it printed the first 6...
Drivers and Hardware
Solved HP D1460 Printer intermittent prints
Since I upgraded to Win 10 Pro from Win 8.1 Pro printing has become intermittent on my Deskjet D1460. There are no drivers on the hp site for this printer for Win 10 just the scan and print doctor. In fact the only way to get the printer to print...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:18.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums