Page 4 of 4 FirstFirst ... 234
  1.    19 Feb 2017 #31
    Join Date : Nov 2014
    The Netherlands
    Posts : 628
    Win 10 Pro x64 1607 (Build 14393.953)

    Quote Originally Posted by sml156 View Post
    On my linux (Debian) when I want to connect my Win 10 computer to an SMB running linux I run this command
    From a linux terminal:
    Code:
    service smbd stop && service nmbd stop && service smbd start && service nmbd start
    I have not figured out how to run that at every boot up yet.
    Thanks for your input, I don't use ubuntu nor Linux. Could this be the root cause of the issue @noxsoldier is having ATM? As his other PC's in his network can reach and interact with the U-server, I do think it's network related.

    Of course this should be checked too then.

    Cheers
      My ComputerSystem Spec
  2.    20 Feb 2017 #32

    Hi there
    @noxsoldier

    Let's go RIGHT back to FIRST principles

    1) look at the SAMBA server -- Here for example is a basic SAMBA setting that will allow most things to access the shares -- To solve these sorts of problems start SIMPLY and with MINIMAL security - always then tighten up later --too many people get into real obscure Windows settings / complicated domain issues and all sorts of other stuff.

    2) first thing to ensure that SAMBA is actually running so in the server you need as root to type (depending on the Linux distro) is : service smb status and service nmb status (could be smbd and nmbd depending on the distro).

    3) if that's up and working enter TESTPARM which should verify that your samba config is fine

    4) disable Linux firewall while conducting the test.

    5) if you haven't added your user to the SAMBA system add it with (as root) smbpasswd -a username

    6) username should be same as Windows username - note we are dealing with HOME networks here

    7) example of a simple smbconf file - minimal security - but it will easily show the Windows machines. Note the file is in directory etc/samba

    The samba shares are then the 3 HDD's mounted on /mnt/DV1, /mnt/DV2 and mnt/DV3


    [global]
    max protocol = SMB3
    # can set it to SMB2 if you want experimental SMB2 support.
    #
    workgroup = WORKGROUP
    server string = Samba Server Version %v

    ; max protocol = SMB2

    log file = /var/log/samba/log.%m
    max log size = 50
    security = user
    passdb backend = tdbsam
    name resolve order = bcast host lmhosts wins

    load printers = yes
    cups options = raw

    ; printcap name = /etc/printcap
    # obtain a list of printers automatically on UNIX System V systems:
    ; printcap name = lpstat
    ; printing = cups


    #============================ Share Definitions ==============================

    [homes]
    comment = Home Directories
    browseable = yes
    writable = yes
    valid users = %S

    [printers]
    comment = All Printers
    path = /var/spool/samba
    browseable = no
    guest ok = no
    writable = no
    printable = yes


    [HDD1]
    comment HDD1
    path = /mnt/DV1
    guest ok = yes
    writeable = yes
    browseable = yes

    [HDD2]
    comment HDD2
    path = /mnt/DV2
    guest ok = yes
    writeable = yes
    browseable = yes

    [HDD3]
    comment HDD3
    path = /mnt/DV3
    guest ok = yes
    writeable = yes
    browseable = yes

    I've assumed workgroup is the name of your Windows workgroup.

    Now we check to see if SAMBA is serving the files --no point in messing around in Windows if samba isn't even passing the files across to windows -- OK you are running your system headless but you should still be able to logon to it via RDP / SSH / Telnet or similar from Windows. If you have a GUI on your linux system install package XRDP and then you can use Windows RDP to connect just as if it were connecting to another Windows machine.

    Here from Linux server brownbear (the underlined one) you see the 3 shares HDD1/2/3 and ALL the machines this SAMBA connection can service (should be ALL the machines in the workgroup (called workgroup) defined in the smb configuration file. If any Windows machine is missing then you've a problem here right at the start - but in general Linux networking tends to work FIRST TIME !!!.

    A common error in Windows is to forget to check in the Windows client if Network Discover is enabled.

    Click image for larger version. 

Name:	snapshot10.png 
Views:	2 
Size:	104.3 KB 
ID:	122087

    Now we'll look at a Windows machine (I'm running W10 X64 pro_ and see what the network shows for brownbear.


    Click image for larger version. 

Name:	snapshot11.png 
Views:	2 
Size:	70.7 KB 
ID:	122086

    Once you've got shares working then mess around with security etc etc.

    Note also in a home network everything should be on the same subnet --e.g all on 192.168.1.xx with gateway 192.168.1.1 or whatever for your Routers settings are --its usually 192.168.1.xx or 192.168.0.xx for domestic grade routers / cable boxes.

    Hint also - if your server is re-booted very infrequently --mine is - then just start SAMBA manually instead of any weird scripts with a load of "&"'s in them.

    On most distros it's simple as root - systemctl start smb(d.service and systemctl start smb(d).service

    also of course check that the fileshares / Disk volumes / directories are actually mounted !!!! and accessible.

    Cheers
    jimbo
    Last edited by jimbo45; 20 Feb 2017 at 10:56.
      My ComputerSystem Spec
  3.    21 Feb 2017 #33
    Join Date : Nov 2014
    The Netherlands
    Posts : 628
    Win 10 Pro x64 1607 (Build 14393.953)

    Hi @jimbo45,

    Thanks for your comprehensive workflow, if this is the way to troubleshoot his issue with the U-server, I for sure was looking in the wrong direction trying to help @noxsoldier.

    Well anyway, let's hope he's returning here soon and is able to sort out the issue. Of course I'll be watching and following this thread with great interest!

    Cheers
      My ComputerSystem Spec
  4.    25 Feb 2017 #34
    Join Date : Nov 2014
    The Netherlands
    Posts : 628
    Win 10 Pro x64 1607 (Build 14393.953)

    Hi @noxsoldier, have you already managed to solve your issue(s) with the help offered by @jimbo45? That would be nice news around this block!

    Cheers
      My ComputerSystem Spec

 
Page 4 of 4 FirstFirst ... 234


Similar Threads
Thread Forum
Creating a samba share in windows 10
I've been using unauthenticated samba share on my computer for well over a decade using windows 7, vista, and XP (and maybe even further back) to network with various devices in another room via an ethernet cable. I believe Microsoft removed...
Network and Sharing
Issues seeing Samba share from Kubuntu server under Windows 10
All, In my home network I have several computers. A Kubuntu Linux server, a windows 10 laptop and a window 8.1 desktop. Under Kubuntu I have setup several Samba shares for things like videos/photos/music, etc. From the Kubuntu side everything...
Network and Sharing
Win10ProN cannot connect to samba network share
Hey folks, I've got an issue that's been bugging me since windows 7. I've got a debian server on my network running samba and plex. I usually add media to it through samba from my windows computers. Only now with my laptop, I'm having a strange...
Network and Sharing
Samba share doesn't work
Hi, I have Vbox with Ubuntu Server 14.04 LTS installed on it. My host is Win 10 (Version 10.0.10240 Build 10240). I've tried to get my samba share working for the whole day. I asked in #Windows, #ubuntu, #samba, #php, everywhere. I've googled...
Network and Sharing
BSOD mounting ISO natively from samba share
To reproduce: 1) You need a network share drive on another device that is mapped locally as a drive. 2) Place an ISO image of some kind in a location on that shared drive. 3) Attempt to open the ISO natively (double-click or right click->...
BSOD Crashes and Debugging
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 06:29.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums