1.    18 Feb 2017 #1
    Join Date : Jun 2016
    Posts : 6
    Windows 10

    Ethernet does not have valid configuration


    I have been having on-going Internet connection problems with Windows 10 for months. Initially running the Realtek driver repair program would fix the problem. Not any more. I have tried everything suggested from various posts to no avail. I have turned off everything but IP version 4. I just installed the latest driver from Realtek (10013_01172017). No luck. My windows 10 computer is a dual boot machine. Running LinuxMint 18.1 KDE accesses the Internet just fine every time. I am connecting to my cable company's modem via ethernet hard wired. I have rebooted the modem twice today.

    My ipconfig /all results are as follows:

    Microsoft Windows [Version 10.0.14393]
    (c) 2016 Microsoft Corporation. All rights reserved.

    C:\Users\saord>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : HB-III
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Ethernet:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
    Physical Address. . . . . . . . . : 40-8D-5C-56-3C-A4
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Autoconfiguration IPv4 Address. . : 169.254.11.46(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{1AAA851E-CD33-456E-B1C1-F22B480CFC8D}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    The IPv4 address listed above obviously does not connect to my ethernet modem. I would greatly appreciate any suggestions any of you might have to solve this problem.
      My ComputerSystem Spec
  2.    18 Feb 2017 #2

    When you get an APIPA address, that usually means DHCP is either not working or not available to the machine. There are oodles of threads here about fixing Internet access problems, but they take time and energy. You can try the network troubleshooter to see what it says (Type "trouble" in your Cortana search box, then click "Troubleshooting" on the resulting menu list; next, Click "Connect to the Internet" under "Network and Internet" there. It may or may not help.). If that doesn't work, please consider performing an in-place upgrade/repair install (tutorial link). In reading posts here for the last 8 months it seems to be the best bet to fix things relatively quickly and easily.
    HTH,
    --Ed--
      My ComputersSystem Spec
  3.    18 Feb 2017 #3
    Join Date : Jun 2016
    Posts : 6
    Windows 10
    Thread Starter

    Thanks for the response. In reading the thread on 'Repair Install of Windows' it states that you use the Media Creation Tool within Windows to download either the iso or the usb. Since I cannot connect to the Internet in Windows 10 this does not seem like a viable option.
      My ComputerSystem Spec
  4.    18 Feb 2017 #4
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,450
    windows 10

    Try setting a fixed IP see if it works then
      My ComputerSystem Spec
  5.    19 Feb 2017 #5

    Make a backup of your current system image, then you can try the reset your computer options (Settings, Update, Recovery, Reset this PC). If it works, this does not require Internet access, but it will create an image that lacks all of your current applications, preferences, and settings (that's why you need to back up your current state if you choose to take this path). It probably makes sense to go visit a friend who does have Internet access, take a USB drive with you, and use the Media Creation tool there to build yourself the repair install media.
    HTH,
    --Ed--
      My ComputersSystem Spec
  6.    20 Feb 2017 #6
    Join Date : Jun 2016
    Posts : 6
    Windows 10
    Thread Starter

    Thanks again for your help. I'll give that a try
      My ComputerSystem Spec
  7.    21 Feb 2017 #7
    Join Date : Jun 2016
    Posts : 6
    Windows 10
    Thread Starter

    Failure


    This morning I booted into Windows 10 to use my accounting program (the only reason I use Windows at all) and it successfully connected to the internet. I had made no changes in Windows and had not rebooted the cable modem--it just worked. Seeing this as an opportunity to act on the previous suggested fix to the connection problem I followed TenForums tutorial on "repair and install of Windows 10". As a result of that effort, now Windows will not boot at all. I get a "system thread exception not handled" error message. I have tried the restart option with built in troubleshooter twice with no luck. I tried the startup repair option to no avail. Under other potential actions Microsoft presents were 'Reset this PC', System Restore, System Image Recovery, Command Prompt, Startup Setting and 'Go back to previous built'. At that point I figured I had done enough damage so I turned off the computer and am now seeking advice as to how to proceed.
      My ComputerSystem Spec
  8.    21 Feb 2017 #8
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,450
    windows 10

    If you get the lates win10 iso https://www.microsoft.com/en-gb/soft...load/windows10 then do an upgrade its will keep all your setting software etc
      My ComputerSystem Spec
  9.    22 Feb 2017 #9
    Join Date : Jun 2016
    Posts : 6
    Windows 10
    Thread Starter

    Thanks for the quick response. I have downloaded the ISO file, but what do I do with it? Windows 10 won't boot so I can't follow the instructions in the TenForums for a "repair install of Windows 10".
      My ComputerSystem Spec
  10.    22 Mar 2017 #10
    Join Date : Jun 2016
    Posts : 6
    Windows 10
    Thread Starter

    Solved--The hard way


    After numerous attempts using all suggested methods over a period of several months I finally gave up. I reformatted the drive and reinstalled Windows 10 from my original Microsoft Disk. So far the system is working without any problems.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Ethernet doesn't have a valid IP configuration
So... I just updated from win 7 to win 10, as I got it for free. All went smoothly, but there was no ethernet connection. I'm running a custom built pc, connected to my router via ethernet cable. At first windows detected the cable, but said:...
Network and Sharing
Solved Ethernet doesn't have a valid IP configuration
Hello, I'm about 4 hours deep into trying to fix this. I've followed several forum posts with similar issues, with no luck. I've been running windows 10 on my PC with my current hardware (including modem/router) for about a year now with no...
Network and Sharing
Ethernet doesn't have valid IP configuration
I've been working on this for over two hours now. I have wifi on laptop. In Windows 10 I can't access internet on PC with Ethernet. On the same computer I have a Linux Mint partition and ethernet connection is fine there 160Mbps. I've unplugged...
Network and Sharing
Ethernet does not have a valid IP configuration
Hi guys, I am running Windows 10 demo version. I have problems connecting to the net. I am shown the error along the lines of "Ethernet does not have a valid IP configuration". From command prompt I run "ipconfig/all" and here is the...
Network and Sharing
Solved Ethernet doesn't have a valid IP configuration
8 hours ago my computer was connected via Ethernet and functioning fine during online gaming. This morning approx. 4 hours ago I awoke to notice the computer updated and restarted during my sleep. Now the network icon has an exclamation mark and...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:58.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums