Windows 10: "Modern" apps cannot connect to internet but all other apps can.

  1.    17 Feb 2017 #1

    "Modern" apps cannot connect to internet but all other apps can.

    I recently had an odd Trojan horse and, while it seems to have been sorted, some damage has been done in it's wake.

    For some reason I cannot use any Metro apps. Windows Store says there is no internet connection, Cortana says it cannot connect, Edge closes as soon as it is opened... You get the idea. Practically every Metro app is behaving like this and yet my internet connection is just fine outside of Metro apps.

    I'm not sure what to do here, I've tried a few different fixes for similar problems but nothing has helped. I did recently install Malware Bytes and Panda to clean up my system and everything was working before then (besides the obvious adware) so my guess is some sort of setting has gotten swept up in the search for dangerous files?

    Could anyone offer me any help/insight here? I get lonely without Cortana.
      My ComputerSystem Spec

  2. Posts : 6,831
    Windows 10 Pro x64 Build 1709
       17 Feb 2017 #2

    Hi CaptainBritish

    Interesting. In your title you mention other apps can access internet but Edge closes on start. What apps do work.?

    First I would shut down Windows completely by holding down shift key and clicking shutdown (not restart)

    If you are absolutely sure that the bugs are gone there are several troubleshooters and a reset that may help.

    Start => Setting => Network and Internet.

    On the right hand side scroll all the way down to bottom where you will see Network reset. This will cause you to loose your stored wireless password.

    I would also run these commands commands at Command Prompt(admin). Don't enter stuff in brackets, this is what the command does.

    ipconfig /flushdns (Clear the dns cache)
    nbtstat -RR (release and refresh NetBIOS names)
    netsh int ip reset (reset ip settings)
    netsh winsock reset (Reset Winsock Catalog)

    To gain access to trouble shooters

    Right click start, Click Control Panel, click System and Security, under Security and Maintenance tab, Trouble shoot common problems. When Window opens click on View all, over to the left in navigation pane.

      My ComputerSystem Spec

  3.    17 Feb 2017 #3

    Well, I've tried everything you suggested but nothing has made a difference. Troubleshooting doesn't detect any problems with my connection in any category, the errors seem isolated to "Metro" apps alone.

    Caledon Ken said: View Post
    Interesting. In your title you mention other apps can access internet but Edge closes on start. What apps do work.?
    By that I mean anything that is running under the new UWP format is somehow unable to get an internet connection. Cortana, the Windows Store, Edge (which as I said before is instantly crashing) and any other "Modern UI" app. If the program is installed traditionally on Windows such as the Chrome browser I am running now there are no issues at all.
      My ComputerSystem Spec

  4. Posts : 6,831
    Windows 10 Pro x64 Build 1709
       17 Feb 2017 #4

    You could try running

    sfc /scannow

    from command prompt(admin) to see if it is reporting issues?

      My ComputerSystem Spec

  5.    17 Feb 2017 #5

    Well, I ran it and it said there were issues that it could not automatically fix. The log file is here if it is of any use.
      My ComputerSystem Spec

  6. Posts : 6,831
    Windows 10 Pro x64 Build 1709
       17 Feb 2017 #6

    Thanks. I boiled the ocean down to this.


    There were numerous errors about "Overlapping ownership of directories" and quite a few Hash mismatches. Most seemed to be repaired.

    From what you sent me this looks like you've run SFC yesterday as well.

    It is stated it can take multiple runs to clear. That said in this last run it cannot repair the file Tokens_tts_en-us.xml

    For that same file there is an error message that the source file in the store is corrupted, Hash Mismatch.

    I would recommend you run sfc /scannow one more time, just to be sure. If it says it can't fix then I would use Option 1 in this tutorial

    DISM - Repair Windows 10 Image

    Others may have a different view on errors and repair process. In any event I would ensure that all my data is backed up off computer.
      My ComputerSystem Spec

  7.    18 Feb 2017 #7

    Those permissions errors were likely my fault, I had to do some sort of hacky workaround to get the original Cortana voice back. Regardless I've decided to just bite the bullet and format. Thanks for your help anyway.
      My ComputerSystem Spec


Related Threads
Hi, As the post title suggests, I am having trouble with the modern apps and connectivity. It feels like half my computer will connect to the internet, and the other half won't. Desktop apps like Chrome, Steam, Outlook, iTunes etc. all connect to...
Hi, I have quite big problem with my windows 10. I installed a fresh copy of win10 on a pc and everything was ok! After i joined computer to a domain my menu start, edge, calc, ms store are not working. There is a error in event log like: ...
I just upgraded a reasonably new Dell XPS from Win 8.1 to Windows 10 Home. The upgrade appeared to progress normally but when finished I couldn't find any "modern" apps and then I saw that when I clicked on the Store icon. I get a message that...
No "Modern" Apps Launching in Software and Apps
I'm running build 9879, and there's a pretty big issue. Whenever I try to launch any "Modern" app, the icon appears in the taskbar, and the loading screen appears for a flash of a second, then disappears. The icon stays, and when I try to click the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:00.
Find Us