Cannot access HTTPS sites through any device on my home network


  1. Posts : 1
    Windows 10 Pro x64
       #1

    Cannot access HTTPS sites through any device on my home network


    I'm having this problem and few more for about 2 months, asked my ISP, they renewed my IP and everything, they say it's not their problem. I cannot login to most of my social network accounts because it opens the site in http instead of https IMO, sometimes it works when I manually add https to the link. It started happening after my ISP gave me a new router, THOMSON. I tried to fix it by following many guides like reset this, reregister that etc. Also formated my HDD, still the same. When I open steam app on my phone it says that I'm not logged in, but when I connect to my friends wifi it's all okay. also when I open twitch app on my phone my router's US light starts blinking a lot, then I losevmy connection and have to restart my router. Asked my ISP to check into it, they said everything is fine by their side and that the router is okay, which I doubt. I did a hard reset on my router once, not long after I got it, could that be the issue, maybe I didn't configure it properly. I really don't know what to do, every tip is much appreciated.
      My Computer

  2. Caledon Ken's Avatar
    Posts : 20,932
    Windows 10 Pro x64 Version 1909
       #2

    Welcome to the TenForums @emin231

    Could you tell us exactly what Thomson router you have?

    Did your supplier give you a user name and password to connect to the Internet?
      My Computer

  3. Berton's Avatar
    Posts : 8,239
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint, Win7 Pro
       #3

    By hard reset, do you mean you pulled the power cord rather than merely turn the switch off or did you use a pointy thing to press the Reset button? Using the Reset should require setting the Router up again for such things as the password for the Router and the separate password for the Wireless. I just went through that with a client's D-Link Router yesterday.
      My Computer

  4. Samuria's Avatar
    Posts : 5,059
    windows 10
       #4

    Does your ISP set a specific MTU this problem is often wrong MTU does everything thing else work OK?
      My Computer

  5. slicendice's Avatar
    Posts : 4,533
    Windows 10 Pro x64 v2004 Build 19041.329 (Branch: Release Preview)
       #5

    I have a Thomson router here still for a few days. (I changed ISP so have to return the "borrowed" router soon) I can be of better help during the time before I have to send the thing back.

    Please do a full reset once more by powering the device off, then pressing the hard reset button for at least 10s, 30s just to be on the safe side. Then power it up again and see if the problem still exists.

    Report back once done these procedures.
      My Computers


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:18.
Find Us




Windows 10 Forums