Windows 10: LAN driver missing from Device Manager Solved

  1.    03 Jan 2017 #1

    LAN driver missing from Device Manager


    And so I cannot use a LAN connection, I can use wi-fi though. I've tried another LAN cable although I since found there is no LAN driver anyway.

    Windows 10 Anniversary Build, latest (I think).

    I can get LAN connection working OK on another laptop from the same router. I don't know what the driver is even so I'm not sure how I can download it.

    Thanks!
      My ComputerSystem Spec

  2.    03 Jan 2017 #2

    Give us the model number of your laptop then we'll sort out the driver that you need.
      My ComputerSystem Spec

  3.    03 Jan 2017 #3

    I should have thought of that!

    Envy 15 J2E80EA#ABU

    Thank you!
      My ComputerSystem Spec

  4.    03 Jan 2017 #4

    If it's one of these: HP ENVY 15-q005tx Notebook, here's a link to its maintenance and service guide: it says you've got a variety of WiFi module possibilities including:
    WLAN module:
    Broadcom BCM43142 802.11 bgn 1x1 Wi-Fi + BT4.0
    HMC Combo Adapter 753076-001
    Intel Dual Band Wireless-AC 3160 802.11ac 11 WiFi + BT 4.0 Combo Adapter 710662-001
    Ralink RT3290LE 802.11b/g/n 11 WiFi and Bluetooth 4.0 Combo Adapter 690020-001
    Realtek RTL8188EE 802.11bgn Wi-Fi Adapter 709848-001
    Intel Dual Band Wireless-AC 7260 802.11 ac 22 WiFi + BT 4.0 Combo Adapter 756753-001
    Intel Dual Band Wireless-AC 3160 802.11 ac 1x1 WiFi + BT 4.0 Combo Adapter 784638-001
    Intel Dual Band Wireless-AC 7260 802.11AC 2x2+ BT 4.0 Combo Adapter 784650-001
    Could you please open up Device Manager and get the info on your wireless adapter (or the vendor's hardware IDs if it's not clear what's what)?
    thanks,
    --Ed--
      My ComputersSystem Spec

  5.    03 Jan 2017 #5

    Hi Ed,

    This is my model:
    HP ENVY 15-j151sa Notebook PC (ENERGY STAR)Model #: J2E80ESerial #: 5CG43011ZY. This is brought up with HP 'Identify now' link.

    The only network adapter listed is a Ralink RT3290 802.11bgn wi-fi adapter.

    I have tried installing what 'seemed' to be the correct driver only for the install to halt with a message 'Realtek Network Controller was not found'. If deep sleep mode is enabled Please plug the cable. whatever that means! but I'm not even sure I had the right driver, just what HP told me I needed.
      My ComputerSystem Spec

  6.    03 Jan 2017 #6

    Try this driver unless you've already got version 5.0.57.0 (or higher) installed: Drivers & Software - HP Support Center.
    HTH,
    --Ed--
      My ComputersSystem Spec

  7.    03 Jan 2017 #7

    I managed to solve the problem which was that the Network controller had 'gone to sleep' hence the message. I discovered that the cure is to remove the laptop battery for about 10+ minutes and that wakes it up again!

    See here: Realtek’s network controller deep sleep mode issue | Adeel Ejaz: PHP, jQuery and Web

    There have been quite a few people with this problem.
      My ComputerSystem Spec

  8.    03 Jan 2017 #8

    Good for you! Glad you found a workable solution. Hope it doesn't happen too often, though.
    Best wishes,
    --Ed--
      My ComputersSystem Spec


 

Related Threads
Hi, title says it all. I'm having problems with my computer CD/DvD drive where its not shown in File Explorer As (D: ) or even shown in Device Manager. I have tried inserting a disk and ejecting it out and it works fine. However the drive is just...
Hi, On Windows 8. 1, I had no issues with this speaker. It's a JBL Charge. After upgrading to 10 it worked fine until a reboot when it failed to connect (it pairs, but won't connect, and the speaker doesn't appear as an audio-out option in Sound...
Hey, it's still possible to revert from Device Manager, and download a correct driver from the website. Normally it should show "Microsoft edition" or something like this, depends of the build of Windows 10
The driver rollback is grayed out (unavailable) for devices in the Device Manager. From what I find doing a search, the user must be an "Administrator" or it will be unavailable. My account is an Administrator account. What do I have to...
Dear friends , I upgraded my old pc (which is a compaq presario f505ea) to windows 10...Everything is ok but display is a " microsoft basic display" on device manager altough it's a geforce 6100 graphic card...I tried to install nvidia driver but...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:48.
Find Us