Page 9 of 29 FirstFirst ... 789101119 ... LastLast

  1. Joined : Dec 2015
    Posts : 12
    Win 10
       14 Dec 2015 #81

    Hi, I created a thread with a similar problem here

    shares on Win 7 PC - Windows 10 Forums

    I have now resolved this issue which "may" help other users who are having issues accessing shares on Vista/7/8/10.

    By the way I should say I don't use the HomeGroup feature so it's not a factor and apologies for this being a bit TL;DR bait.

    I have never had network/share issues on systems running any flavour of Windows 7 before now and it was only trying to get my Win 10 box to see a share on a Windows 7 box that I ran into problems. However I now realise this was more by luck than design

    Firstly the SMB fix described by DaveI was required (on the Win 10 box) as I got the access denied issue trying to open a network location (at least on the first attempt) usually I could open a network location on subsequent attempts and see (but not access) the shares. After disabling SMB 2/3 I could access network locations without errors but not access the shares due to not having the required permissions. I had never encountered this problem before. Oddly I "could" access the share on my Win 10 box from the Win 7 box but not the other way around.

    Normally to enable sharing, I click the Properties link on the item I want to share, go to the Sharing tab and Click the "Advanced Sharing" button (for me the SHARE button is always grayed out - I assume this is normal?)

    I then click the "Enable Share this Folder" box, then click the "Permissions" button.

    The Group or Username in this dialogue is always "Everyone" and I select the required permission check boxes and click OK.

    This has always worked up to now.

    However, I always set my PC's up with the SAME user/password as administrator as default and I also disable "Allow password protected sharing" and it's always worked I can access the shares from any pc to any other without entering a username/password and without any permissions issues - until I tried accessing my Win 7 box from my Win 10 box.

    Ok, so I couldn't access a share on my Win 7 box from Win 10 as I kept getting the "You do not have permission" issue. So I checked the sharing between this Win 7 box and another Win 7 box I had previously been able to access without issue and I was getting a Username/Password dialogue which I hadn't seen before. I was begining to think it was an update to 7 or something that was causing the issue.

    However I now know that accessing a share on computer (B) from computer (A) where the username is the same on both PC's will trigger a login dialogue (regardless or whether password protected sharing is enabled or not) if the password on either PC is different (different can also mean no password for one of the user instances as well).

    So I removed the password from the one account so both instances were password free and tried to access a share but I then got a "You do not have permission" message.

    I couldn't understand this as I'd given full control to "Everyone" and Everyone is everyone right? apparently not "Everyone" is a specific user group - i.e not authenticated, system,administrator or user (on the system where the share resides, I assume).

    I went into the Properties/Security tab of the share I was trying to access and sure enough the user group "Everyone" wasn't included in the "Group or Usernames" box although Authenticated users,SYSTEM,Administrators and Users were listed.

    So I had to click the "Edit" button then "Add" button and type "Everyone" (as that's the default user group when I originally enabled sharing) into the object box then click "OK"

    This usergroup now appears in the list on the Security tab and the list of permissions can be changed here as required.

    This explains why sharing worked originally as all PC's had the same user name/password and "Authenticated Users" was already in the Group/Username box of the Security tab.

    This explains why I couldn't access the share between the two Win 7 boxes as I had removed the password on one of them (but I hadn't tried to access a share since so I didn't realise it was broken).

    It also explains why I could access the Win 10 share from the Win 7 box as the Win 10 share was on an SD card and the default User Group in the security tab for this drive was already (and only) "Everyone"

    Networking, it's a bit of a bother....
      My System SpecsSystem Spec


  2. Joined : Oct 2014
    Posts : 1,284
    win 10 Insider
       14 Dec 2015 #82

    Yes, but at least win 7 is more predictable than win 10 1511.

    That Everyone with full access is important as you found. But there is no need to have same user/passwords. I've never done that but, hey, it's over to the network setter uperrer!
      My System SpecsSystem Spec


  3. Joined : Aug 2015
    Posts : 9
    Windows 10
       15 Dec 2015 #83

    KRL said: View Post
    Open the services menu by clicking start and then clicking RUN and typing 'services.msc' and pressing enter.


    Look for the following services in the list:

    DNS Client
    Function Discovery Provider Host
    Function Discovery Resource Publication
    Peer Networking Grouping
    HomeGroup Provider
    HomeGroup Listener
    SSDP Discovery
    UPnP Device Host

    Make sure they are set to AUTOMATIC START instead of MANUAL.

    Go down the list one by one and even if they are running do a mouse right click and SELECT "RESTART".

    On the ones that are showing a blank and not running right click and SELECT "START".

    That's all I did and all 3 Laptops are back in the Networking Panel and in the Homegroup WORKGROUP.
    After hours of searching, trying various fixes, not to mention consuming a half a 30 case of Coors light all three of my time wasters are again talking.
    My local brew distributor and I both Thank-You!

    Bill
    Last edited by BillPa; 15 Dec 2015 at 19:38.
      My System SpecsSystem Spec


  4. Joined : Dec 2015
    Posts : 12
    Win 10
       15 Dec 2015 #84

    linw said: View Post
    Yes, but at least win 7 is more predictable than win 10 1511.

    That Everyone with full access is important as you found. But there is no need to have same user/passwords. I've never done that but, hey, it's over to the network setter uperrer!
    The point I was making is that I now realise it only worked previously because I had the same username/password on each machine (there aren't any other users I just like like to have a P/W protected login on my mobile devices). I now assume it validated as a user or authenticated user which were pre-existing objects in the security tab.

    After I removed the password from one Win 7 box (a desktop), it broke - or at least forced a login request. Adding the Everyone user into the Security Tab fixes this (and is presumably now user independent).
      My System SpecsSystem Spec


  5. Joined : Aug 2015
    Posts : 9
    Windows 10
       15 Dec 2015 #85

    .Good news ( I think?) I changed the homegroup name to 'WORKGROUP" (default) from 'MSHOME' that I had created/used before on W7 and 10 OSsr and like magic all three boxes can now see each other. For whatever reason the HG name mattered is beyond my pay grade or level of expertise.
    Then I added permissions for "Everyone" and now I can browse the other boxes.

    Bill
    Last edited by BillPa; 15 Dec 2015 at 23:59.
      My System SpecsSystem Spec


  6. Joined : Dec 2015
    Posts : 2
    windows 7
       16 Dec 2015 #86

    I am not trying any more. Thankfully this is not my computer and I will go down to my file server and copy the flles I need to a usb drive. This is the third version of this I have tried and always ended up pissed off. At my age I will never be forced into it. I've had to remove it from friends windows 7 computers three times because they were tricked into installing it
      My System SpecsSystem Spec


  7. Joined : Dec 2015
    Posts : 2
    Win 10, Win 7
       16 Dec 2015 #87

    Hi All,

    My Win 10 (10586) machine could 'see' my 2 Win 7 machines but would throw an 80070035 error if I tried to connect to them.

    Both Win 7 machines could see and connect to the Win 10 machine

    Long story short, I added the IP addresses and names of my network shares to the Hosts file and the Win 10 machine could instantly see and connect to the Win 7 machines.

    Problem solved.

    I haven't tried using a PIN yet on the Win 10 machine. For now, I'm just glad that it's working.

    HTH -Kevin N
      My System SpecsSystem Spec


  8. Joined : Oct 2014
    Posts : 1,284
    win 10 Insider
       16 Dec 2015 #88

    Errrm, it is not really working. Your workaround is working but the fundamentals are still shot. And it is no better in today's new version 11082.
      My System SpecsSystem Spec


  9. Joined : Nov 2015
    Posts : 64
    Windows 10
       17 Dec 2015 #89

    BillPa said: View Post
    After hours of searching, trying various fixes, not to mention consuming a half a 30 case of Coors light all three of my time wasters are again talking.
    My local brew distributor and I both Thank-You!

    Bill

    Awesome Bill! Cheers on the Coors! ... ... ...
      My System SpecsSystem Spec


  10. Joined : Aug 2015
    Wales
    Posts : 164
    Win 10 Pro 64Bit
       17 Dec 2015 #90

    All

    Not sure if my problem is 100% the same but I discovered my lack of access between win 7 and win 10 pc's that was introduced recently, was down to firewall settings on the win 10 PC. (These were all working fine until the recent update) I haven't discovered which setting is causing the issue but turning the firewall off for Private networks solves the issue for me. (Not something I want to continue with! )

    Regards
    UKMedia
      My System SpecsSystem Spec


 
Page 9 of 29 FirstFirst ... 789101119 ... LastLast


Similar Threads
Thread Forum
i upgraded 2 computers to windows 10 and java doesnt work on both
i upgraded 2 computers to windows 10 and java doesnt work on both
Software and Apps
Business type workgroup Network
Finally installed Win10 on a computer with raw HD. It installed realtively easy. But I can not figure out how to setup a network to see two Win7 computers on a small business type workgroup. I disabled Homegroup since I am most comfortable...
Network and Sharing
Windows 9 Might Not Work on 32-Bit Computers Report
More
Windows 10 News
Steampunk computer computer cases/keyboards....
http://i.imgur.com/6tiV6Mo.jpg http://i.imgur.com/hDcLSPe.jpg http://i.imgur.com/5s8rLWI.jpg http://i.imgur.com/Q7UIuP6.jpg
Chillout Room
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:42.
Find Us
Twitter Facebook Google+



Windows 10 Forums