Windows 10: Ping OK but HTTP/HTTPS (mostly) failing Solved

Page 1 of 4 123 ... LastLast
  1.    02 Jan 2017 #1

    Ping OK but HTTP/HTTPS (mostly) failing


    Hi, I've got a Win 10 64 bit desktop PC. It's my workhorse and has been working fine.

    Recent changes: we moved our phone line and I started getting signal drop-out. My old NIC had no new drivers so we upgraded both the router and the wifi card moving from 802.2g to ac capability. That worked for a little while. Then I hit the issue that MS caused with their system update in early December when HTTP was dropping out.

    The short version of fixing that was:
    netsh winsock reset
    netsh int ip reset
    ipconfig /release
    ipconfig /renew
    ipconfig /flushdns

    When the fix came in KB3206632 it was installed on 14th December and the problem went away. I have been using my PC just fine since then.

    A couple of days ago I went to try to access some files on my NAS. I could not see the NAS in Explorer. I hadn't tried to use it for a while but I could ping it just fine. I simply couldn't see it in my explorer.

    I went to start to search for info to help online. As I did my browser started to freeze - or rather to timeout on even getting Google up. For a while I could see HTTPS pages like Facebook or Google Calendar but they too stopped working.

    I tried a reboot.
    I tried to reboot the router (though all other PCs in the house could access the net just fine - like the laptop I'm working on now).

    I tried the above sequnece of commands from before the MS patch went in.

    I tried uninstalling the adapter driver and scanning for hardware, then pointing it at the Archer T9E PCI Express Adapter driver that I had downloaded from TPLink which is the Archer T9E_V1_151026 driver. For some reason (probably because the driver is an exe) it installs by default a driver from 06/02/2014.

    I therefore tried uninstalling the adapter driver and rather than scanning for new hardware simply running the T9E_V1_151026 setup (as it is an executable). It ends up still installing a driver from 06/02/2014 version 6.30.223.228

    I've also gone into Settings>Networking and Internet>Network Reset.

    I've tried running without AVG Internet Security enabled in case it was a firewall issue.

    From an admin command prompt I can:
    ping 192.168.1.1 (router)
    ping bbc.co.uk
    ping google.co.uk
    ping 8.8.8.8
    ping 127.0.0.1

    I can therefore see various sites, DNS resolution seems to be happening.

    When I go to a browser (I've tried Firefox, which is my default, Chrome and Edge) and try to go to BBC - Home I get a message that the connection was reset whilst the page was loading. When I go to Facebook it just times out (though yesterday I did an update on Facebook and yet could not get to BBC. When I go to Google Calendar it times out, now, but this morning I couldn't get Google up but I could post an entry in my calendar and see it on my phone! So sometimes HTTPS things are working but HTTP ones are not at all. At this moment I can't get it to respond to any site, HTTP or HTTPS.

    I have tried toing to my router Dashboard (usual default 192.168.1.1 stuff) but it times out.

    When I try the network troubleshooter it just sits there and spins its wheels - it never times out, it just sits there.

    I'm not going via a proxy.

    I am very confused that "sometimes" HTTPS works, but other times it doesn't. I'm confused why I can ping by name or address but can get neither name nor address to work in the browser.

    My tecchie days are too long ago to be current on Win 10 so I'm sure there must be stuff I am missing but don't know what.

    Has anyone got any bright ideas, please? I'm stuck.
      My ComputerSystem Spec

  2.    02 Jan 2017 #2

    With so many strands in this bowl of "problem spaghetti" all so viciously intertwined, you may wish to ponder an in-place upgrade/repair install. See this excellent TenForums tutorial: Repair Install Windows 10 with an In-place Upgrade.
    HTH,
    --Ed--
      My ComputerSystem Spec

  3.    02 Jan 2017 #3

    Welcome to the forum. In stead of pinging try tracert is tracert BBC.co.UK. Have you checked to see if any other router is close by and on same channel that can do it. Is this ADSL or cable? It's a big jump from g type router to AC type 50 mg to 3 gigs so it can be your MTU is set wrong that would cause these problems
      My ComputerSystem Spec

  4.    02 Jan 2017 #4

    Thanks for the thoughts, gents.

    Ed, I wouldn't say it was spaghetti - I've simply given the back story for completeness. It's often something small that one overlooks, isn't it, hence giving the story. Over time lots of things change on a PC but these were the only recent changes. I could have come on here and taken it down to bare bones and said:

    I was getting 35Mbps down and 9Mbps upload on an ADSL link just a few days ago and despite changing nothing myself suddenly HTTP isn't working.

    I'm not discounting an in situ repair but it's a lot of hassle if this is something small that can be tweaked. Indeed that's why I've got for simpler stuff like doing a driver uninstall/reinstall and trying a network reset, rather than doing it to the whole of Windows.

    Samuria, tracert to bbc.co.uk or off to google.com works fine too. There's only one router I've got to play with. It's ADSL. You say the MTU might be set wrong - I've not changed it on the PC or on this laptop. This laptop is working (as is my wife's), the PC is not. Where do I check/change? I've gone into the connection properties and then to configure the adapter, I can't see anything that matches MTU in the Advanced Settings.

    Bear in mind this was working since the last upgrade from MS on the 16th December - I've not conciously changed anything in the settings. It only stopped on New Year's Eve.
      My ComputerSystem Spec

  5.    02 Jan 2017 #5

    Hmmm. You might consider visiting SpeedGuide.com and downloading and installing their TCPOptimizer package. If you let it optimize your system, it might fix something that's currently broken. It will address MTU issues as well as a bunch of other stuff. Check it out!
    HTH,
    --Ed--
      My ComputerSystem Spec

  6.    03 Jan 2017 #6

    Ed, well that's interesting - and not positive.

    I just tried the optimiser. As it started up and said "please wait, reading settings". Then it complained that "it is taking more time than usual to read current settings, you can continue waiting , or skip this step." I did leave it waiting for a while but it just sat there. So I skipped. I then set the connection speed to the advertised speed, chose the adapter and told it to go for optimal settings. The optimiser then asked if I wanted to apply settings and I said OK... and it just sat there spinning its wheels. When I tried clicking on the dialogue box it just comes up "not responding" in the title.

    So it looks like the stack is awry if it can neither read nor write values to it.
      My ComputerSystem Spec

  7.    03 Jan 2017 #7

    As an aside on the MTU - in the MTU/Latency tab of the TCP Optimizer it suggests MTU of 1492. The "optimal settings" button says it will leave the MTU at 1500 which is the default value.
      My ComputerSystem Spec

  8.    03 Jan 2017 #8

    Am running repair install now - it might save some time! (Shame I'll have to re-install all my purchased fonts...)
      My ComputerSystem Spec

  9.    03 Jan 2017 #9

    Sigh. Nope.

    Well, Ed, I tried the system repair and a couple of hours later I've got my machine and have gone to use the browser and I'm back exactly as I was before you suggested it (save for reinstalling fonts and getting any Windows Updates). I've also now (successfully) run the TCP Optimizer tool.

    Today, after the repair, I opened a browser (firefox) tried to surf to BBC.CO.UK and it said in the message space that it was "connected to www.bbc.co.uk" but then just sat there. I tried a few other sites. GMail connected fine. Google calendar connected fine. Google.co.uk just sat there. My own website just sat there. Facebook just sat there.

    I know it isn't just Firefox. I went to check and see if I could get latest Windows Updates and it is sitting saying "checking for updates..."

    I have however just run the Firefox refresh/reset (Refresh Firefox - reset add-ons and settings | Firefox Help) and restarted Firefox. Now I can't get to GMail or Google Calendar either.

    I'm still good to ping bbc.co.uk or 8.8.8.8 or facebook.com and tracert shows the route going out over my router.
      My ComputerSystem Spec

  10.    03 Jan 2017 #10

    Ok, this is just bonkers. I mean really bonkers.

    I've re-booted at each step in what I've done above. Having tried to do the "Windows Update" and failed I thought I'd try one more re-boot. As it shut down it told me not to turn off that it was doing things.

    Quite what it was doing I wasn't sure. However when I went back to do Windows Update when it powered up Windows told me there was a failed update.

    I asked it to try again. It started merrily downloading updates. Currently it is 11% through downloading: KB3209498 Adobe Flash Payer security update, KB3206632 Win 10 cumulative update, and KB3199986 Another Win10 update. It's slow but it is downloading.

    Why a *failed* update should make things work is beyond me.

    As it seemed to be doing downloads I went to my browser:
    Facebook - OK
    BBC - OK
    Gooogle - OK
    My router dashboard - OK
    Speedtest.net showing (amazingly) 40.09Mbps (the fastest I've seen on this PC ever) for download and whilst upload went to "connecting" and sat there, when I re-loaded the page I got a healthy 8.76Mbps upload speed too.

    I am holding my breath for what happens when those updates install. I'll let you know if it is still working when they're all done.
      My ComputerSystem Spec


 
Page 1 of 4 123 ... LastLast

Related Threads
Source: Google Online Security Blog: Heres to more HTTPS on the web!
Source: When to use a HTTP call instead of a WebSocket (or HTTP 2.0) | Building Apps for Windows
This issue arises randomly and only once has it ever recovered. Event viewer also does not show anything either. Restarting fixes this issue, but I would rather find out what caused this issue in the first place. I cannot connect to any sites...
Solved firefox and https in Browsers and Email
have the latest firefox installed but https web pages do not work on even the latest insider update. doesn't work desktop comp which is win 10 ver 1511 build 10586.63 this has been going on a few weeks now. uninstalled it and reinstalled same...
Failing to replace failing laptop hard drive in Performance & Maintenance
Toshiba C55 series with a failing hard drive. My first attempt was to clone the drives using my Acronis True Image 2015. Formatted the new drive and placed in the PC. Old HD in a USB drive enclosure. Booted from the TI "Bootable Rescue Media.."...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 09:15.
Find Us