Windows 10: Windows 10 partially losing network connection; Event Viewer entries


  1. Posts : 5
    Windows 10 Pro Anniversary Edition (build 14393), Brazilian Portuguese language
       20 Dec 2016 #1

    Windows 10 partially losing network connection; Event Viewer entries


    Sorry, I have searched before posting, and seen other threads about similar problems, both here and elsewhere, but they either described very specific and different situations or proposed solutions that I have already tried. In fact, I have tried everything I could think of or that I’ve found on-line.

    I keep losing my network connection all the time - but not completely: some things work, some don't. The tray icon remains OK, hovering the mouse over it shows “Internet access” and I can even successfully ping external IP addresses. Windows’ Network Troubleshooter invariably says it “can’t identify the problem.” In short, Windows thinks, shows, and insists that all is fine, but I can’t access anything. I can’t even access the router’s Web interface (regardless of browser used).

    This shows that it’s not a DNS problem, because I can’t access the router's IP Web address either (even though I can ping it). I have noticed that SNTP time sync keeps working (with NetTime, which uses DNS to resolve time server addresses), but HTTP, POP, SMTP, and Skype don’t work.

    My PC is a home-built desktop using the mainboard’s built-in network adapter, which is by Realtek (PCIe GBE Family Controller, says Device Manager). Other than the Internet connection, there is no LAN. I’ve been running Windows 10 Pro for over a year. Now it’s the Anniversary Edition, which was cleanly installed, but the problem was already happening before with the RTM version and I don’t think the Anniversary Edition itself is the problem.

    I have also heard of a recent Windows Update that caused similar problems, but I my problems started well before that, a few months ago (still with the RTM version), possibly after some other Windows Update (they are always current here). At that time, I was living at a house with WiFi Internet connection supplied by the landlord. That connection was very slow and unreliable, and I thought my problems came from that.

    Now, however, I’ve moved and have an exclusive blazing-fast 50 Mbps fiber optic connection. The router is also WiFi-capable, but the problem happens all the same whether I use WiFi or the Ethernet cable. The LEDs on the router are all fine, and when I can access the user interface, everything is OK. But the problem is getting worse, because before I moved, my network connection used to restore itself spontaneously after a few minutes, until the next random failure. Now the only remedy is a reboot, which solves the problem for a while, then I have to reboot again. I use my PC for work and it’s a big annoyance having to save everything and reboot several times a day.

    What I have tried (all in vain):

    • Making sure that energy saving is off for the network and WiFi adapters in Device Manager;
    • Checking that Windows’ own drivers are up-to-date (Device Manager says they are);
    • Downloading and installing the latest network drivers from Realtek (and D-Link for the WiFi dongle);
    • Deleting and reinstalling the network adapters in Device Manager;
    • Checking if there was some BIOS parameter that could be interfering with the network (there wasn’t, other than “Enable LAN,” and it is enabled);
    • Reconfiguring DNS servers to be obtained automatically, or to use the router’s address, or to point both directly and via the router to the ISP’s default server, to Google DNS and to OpenDNS; oddly, browsers report name resolution problems, but not Windows’ Network Troubleshooter;
    • Removing the WiFi dongle when using Ethernet;
    • Disabling my security software (Comodo Firewall and Kaspersky Anti-Virus, both the latest and updated) — by the way, no malware is reported after a complete scan;
    • Resetting the router and switching the Ethernet cable between ports (but as mentioned before, the problem also happens with WiFi);
    • Alternating my PC between DHCP and a fixed IP address;
    • Resetting the TCP stack, and using every possible netsh and ipconfig variant, as well as sfc /scannow to check for system corruption.

    The only two things I can think of that I haven’t tried yet are installing a separate PCI network card, and giving up Windows 10 and returning to 8.1 or 7. Understandably, I want to avoid both, especially the latter.

    Because Windows believes and shows that everything is normal (even though it isn’t), the only vague clue I’ve got is some strange errors in Event Viewer. I use a (Brazilian) Portuguese-language version of Windows, so here goes my translation:

    “Closing a UDP socket with local port number 55740 in process 1600 is taking longer than expected. (...) This usually happens due to bad behavior of network drivers. (...)”


    Process 1600 was an svchost instance running four services: NlaSvc, LanmanWorkstation, DNScache, and CryptSvc. As you can see, the first three are directly network-related, and the last one indirectly so.

    Any hint? Thanks a lot!
      My ComputerSystem Spec


  2. Posts : 5
    Windows 10 Pro Anniversary Edition (build 14393), Brazilian Portuguese language
    Thread Starter
       26 Dec 2016 #2

    Well, I've found the culprit and solved my problem. I noticed that the problem happened most often when I visited two Web sites: a local news site and Filehippo.com. Both are full of ads, traffic analyzers, data miners, the usual fare in today's Web sites. And I forgot that, in addition to Kaspersky and Comodo, I had a third so-called "security" program: a home banking "security module" that is mandatory to access my bank account via the Web. (Unfortunately, all major banks in Brazil use the same "security" system for their Internet home banking, with only very minor customizations.)

    This program has a very bad reputation for causing all sorts of problems. It's very heavy-handed and paternalistic, runs all the time even when the home banking isn't in use, consumes considerable CPU resources, and interferes with a lot of other software. It uses rootkit techniques and behaves like one, but they managed to whitelist it in all antimalware systems. And apparently, it panicked when a connection to some data mining site was detected. The problem is, such sites and connections are a sad fact of life. Either you accept them and move on, or you can go to Walden Pond and disconnect yourself from the Internet altogether.

    I uninstalled the software and everything is fine now. That was easier said than done - it stubbornly protects itself from uninstalling, and I had to boot to Linux (which ignores Windows file security) to delete leftovers that insisted on loading the "legit" rootkit even after supposedly uninstalled. But I finally succeeded and my problem is now solved. Now I have another one - not being able to access my bank account from the PC any more. But that convenience is not worth the much greater hassle it caused me.
      My ComputerSystem Spec

  3.    26 Dec 2016 #3

    Are you able to install the banking app in a VM? If that will work, you could create a VM purely for banking use and run it only when you needed banking access. If that won't work, you might want to set up a dual boot situation so that you boot into the account with the low-level banking utility installed only when you need to do banking. Just some suggestions that I hope you find helpful. If not, please ignore them.
    Happy holidays!
    --Ed--
      My ComputerSystem Spec


  4. Posts : 5
    Windows 10 Pro Anniversary Edition (build 14393), Brazilian Portuguese language
    Thread Starter
       26 Dec 2016 #4

    Ed, I've tried a VM. It would be the perfect solution. Unfortunately, my bank's "security policy" forbids VMs. The first login went OK, but in the second one my Internet access to the banking system was blocked and I had to go to the physical branch to restore it. There they told me they don't allow it, I don't know why. I don't even know how their system detected I was using a VM. And dual-boot would be too much of a hassle and an overhead - lots of disk space and another OS to maintain just because of that, it's not worth it.

    They have good mobile apps (even including barcode scanning to pay bills and such), but my smartphone was stolen and I haven't been able to replace it yet, so that's not an option at the moment. Well, they have several ATMs near my home where I can do things as well, and I also have good old telephone access, so it's not that bad.
      My ComputerSystem Spec

  5.    26 Dec 2016 #5

    I'd suggest going the dual-boot route, and installing the Windows program only on one of the two images you set up. Then, you will only suffer from the impact of your banking application when you need it and don't have to suffer from it otherwise. You'll lose some time to rebooting to switch from one usage scenario to another, but that lost time may very well be returned to you thanks to improved performance when doing normal Windows stuff.
    Again, hope this helps!
    --Ed--
      My ComputerSystem Spec


  6. Posts : 5
    Windows 10 Pro Anniversary Edition (build 14393), Brazilian Portuguese language
    Thread Starter
       01 Jan 2017 #6

    I celebrated too soon. The problem is still happening, albeit less often now - only once every day or two. So, I've just marked the thread again as unsolved, though I'm pessimistic that a solution will be found here.

    The problem probably has more than one trigger, and that Internet banking module likely provided some of them, as the problem has no doubt become less frequent since uninstalling it. But it's still happening, usually when I access one of two sites: a local news site and Filehippo.com.

    My guess and theory is that either Windows 10's network stack has an obscure and hard-to-pinpoint kind of bug that happens only in some very specific conditions, or Realtek's network driver has one (but I've seen similar problems described with other manufacturers' systems in other forums). Either program must freeze or loop some routine when a certain sequence of network requests or traffic occurs. It's beyond my resources and skill to trace exactly what causes that, especially at the level of detail that investigating this bug would require. I hope Microsoft investigates this.

    As for the Internet banking module, no way I'm going to go through all the hassle of installing, updating, and maintaining a separate Windows partition just for that. I'd rather do without it and solve my banking problems by good old telephone, by ATM or in person at the branch, as the case may be.

    Thanks a lot, anyway.
      My ComputerSystem Spec

  7.    02 Jan 2017 #7

    Are you sure it is your computer and not your local network gear? Do other devices on your network also lose connection at the same time?

    Did this computer have a clean Windows 10 install, or was it an upgrade? Tell us about your computer hardware.

    Next step, I'd use msconfig to do a diagnostic startup with basic services and networking only, and run in that mode for a few days to see if the problem happens again.

    Also, I'd try to reset the network stack: How to reset all your Windows 10 network adapters with just 6 clicks | Digital Citizen
      My ComputerSystem Spec


  8. Posts : 5
    Windows 10 Pro Anniversary Edition (build 14393), Brazilian Portuguese language
    Thread Starter
       02 Jan 2017 #8

    John, all your questions had already been answered in my original posting. I'm sure it's the computer because: (1) I've just moved, the Internet connection was completely different in the two places, and the problem happens all the same, and (2) the problem goes away temporarily as soon as I reboot, without doing anything with the router.

    There are no other devices in my network, there is no LAN, and as I explained above, some forms of connection (direct ping to IP addresses, SNTP) still keep working when the problem happens. It happens both with Ethernet and WiFi, but I can't test WiFi with a phone because my smartphone was stolen and my provisional replacement phone is a very basic one that doesn't support WiFi. I believe, however, that it would be normal.Windows 10 was cleanly installed (even the Anniversary Edition was), the PC is a home build with no bundled software, and my complete hardware configuratiion can be seen clicking on "My System Specs" in my postings. What's not there (but I mentioned above) is that it uses an integrated on-board network adapter by Realtek.

    Running the PC with basic services is not really an option, because I need the PC fully functional for my work and can't keep it running for days in that mode until the problem (possibly) reappears. And in my original posting I mentioned having reset the network stack - more than once, to no avail. Only, I hadn't used Windows 10's "Network Reset" feature - I did it manually uninstalling the network adapter in Device Manager and letting it reinstall it, then netsh winsock reset followed by netsh int ip reset, ipconfig /release and /renew.

    I've just reset the network again, this time using the configuration window. So far, so good, but as the fault is intermittent and unpredictable, I can't tell if it has made any difference - probably not, judging from my previous experience.
      My ComputerSystem Spec


 

Related Threads
Performance & Maintenance Clear All Event Logs in Event Viewer in Windows in Tutorials
How to Clear All Event Logs in Event Viewer in Windows Event Viewer is a tool that displays detailed information as event logs about significant events on your PC. Event logs are special files that record significant events on your PC, such as...
Upgrading from win 8.1 Pro to win10. Seemed to be going well and then saw lost internet connection in systray. Troubleshooting came up with "windows sockets registry entries required for network connection are missing". Can anyone help resolving...
Hello everyone, I keep seeing this error appear several times a day, even during idle, in my Event Viewer. I did a clean install of build 10586 less than a month ago. I'm not having any overt issues yet, but the error is disturbing. ...
EDIT: ARGH, sorry, meant to post this in General Discussion forum, I have no idea if it is a network issue. Hello everyone, I keep seeing this error appear several times a day, even during idle, in my Event Viewer. I did a clean install of...
Clearing event viewer entries in General Support
How can I construct a .bat file to clear entries in the event viewer. Thanks
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:25.
Find Us