I am frustrated beyond belief. I have spent a minimum of 10 hours attempting to install Homegroup on my Windows 7 and Win 10 machines - 3 desktops ( 1 Win 10; 2 Win 7) and 2 laptops ( 1 Win 10; 1 Win 7).
After reading how simple it was to connect my Windows devices, I followed the very simple instructions on the Microsoft site and (surprise!), I immediately ran into a brick wall. Each machine wanted to be *the* Homegroup machine. After reading some more forum posts, I found out how to remove Homegroup from the wannabies and set up just one desktop as the “Alpha” machine and how the others could be connected to it.
My next roadblock was that going through the same simple Homegroup set up procedure, every stinking one of the machines I attempted to tie into Alpha did not display the necessary “Join Now”” option.
Hour after hour was spent reading forums and posts of how others were baffled and stopped and how some fixed their issues. This gave me the chance to venture into settings and system checks I never dreamed of but I diligently pushed forward to ensure my settings were audited and changed if necessary. As a note, I did not find any settings on my machines needed changing. Nothing helped!
So where to go from here? After sleeping on it, the following morning I asked Goggle one more time, WTF was wrong and why was there no “Join Now”” option showing. Just by pure luck, I noticed one post back in 2011 on a forum that blamed BitDefender for blocking the Homegroup “Join Now” process. Since I had just spent a couple of hours the week before installing BitDefender 2017 on all my computers, I said a few choice words (and a few hopeful words) and set about uninstalling BD on my Alpha desktop and on two of my other desktops.
Following the uninstall process on these machines, I went through the Homegroup set up process again on my Alpha desktop. This time, I rejoiced because the “Join Now”” option now showed on desktop # 2 (Win 7 64 bit Home). Yesssssss! I clicked on ““Join Now” and followed by entering the Alpha desktop Homegroup Password on the next screen and clicked OK. I anxiously watched the little moving light run across the window telling me the computer was processing my request. Unfortunately, after what seemed to be 10 minutes, the light stopped moving and a pop up appeared that announced, “Windows cannot set up a Homegroup on this computer”. So I tried again with the same result.
So this is called simplicity, huh? After screaming a few more choice curses, I tried the same with desktop #3 (Win 7 64 bit Home). Same message: “Windows cannot set up a Homegroup on this computer”. Talk about being disappointed, disgusted, and pissed off!! I found myself wishing I could get my hands around the neck of the Microsoft weenie that wrote: “Microsoft included HomeGroup to allow Windows devices to share resources with other PCs on a local network with an easy to set up approach that anyone can use.” GRRRR!
So I ask the reader(s) of this post, where do I go from here? I hesitate to ask because it is likely the suggestions will be something I’ve already tried…but….maybe someone will suggest something that will work. Fire away. Thanks in advance.