Windows 10: Router NOT showing up in Network Infrastructure

  1.    29 Nov 2016 #1

    Router NOT showing up in Network Infrastructure

    I have three computers on my home network. Computer #1 is connected to my Cisco DPQ3925 router via ethernet, as is computer #2 via WiFi. I can logon to the router’s web administration page via a web browser on both of those computers. Computer #3 is also connected to the same router via ethernet, and, up until recently, I was able to access the router’s admin page on it as well; no problem. But now, on computer #3, when I type (or in the address bar of the web browser (or use the “router123” web page,) I am redirected to the Microsoft Windows Internet Information Services web page. I’ve used Edge, IE, Firefox, and Google Chrome, all with the same result.
    There is no entry in the “Hosts” file causing this redirection. I’ve consulted my ISP’s technical support twice and they have been unable to solve the issue (Cisco says the ISP owns the router and it uses the ISP’s software.) I’ve exchanged the router for an identical substitute and have the same problem. I’ve reset both the old and the new routers to factory defaults, and upgraded the firmware: No improvement. I’ve reset the winsock, and released and renewed the IP address (although I’m using static IPs on all my devices.) Clearly, something has changed on computer #3, but I have no idea what or when, and, since everything else works fine, I’m hesitant to do a restore to an earlier time.
    I’ve come to suspect that the problem lies in the fact that, despite being able to access the both my home network and the internet, computer #3 is not “seeing” the router. For example, both computers #1&2 list “Cisco DPQ3925” under Network Infrastructure in their respective Network Explorers. However, computer #3 does not. It can ping the router, and private network discovery and file/printer sharing are turned on. I’ve turned off the Windows firewall and Windows Defender. The Server service, all the Network services, and all three “Peer” and all three “Diagnostic” services are running. Still the router does not appear in #3’s Network Explorer. I’ve typed “\\Cisco DPQ3925”, but am told “Windows cannot access \\Cisco DPQ3925,” which, as I understand it, means, as far as computer #3 is concerned, the router does not exist. However, I am also given error code 0x80004005, which, according to various sources, could mean a missing DLL or corrupted Registry (I update the computer, run Windows Malicious Software Removal Tool, and clean the Registry with CCleaner regularly.) And, when I ran the diagnostics, I was told “the DNS server might be unavailable.” However, the DNS service is up and running.
    I’m at my wits end. Can anyone help me?
    • Is there a connection between this failure to list the router in the Network Explorer and my inability to access the router’s admin page?
    • What could be making the router “invisible” to the Network Explorer, and how can I change that?
    • Does the fact that Windows “cannot access \\Cisco DPQ3925” confirm that it cannot see the router because it doesn’t think it’s there? If so, what can I do?
    • Does error 0x80004005 mean there’s a missing/corrupt DLL or Registry file? If so, how do I go about finding/repairing the problem file?
    • Is it caused by a missing “share,” and if so how do I create one?
    • Do I need to “mount” the router on the C:/ drive? If so, how?
    • Any other ideas?
    Please help, I’m at a complete loss and nobody I’ve consulted has a clue! Thanks in advance for any advice/guidance you might give.
      My ComputerSystem Spec

  2.    29 Nov 2016 #2

    Welcome to the forum. on the faulty one open a cmd prompt type ipconfig /all then tracert post results
      My ComputerSystem Spec


Related Threads
This week I upgraded to a new router. While fighting some unexpected connectivity problems I found that network discovery had been turned off on all 3 of my computers. Should I have anticipated this? I can't think of any reason Windows would...
How to secure your router and home network | PCWorld
Windows 10 Not Showing my router in Network and Sharing
Hey so I decided to take the plunge and upgrade from windows 7 professional 64bit to windows 10 pro and safe to say I am not impressed so far, boot times are 2x as long as windows 7 and the wifi list is showing it seems every single damn router in...
Hi i have been suffering slow WiFi speeds for a while now and sky have replaced my router. I have two computers both running windows 10 with the latest build Now since i started with this router i have lost my home network and i have not...
Ever since i upgraded to the latest version of windows 10 my Ethernet has been broken i have tried installing the drivers from intel directly it still doesn't work. If anyone has any possible solutions help would be appreciated and if more...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 18:31.
Find Us