Cannot install D Link modem , windows not recognizing the drive


  1. Posts : 1
    Windows 10
       #1

    Cannot install D Link modem , windows not recognizing the drive


    Please see the screenshot below:

    https://i.stack.imgur.com/gOhPm.jpg

    The first time I inserted the modem it showed in the File Explorer view. After that first time, when I tried to insert the modem again it is showing as the black D drive icon. I tried to fix the thing via the Device Manager, but it is still not showing.

    What should be done to resolve this issue?

    Look at my D Drive in the screenshot , it is not recognizing the USB device
      My Computer


  2. Posts : 72
    Windows 10 Home x64 v1511, many others virtualized
       #2

    Same problem with DWM-157, after two days, it stopped to show its filesystem with installation files. Replaced under warranty but I'm not sure how long it will work.

    Try to plug it in different computer; in the case of failure ask for replacement/refund.

    Also you should know its behavior:
    - while plugging it in usb port it shows content of its "virtual cd" for software installation
    - if you install it, run Connection Manager and connect to 3G network then the "virtual cd" disappears, it will look as on your screenshot
    - to gain access to its filesystem again, you have to 1. disconnect from 3g, 2. unplug the modem completely, 3. plug it in again.
    It is by design, probably to avoid overloading of its internal microcontroller, but switching between two modes looks a little bit unreliable...
    Last edited by valihrach; 27 Nov 2016 at 06:04.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:43.
Find Us




Windows 10 Forums