Page 1 of 3 123 LastLast

  1. Joined : Nov 2016
    Posts : 11
    Windows 10
       3 Weeks Ago #1

    Wifi Network Adaptor disappearing - HW or SW? How to fix?


    Hi

    I'm having wifi problems with my lappy, but I can't figure-out whether it is hardware or software. There is evidence to suggest that recent versions of Windows 10 have been causing wifi problems. If the problem _is_ with Windows and they are going to fix it, then I can stop worrying about trying to fix the hardware (I am travelling abroad and it is near-impossible to find expertise/parts/tools).


    Gory Details:

    System: Levono Yoga2 Pro laptop. Intel Core i7-4500U. 8GB RAM. Windows 10 64 bit.
    I have been using Windows 10 since it came out without any problems. I have been keeping it updated.

    Precursor to this problem: On 4th November 2016, mid-session, apropos of nothing, my wifi stopped seeing the wifi network it was connected to; or any other wifi networks. (My phone could see plenty). This was evidenced in the Taskbar, Action centre, Settings dialogs of the PC. The Windows version was upto date at the time, but downloading the next week's Microsoft Patch Tuesday updates (9th Nov) fixed the problem. System working AOK. Yay.
    (MS update: KB3200970 "Addressed issue with the system tray showing no Wi-Fi connection even when Wi-Fi is present")

    System fixed - I made a system-restore point.

    The "fix" held for 24 hours, then a new, more severe problem started occurring (='the current problem').

    Current problem: After 3 to 5 hours of normal, troublefree operation, the PC stops seeing the wifi entirely. Any menu options associated with wifi networking disappear entirely. The Device Manager can no longer see the Network Adapter (Intel Wireless-N 7260) or its driver software. (That statement is somewhat summmarised - see Note 1 at the bottom of this post for more details).

    None of the Events in Event Viewer explain the disappearing Network Adapter.

    If I do a (whole) system restore back to my restore point, then everything is fine-and-dandy for a few hours, then the Network Adapter disappears again, along with any chance of seeing any wifi controls.

    System Restore consistently fixes it for a few hours. Then the Network (adapter) consistently disappears again.

    - - -

    So, is that hardware or software?

    One might think it is temperture/overheating related, but the problem also once occurred overnight when the PC was switched off (it was fine when I went to bed and switched it off, but was 'broken' when I switched it on again in the morning).

    One might think it is Virus related, but everything shows-up clean in MBAM and Avast.

    If it is a hardware problem, why would a system restore (to a point a few days ago) fix it?

    I'm thinking/hoping that the problem is caused by recent versions of Windows 10 (f,g below). But I can't find examples of other people suffering.

    If it _is_ caused by the OS, how does one inform Microsoft about it? (I don't want to join the 'Insiders Community')


    Any ideas?

    TIA


    -----------------------------------------
    p.s. I have done as much diagnostics as possible - gory details here:

    Note: the text "Result: FAIL" means that after a few hours of normal operation, AOK, the Intel Wireless-N 7260 Network Adapter can suddenly not be detected and any wifi activity/option becomes unavailable. Restart doesn't help. Restoring the system to a previous state fixes the problem (for a few hours).

    Scenarios a-e all have the wifi switched on and connected to a wifi network.
    a) System status up-to-date at 10 Nov. Result: FAIL

    b) System status reverted to a Restore Point made in OCTOBER 2016: Result: FAIL

    c) System status up-to-date at 10 Nov. Updated Network Adapter DRIVER to a newer version found by Device Manager (but not listed in the manufacturer's website's list of drivers). Result: FAIL

    d) System status reverted to a Restore Point made in AUGUST. Retained old NA driver. Downloaded and applied November 9th MS Updates and updated Browser (Firefox) Version and Virus definitions: Result: FAIL

    e) System status reverted to a Restore Point made in August. Retained old NA driver. Update Browser (Firefox) Version and Virus definitions, but DID NOT download/apply November 9th MS Update: Result: RUNS FINE FOR THE 4 HOURS UNTIL MS FORCES THE LATEST MS OS UPDATES TO BE APPLIED, then runs OK for a few hours then FAILs.

    .

    Scenarios f-g have the wifi switched OFF; or switched on but not connected to a wifi network; so that Automatic Updates can't be forced onto the computer.

    f) System status reverted to a Restore Point made in August. Wifi switched OFF. Result: RUNS FINE FOR THE 14 hours I tested it. (i.e. the Network Adapter appears to be fine, as reported by the Device Manager)

    ...

    g) (follows on from (f))... Wifi now switched ON but options set to "forget" known wifi networks, (so wifi is ON and polling nearby networks, but is not connected to any of them). Result: RUNS FINE FOR THE 6 hours I have (so far) tested it. (i.e. the Network Adapter appears to be fine as reported by the Device Manager)


    Conclusion: f and g seem to suggest that the problem arises from later (current) versions of Windows 10. But this is inconclusive, because in scenario (f), the wifi card is not being used and and (g) it isn't being used for sending/receiving internet traffic

    (N.B. I am abroad and using my hotel's wifi network(s) to try and use the internet. I have no control over the network itself).

    ----------------------

    Note 1:

    When I say "The device manager can no longer see the Network Adapter" - this is a _summary_ of what happens - infact, it seems to go through 4 separate stages:

    1) normal operation - everything AOK.
    2) The PC reports it is still seeing the wifi connnection that it is/was connected to, but is seeing no other wifi networks. The wifi network it connected to can no longer send/receive any data
    3) The Device Manager shows a yellow warning triangle on Network adapters> Intel Wireless-N 7260, and 'Properties' shows "No drivers are installed for this device."
    4a) The Device Manager shows a yellow warning triangle on Network adapters> Intel Wireless-N 7260 and Properties shows "This device cannot start. (Code 10). This device does not exist."
    or
    4b) Device Manager, Network adapters> doesn't show Intel Wireless-N 7260 at all.

    A few minutes pass between each step through the stages occurring. Other apps running on the PC (e.g. mp3 player) freeze up for a couple of seconds when each stage changes to the next.
      My System SpecsSystem Spec


  2. Joined : May 2016
    Posts : 524
    Windows 10
       3 Weeks Ago #2

    I suggest you to go to Device Manager and Uninstall Driver from there. If there is a box "Delete Driver Software....." check it also.
    Go to Programs and Features and uninstall Intel Software for the Card.
    Reboot and do NOT install any Driver.
    Windows should Install Default Drivers for Card automatically. Check it in Device Manager. If not, Update Driver by means of Search on-line.
    That should solve your problem.

    Seems that updated Drives Packages from Intel are not working very well in W10 AU, I think MS did change a lot of things in WiFi and some things from previous OS are not working any longer, for example, the Ad-Hoc feature does not work any longer and WLAN AutoConfig (aka Intel ZeroConfig) is giving errors in Event Viewer.
      My System SpecsSystem Spec


  3. Joined : Nov 2016
    Posts : 11
    Windows 10
       3 Weeks Ago #3

    Hi
    thanks for the reply. Actually I had deleted the drivers from Device Manager previously, but I forgot to mention it! I didn't previously delete anything from Programs and Features.

    Now I have deleted drivers (from Device Manager again) and deleted "Intel PROSet/Wireless Software (v18.40.4)" from Programs and Features. Restarting the machine has replaced the drivers as expected, but not the Software. Should it have ? Do I need it ?

    thanks
      My System SpecsSystem Spec


  4. Joined : May 2016
    Posts : 524
    Windows 10
       3 Weeks Ago #4

    Hi there,
    No, you do not need the Intel Software, it just works perfectly with drivers only.
    Intel Software was mainly important for the Ad-Hoc thing but that is not working in W10-AU, the WiFi layers have been changed and there no working Solutions for W10-AU.
      My System SpecsSystem Spec


  5. Joined : Nov 2016
    Posts : 11
    Windows 10
       3 Weeks Ago #5

    Hi

    Unfortunately, it has just bombed out again - same as before (after a couple of hours running withthe "fresh" drivers) (actually the driver version is the same as in (c) above (which was sourced through Device Manager>Update Driver Software)). I have also tried the "Intel Driver Update" app, but it doesn't find anything newer.
      My System SpecsSystem Spec


  6. Joined : May 2016
    Posts : 524
    Windows 10
       3 Weeks Ago #6

    Hi,
    I have a Intel AC7260 Card and it works best with Windows Default Drivers.
    Do not try the Updates, stay with the Default Drivers in order to Sort things out.
    So , repeat the uninstall and do not Update Driver, until you figure out what is going on.

    Another Problematic aspect are the Sound Drivers/Display Drivers, you may want to Delete them and re-install.

    You could try this things also:
    in a Elevated Command Prompt
    ipconfig /flushdns
    ipconfig /registerdns
    ipconfig /release
    ipconfig /renew
    NETSH winsock reset catalog
    NETSH int ipv4 reset reset.log
    NETSH int ipv6 reset reset.log
    exit and reboot

    You can try the "Network Reset" available in Settings>Network and Internet at bottom of page.

    You can perform a Sort of "Clean Boot" but in Safe Mode:
    run>msconfig.msc
    in Boot Page choose Safe Boot
    in General Page choose Diagnostic Startup
    Press OK and Restart
    You restart in Safe Boot and PC will always boot in safe mode. While in Safe Boot, run again msconfig.msc and choose in General Page "Normal Startup"
    Now PC will boot always in Normal mode again.

    EDIT: On Device Manager> Properties > Disable the Power Management for testing purposes
      My System SpecsSystem Spec


  7. Joined : Nov 2016
    Posts : 11
    Windows 10
       3 Weeks Ago #7

    OK, I've done everything upto the "Clean Boot"part .... will let it soak for a while..
    thanks
      My System SpecsSystem Spec


  8. Joined : Nov 2016
    Posts : 11
    Windows 10
       3 Weeks Ago #8

    It just stopped again.

    I found 6 of these (within 40 seconds) in the event log leading up to the failure:

    Warning: The network interface "Intel Wireless N 7260" has begun resetting. There will be a momentary disruption in network connectivity while the hardware resets. Reason: The network driver requested that it be reset. This network interface has reset 6 times since it was last initialized.
    EventData
    IfGuid {CC4AA2FA-DC52-4D03-AC11-154DFA0B5C13}
    IfIndex 19
    IfLuid 19985273102270464
    AdapterName Intel(R) Wireless-N 7260
    ResetReason 3
    ResetCount 6


    followed by two of these:

    Error: WLAN AutoConfig detected limit connectivity, performing Reset/Recover.adapter.
    Code: 2 0xDEADDEED 0xEEEC

    System
    - EventData
    ErrorCode 2
    Reason 0xdeaddeed
    IpFamily 0xeeec
    PortType 0x0
      My System SpecsSystem Spec


  9. Joined : May 2016
    Posts : 524
    Windows 10
       3 Weeks Ago #9

    Hi,
    With last W10 . 447 Update I did got also such a Reset Error. I had to uninstall latest Intel Drivers and Install the Windows Default and since then I have not seen more Reset.
    It seems be that 447 has Broken WLAN , now deeply.
    May be you need to uninstall that 447 Update and stay with 351, was working fine for me, and I could use Intel Install Update Driver Packages.

    About that WLAN AutoConfig, so far I can say it is the special Intel ZeroConfig that allows the Ad-Hoc, but W10-AU is not allowing to disable or use another ZeroConfig, as in previous Version Windows.
    This WLAN AutoConfig is part of Intel Driver Package and is being installed with Drivers, so it seems you have still the Intel Software installed.
    I suggest you to uninstall all Driver and Software and perform the "Clean Boot" as I said above.
      My System SpecsSystem Spec


  10. Joined : May 2016
    Posts : 524
    Windows 10
       3 Weeks Ago #10

    The Windows Default Driver 17.15.0.5 is performing very good, I have the Max. possible Speed and specially a Constant Speed. The update Driver on-line or Intel the Speed is not Constant, it is jumping up and down, and sometimes stays at half of speed.
    In picture I am transferring a File from one computer connected wired to router with a USB2.0 Adapter, and is achieving the Max Speed of 42MB/s, that is the optimal speed. The other PC is the AC7260 connected in 5GHz Band.
    Attached Thumbnails Attached Thumbnails Ac7260 Max speed.jpg  
      My System SpecsSystem Spec


 
Page 1 of 3 123 LastLast


Similar Threads
Thread Forum
Crackling Audio When WiFi Adaptor is Enabled
Hey peoples, wondering if you can give me a hand with this? The audio on my Surface 3 is making an annoying af crackling sound but only when my WiFi adaptor is enabled. When it's disabled audio is chill but I can't stream without WiFi (obvi) ...
Drivers and Hardware
Solved USB WiFi adaptor
I need to move my windows 10 desktop away from the router and need to use an USB WiFi adaptor to connect to the internet. I have an older Belkin F5D8053 but It wont download the drivers. Win10 recognises it but cant set it up. The latest Drivers on...
Network and Sharing
Wifi adaptor problem
Hi, My wifi adaptor suddenly stopped working, but I can connect to internet with Ethernet cable. Replaced wifi adaptor but still cannot to internet with same.............any ideas? Regards, John P.
Network and Sharing
Solved How do connect to the built in WiFi adaptor?
I have always connected to the internet via a external USB WiFi adapter. Now I need to connect to the one that is built in to my mother board. I went to Device Manager and Enabled it, but it isn't discovered. Do I need to do something else. And...
Network and Sharing
Network adaptor has disappeared when upgrading to W10
I'm running 8.1 and successfully upgraded to 10 last night. Unfortunately, my network adaptor has disappeared and I have no available WIFI connections. The only option is to connect via ethanet which unfortunately my Lenovo Yoga cannot do. I...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:38.
Find Us
Twitter Facebook Google+



Windows 10 Forums