1. Joined : Aug 2015
    Posts : 37
    Windows 10 Home (64-bit)
       4 Weeks Ago #1

    Problems with Wireless LAN drivers?


    Hello,

    For a few months now I have been encountering issues with wifi connections.
    They tend to be unstable and my laptop periodically loses connection to the network, or cannot connect to begin with. (or the wifi symbol in the task bar has the yellow exclamation point)
    Very frustrating when I need a fully functioning connection or when trying to print documents.
    Edit: Even when I sit RIGHT next to the router.
    This happens to any wifi I connect so I don't think it is network-related, but rather driver-related.

    I'm running Windows 10 on a Lenovo Z50-70 laptop, running the latest drivers that Lenovo offers for this device on their site.

    According to Device Manager:
    Qualcomm Atheros AR956x Wireless Network Adapter, driver version 10.0.0.341
    I tried re´nstalling the drivers but it did not change the symptoms.

    Also, there seems to be another device in the Network adapters list: Realtek PCIe GBE Family Controller.
    This device has driver version from back in 2015, but I don't know what it is doing here exactly, because when I check the network center in Control Panel, everything says that the WiFi is running on the Atheros AR956x thing.

    Is there something wrong with my drivers, or is the network card itself slowly dying/failing?
    Lenovo's diagnostics tool reports no issues with the WiFi card whatsoever. Is there another way to find the errors it might be encountering?

    Thanks for reading and I'll appreciate your help!

    PS: Please don't give me the "perform clean install of win10" again. This device IS running a cleanly installed Win10 version... (and frankly I encounter more problems on clean installed win10 versions than simple upgraded versions)

    Edit2: Problems only occur with wireless connections, not cable/ethernet
      My System SpecsSystem Spec

  2.    4 Weeks Ago #2

    Download http://www.crewetown.co.uk/wireless.exe you MUST right click and choose run as admin post results
      My System SpecsSystem Spec


  3. Joined : Aug 2015
    Posts : 37
    Windows 10 Home (64-bit)
       4 Weeks Ago #3

    reg.txt

    Here you go.
    At one step it constantly created a Timeout response (as you will see) so I had to abort it and let the rest continue.
      My System SpecsSystem Spec

  4.    4 Weeks Ago #4

    Which is our wireless station?
      My System SpecsSystem Spec


  5. Joined : Aug 2015
    Posts : 37
    Windows 10 Home (64-bit)
       4 Weeks Ago #5

    I don't know what it was and why it couldn't connect. But is it a major problem to the data that it created in the .txt?
      My System SpecsSystem Spec


  6. Joined : May 2016
    Posts : 524
    Windows 10
       4 Weeks Ago #6

    I have had problems with Lenovo WiFi Cards and Drivers with W10.
    I have tried many Drivers around the WEB but they are worst than Original Lenovo Drivers.

    I may want to try following:
    - Go to Device Manager, select your WiFI Card, right-click on Driver and select Unistall - Check box "Delete Driver Software...."
    - Go to Programs & Features, delete Software for you WiFi Card; Do the same for you BT Device
    - Reboot
    - DO not Install any Software for WiFi
    - Go to Device Manager and see if Windows installed Software for WiFi. If not, FORCE the Search and Update Drivers Online
    - I f this did not help, try to install the Drivers that come with your Laptop, no others.
    - If that still does not work, you have only 2 options: buy a new card or roll-back to your previous Windows Version
    Do not lose Time around, there are no Drivers what ever that will help. The risk you get a Malware is greater.
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Wireless USB adapter problems since upgrade to 10 anniversary
After the same grief I had upgrading to 10, I was finally able to upgrade to 1607 (anniversary version). My wireless usb adapter worked flawlessly for internet access all through the update, however once completed, and it restarted to the 1607...
Network and Sharing
Windows 10 Networkproblems, corrup PCIe & Wireless network ad. drivers
Hi there, My Acer XC-605 desktop running windows 10 does not recognize any network. The connection should run through an ethernet cable. When i looked at the network drivers there are two with an exclamation mark on them: Qualcomm Atheros...
Network and Sharing
Qualcomm Atheros QCA61x4 wireless drivers
I have a Lenovo G70-80 running Windows 10 and Kubuntu 14.04. The Kubuntu 14.04 doesn't recognize wireless connections. No wireless drivers! I found a method that might help called ndiswrapper. For that though I need one of two things. Preferably the...
Drivers and Hardware
Problems connecting to wireless printer
We have a new (albeit old) wireless printer (HP Color laserjet CP3525) with a wireless adapter card. Computers running Windows 7 or Windows 8 could see the network and connect. All computers could then print to the printer. None of our computers...
Network and Sharing
Asus M2N32-SLI Deluxe Wireless Edition network drivers not working
Hello, all, My desktop computer, that has an Asus M2N32-SLI Deluxe Wireless Edition motherboard, with an AMD Phenom II X4 processor and 6GB of RAM, BIOS version 5002, upgraded to Win10 without any issues, using the online upgrade from Microsoft....
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

ę Designer Media Ltd

All times are GMT -5. The time now is 01:07.
Find Us
Twitter Facebook Google+



Windows 10 Forums