Windows 10: USB Printer Support and USB001 Virtual Port are missing Solved

  1. Posts : 5
    Windoze 10 Pro 64-bit
       17 Oct 2016 #1

    USB Printer Support and USB001 Virtual Port are missing - RESOLVED

    I tried the usual "fixes", such as uninstalling/reinstalling the USB controllers/device drivers.
    In desperation, I tried a repair install of W10 Pro.

    The printer in question is a brand new Ricoh SP-C250DN, which operated perfectly when I first plugged it in and selected USB for the initial installation of the drivers. However, after I tested the wireless functionality thru my router, I couldn't use the printer on USB anymore.
    I was seeing "Copy 1" of the printer when I tried to get it installed for USB again. In an attempt to rid the pc of all things Ricoh so that I could reinstall and hopefully get it working on USB again, I removed both original and "Copy 1" of the Ricoh printer. That didn't get 'er done, so I deleted Ricoh reg entries -- the only Ricoh product that has ever been on this pc is this printer, so I felt safe in deleting these (I did not delete entries which contained non-Ricoh data).
    I've done plenty of work in Windows registries over the decades, with few adverse incidents, but this time I obviously slipped up. I discovered the USB Printer Support is AWOL in Device Manager (yes, I set View to Show hidden devices) and USB001 Virtual Port is AWOL from the Add Printer port list.

    Ok, so the reg is/was apparently FUBAR where USB is concerned, which is why I tried the repair install.

    What I tried before the repair install:
    • Ensure the USB connection in printer settings (front panel menu) is active.
    • Connected printer to same USB ports that other devices do work with.
    • Installed latest AS Rock drivers (mobo is FM2A85X Extreme6).
    • Made certain USB is setup properly in BIOS.
    • Confirmed usbprint and usbport inf and sys files are present and accounted for.
    • Manually installed said inf's.
    • Ran DISM scan, which reported perfect health.

    Despite the repair effort, Windows can't see the printer and I'm therefore unable to get it installed for USB. I find it difficult to believe the printer itself suffered a coincidentally catastrophic failure in its USB circuits, but I suppose it's possible. I haven't tried another USB printer to rule that out.

    From what I've read about USB Printer Support and USB001 Virtual Port, they supposedly only show up after printer drivers are installed. Therein lies the rub: I can't install the drivers because they want a USB local port selected to proceed with USB installation -- there isn't one and I can't add one (yes, I tried adding it manually). I'm wondering whether installing a different USB printer would bring them back, thus allowing installation of the Ricoh drivers.
    Let's say that doesn't work. How do I restore USB Printer Support and USB001 Virtual Port without a full/virgin or reset install of W10 Pro?? I'm stumped and getting desperate for answers, but I'm not sure I'm that desperate, since I can use the printer wirelessly if I absolutely must.

    P.S. This got moved to networking, but it probably belongs more in the driver subforum instead, since I'm not attempting to network the printer or share it, only use it as a USB printer. The router connection was just for testing the wireless connectivity (and that worked).
    Last edited by IT Hertz; 19 Oct 2016 at 15:41. Reason: resolved
      My ComputerSystem Spec

  2. bro67's Avatar
    Posts : 4,890
    Mac OS High Sierra 10.13.5
       18 Oct 2016 #2

    You do not need USB with that printer, nor is there a need to use it for USB, even if you do not want it that way. The plus of having it on the network as a Wifi shared printer is that you can place it in a central location and then use either a tablet, Android OS or iOS phone to scan and save to a network share or print from a network share.

    It is capable of being connected to your network through Wifi or Ethernet. From there the computers and devices will pick the printer up and be able to use it. If you installed the software that came with the printer and chose to have it connect via Wifi, you will not see any USB connection if still connected to a computer, since it is going to default after setup to Wifi.

    The manual on the disc explains all of this, including the pdf on Ricoh's website.

    Once we got our Laser, it went in the Dining Room, since it is a central location. We do so much scanning in stuff and faxing or emailing with the app for our Laser, that hardly are we needing to grab a laptop and use it to send something to the printer.
      My ComputerSystem Spec

  3. Posts : 5
    Windoze 10 Pro 64-bit
    Thread Starter
       18 Oct 2016 #3

    Being a wireless proponent is all well and good, but that's not germane to the OP.
    I'm well aware of the pros and cons of wireless tech, and I may use it with this printer or not. My printer is close to the pc (amazingly, some of us actually use desktops, too) that will be using it, and I simply prefer a hard connection to my desktops, always have.

    Back to the point of the OP, I am attempting to restore lost functionality. Even if I never intended to use USB again, I would still find it annoying that something which worked once suddenly no longer works, so it must.. be.. fixed. As an electronics technician by trade, I habitually go into troubleshoot mode when I encounter stuff like this.

    The manual advises that the printer can't be used on both Ethernet and Wi-Fi at the same time. I didn't find anything about any connection type being permanently disabled after the wireless drivers had been installed. That would be idiotic on the part of the engineers.

    Then again. I think it's idiotic to provide only a browser-based monitor/stats utility for only networked units (their Web Image Monitor). There should be a version for non-networked connections, as with all the other printers I've owned. But no, if the user wants to look at detailed stats and isn't networked, the user must waste toner and paper by printing out the stats pages. Such a small utility wouldn't cost many man hours of programming, so they really didn't save much on cost; it's just laziness, because mobile mobile mobile.
    Evidently, since they've crippled USB functionality in this way, their primary reason for even including USB is because they wanted to support PictBridge. But then, everyone who wants to use a camera should do so wirelessly anyway, right?
      My ComputerSystem Spec

  4. bro67's Avatar
    Posts : 4,890
    Mac OS High Sierra 10.13.5
       18 Oct 2016 #4

    You are the other party. If you installed the software that came with the printer, it would have looked for the wireless connection if you even had it connected via USB. If you allowed it to setup via WiFi by entering the SSID and passphrase, the printer server will drop the USB connection and use the WiFi connection as its main way of communication for printing.

    Also you do not have to write a long drawn out reply about this, because it is on your end and you know where the problem lies, so you need to remove the printer from the computer, by running the uninstall program for removing the software, driver and device from the computer. Then just pay attention to what you are doing while installing it again. Pretty simple stuff that is in the information that came with the printer.
      My ComputerSystem Spec

  5. Posts : 5
    Windoze 10 Pro 64-bit
    Thread Starter
       19 Oct 2016 #5

    Indeed, I know where the problem is now. I decided to reset the printer to default settings and try installing it on a virgin install of W10 Pro.
    Turns out, the problem wasn't with Windows/registry or drivers, etc. (at least that proves I didn't FUBAR it ), and it isn't a bad cable (tried a new one), so the culprit is likely the firmware of the printer (which I had updated prior to connecting wirelessly).
    I'll have to contact Ricoh support and see if completely and permanently disabling the USB-to-pc port is a bug or intentional. I haven't tried PictBridge, so that may be disabled as well. Maybe I can get my hands on a previous FW version (i.e. the one that shipped with the unit) to experiment with.

    At any rate, since this isn't a Windows issue...

    @ Mods:
    Feel free to close the thread, unless you want me to update it with my findings/solution, in case anyone happens across it while searching for a similar printer issue. Up to you.
      My ComputerSystem Spec

  6. bro67's Avatar
    Posts : 4,890
    Mac OS High Sierra 10.13.5
       19 Oct 2016 #6

    Again you do not have to write a thesis. If you know that the problem is, which is uninstall the software that was installed along with uninstalling the driver and device, reboot and then reinstall the software to set it up with the printer connected via USB, tell the setup to not set for Wifi, it is basic computer 101 stuff that we are talking about.

    Also the printer does not have bad firmware, it is not a windows problem, it is a problem caused by you rushing to set it up and just clicking away.

    The more you post stating that it is something else, when I have pointed out twice now how to fix it, you are going to continue not wanting it how you want it setup.
      My ComputerSystem Spec

  7. Posts : 5
    Windoze 10 Pro 64-bit
    Thread Starter
       19 Oct 2016 #7

    A few lines of text = a thesis nowadays?

    NB folks: There are a final SIX LINES of text below that I'll end this topic with. I know, I'm a horrible person...

    For those interested, the problem is resolved. It was the printer; not a defect, just finicky. Another firmware update, followed by a specific sequence and timing of connections has it working with USB and Wi-Fi simultaneously connected and activated. Procedure: FW update, reset printer settings via front panel, unplug power cord for several minutes, connect power, install driver, connect USB cable, verify USB001 Virtual Port is present, activate wireless networking via front panel, power off 10+ seconds, power on, setup Wi-Fi via front panel, done.

    @ Mods: the fork is stuck and this thread is done. By all means close or delete it.
      My ComputerSystem Spec

  8.    07 Aug 2017 #8

    Thanks for posting about this I'm having virtual USB 1 port trouble with a Ricoh printer and it was helpful to read I wasn't alone.
      My ComputerSystem Spec

  9. Posts : 2
    Windows 10 Home
       08 Oct 2017 #9

    Greetings and Salutations!!!

    bro67 said: View Post
    Again you do not have to write a thesis. If you know that the problem is.....
    I must disagree. As I am having a similar issue but with a clean Windows 10 Home install and a USB connected BizHub 363 Printer/Copier machine. the additional verbiage is helpful. I need to know what steps where taken, failed and/or not tried. The OP issue I am interested in is the "Virtual Printer Port for USB" missing from Windows 10. As my issue is similar but not identical to the OP, additional information may prevent the need to start a new thread, post and/or extend the discussion beyond what is necessary.

    There are nuances your response simply misses. OP expanded the discussion with the mention of FIRMWARE while you did so with WiFi settings disabling USB connections. So, when a post is too thick word wise, please, instead of complaining on the length, repost a summary. This is less antagonistic while providing crib-notes for other readers.

    Getting ever bit of functionality out of our digital devices is a journey through the Electronic Jungle. Sometimes, digging through as much detail as possible benefits one traveler, while focusing on a streamlined path to the solution benefits other.

    Thank you.
    Semper Fidelis
      My ComputerSystem Spec

  10. Posts : 2
    Windows 10 Home
       08 Oct 2017 #10

    Any one else having an issue with their Konica Minolta BizHub 363 or not able to connect using the USB, the thread below may help.
    It is RESOLVED having found a way to work around the elusive USB001 Port; described as "Virtual Printer Port for USB"

    USB Printer Support and USB001 Virtual Port are missing Solved - Windows 10 Forums
      My ComputerSystem Spec


Related Threads
I deleted some time ago the above as I have never ever used it, but now I have a need. How do I recover it? I have full win 10 installation not an upgrade. Thanks David
Printer port confusion in Network and Sharing
Since upgrading to Win 10 from release date, my wifi printer (Epson XP-215) worked fine until a few weeks ago, when the printer showed 'offline' and the connection could not be restored. Thinking it was a printer problem, I called Epson support and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:17.
Find Us