Can't connect to shared external USB from Linux/Android,can from Win10

Page 1 of 2 12 LastLast

  1. Posts : 1
    Windows 10 & Linum Mint 18
       11 Oct 2016 #1

    Can't connect to shared external USB from Linux/Android,can from Win10

    I've got a weird one that I can't seem to solve.

    I have a Windows 10 Home desktop with a permanently attached external USB HD.

    The internal drives are share from with everyone privileges at a folder level and a drive level (for testing). Homegroup is turned off completely.

    From a Windows 10 machine I can access all shares without issue. Read and write files.

    From any non Windows machine I can access the internal drive (c:) including the public folder, but not the external drive. The shares are seen, but trying to connect produces an unknown error.

    I've tried replacing permissions on the external drive at the root level and replacing them on all child objects with no change. As far as I can tell the everyone read and write permission essentially removes security, so I don't think it's a username and password issue.

    I have no meaningful error messages from android or linux, but have not checked windows.

    Anyone have any ideas?
      My ComputerSystem Spec

  2. bro67's Avatar
    Posts : 5,042
    Mac OS High Sierra 10.13.5
       12 Oct 2016 #2

    It helps to know what this USB drive is hooked into, along with what brand and model that it is. Nothing really that we can do unless we know how it was formatted, how it is connected to either network or the computer and were you able to use it before this problem occurred.
      My ComputerSystem Spec

  3.    19 Nov 2016 #3

    I have searched for a solution to my problem and come to this. op seems to have the exact same problem as mine but too bad there is no fix here.

    My problem is that i just bought a cenovo (apple tv size) mini pc pre-installed with win 10. When I shared any folder from usb external hard drives or usb thumb drives, the cenovo and shared drives can be seen from android phones and tablet using es file explorer, but the folder can't be opened and nothing happen when click. on the other hand any shared folder from the cenovo internal c: and sd card inserted can be access perfectly from android. i have compared all the share permission and security between those shared folders and see no difference. yet i can easily open the shared folders from c: and sd card from android but not anything connect through usb. i am puzzled.

    What is more puzzling is that i have a few desktop windows pc ranging from vista to 10 and they can all access any shared folders from Cenovo no matter from C:, sd card or usb. it is only from android and cenovo usb that is causing share problem. and my android phones and tablet can access any shared folders from all of my desktop pc including win10 perfectly no matter internal or usb.

    I have tried other android file managers and at least they gave me some form of error message when i click those cenovo usb shared folder. astro file manager gives the error "blueerror gen_failure". another filer manager gave error "0xC0000205". May be these means something to experts here.

    I am running out of idea after all the googling. Hope someone had run into a similar situation and found a fix. Thanks in advance.
      My ComputerSystem Spec

  4. bro67's Avatar
    Posts : 5,042
    Mac OS High Sierra 10.13.5
       19 Nov 2016 #4

    Limitations of the hardware, since it can run both Android os and windows. most likely they are running windows inside a virtual machine on the android os that runs that unit.
      My ComputerSystem Spec

  5. Account closed as requested
    Posts : 72
    Windows 10 Home x64 v1511, many others virtualized
       19 Nov 2016 #5

    Tried it, it seems that es file explorer (smb client) cannot connect to admin shares (c$, d$ etc), whilst windows clients can. you have to share the root of your external disk again (properties - sharing - advanced - add) using new sharename, then it will be accessible from non-windows clients. (At least it should, I don't know whether it work with Anniversary Update installed, v1511 is ok.)

    Also non-ASCII charaters in the sharename may cause problems while connecting, avoid them.
    Last edited by Brink; 19 Nov 2016 at 16:30. Reason: removed unneeded comments
      My ComputerSystem Spec

  6.    19 Nov 2016 #6

    Thanks for all the prompt replies. :)

    My Cenovo is a Win10 only machine and not a dual boot. Don't know if that makes a difference.
    I have tried your method to share the whole drive (both USB external hard disk and thumb drive) and gave it a new simple share name but no difference. Some more testing shows that the same problem actually occurred with my desktop Win10 using USB thumb drive, but share is fine with USB hard drive. Weird.

    Share from Cenovo's whole internal C: and D: (SD card) works straight away, which shown as C and D in ES File Explorer, as well as the Users folders.

    Is that something Win10 is waiting to be fixed? There is no such problem with Win7 and Android so may be I have to ditch Win10 for now. So sad if there is no simple fix. Hope to try more suggestions before giving up.
      My ComputerSystem Spec

  7. Account closed as requested
    Posts : 72
    Windows 10 Home x64 v1511, many others virtualized
       19 Nov 2016 #7

    Strange, but I think the problem lays in some combination of settings. Please try this:
    - make sure you have Homegroup disabled
    - make sure you have Simple file sharing (Use Sharing Wizard) disabled
    - create a new share using Advanced Sharing button
    - check if Everyone has at least Write in BOTH the Share Permissions AND the NTFS Permissions, or add it
    - use the Admin account (with right password) to connect to the share from ES FIle Explorer.
    Can you connect to the share this way?
      My ComputerSystem Spec

  8. bro67's Avatar
    Posts : 5,042
    Mac OS High Sierra 10.13.5
       19 Nov 2016 #8

    Can't connect to shared external USB from Linux/Android,can from Win10

    It has nothing to do with Dual boot. That unit is a Android device that they are running Windows on top of the Core Android OS built into it. It will not work like a real computer that will just tun Windows10, because it has to pass through the Android Layer.

    It is a cheap Chinese knockoff that if you do a search, hundreds of people that bought it to use for Windows are dealing with issues on it.

    You could buy a decent Shuttle with the Atom CPU that would run circles around that Chinese knockoff. Just because the price is decent, does not mean that it is going to even run. Most people do not post reviews on this stuff, because they tend to get embarrassed that they threw away hard earned money on something that does not work and has no backing from any manufacturer.
      My ComputerSystem Spec

  9.    19 Nov 2016 #9

    Thanks again.
    I also have that thought before but since more testing shows that the same problem arise on my desktop HP 8100 running Win10 when sharing a USB thumb drive to my Android phones, but no problem sharing a USB hard drive from it. Usually I don't share my thumb drive so I don't know about this problem until now. When I boot the same HP 8100 into Win7, all share works perfect to Android phones and all PC. So I can't help thinking it is Win10 setting related.
    I have follow all your steps but still no luck. Only difference is that I can open the Admin$ folder from Android phone.

    To put it short, using my Android phone and tablet, all shared folders from my Cenovo mini pc's internal C: and D: (SD card) works, but no shared folder from any plug in USB storage can be opened. Again there is no sharing problem between any Win PC.
      My ComputerSystem Spec

  10. Account closed as requested
    Posts : 72
    Windows 10 Home x64 v1511, many others virtualized
       19 Nov 2016 #10

    Hi pkh,

    try this combination: Win10 v1511 (not the AU) and ES explorer in attachment (please extract it from zip); it works for me like a charm (except the admin shares). Tested on both USB3 external enclosure with 4TB drive and on 64GB USB3 flash drive, both formatted as NTFS. I have anonymous sharing fully disabled and no homegroup created.

    Also you may enable Account Logon audit in gpedit.msc if you have Pro version. If you have Home, please follow this thread: How to Enable (gpedit.msc) in Home and Starter Editions of Windows 7 and Later - AskVG and check your Security log.

    If you can connect to the share on external drive from other Windows but not from other SMB client (I assume the same login name and pasword used from both) then incompatibility of SMB client may be the problem but I don't know the exact cause - mine is working, you may test it too.
    Can't connect to shared external USB from Linux/Android,can from Win10 Attached Files
      My ComputerSystem Spec

Page 1 of 2 12 LastLast

Related Threads
5 PCs Connected to Local Network: 1- Win10 Home - V.1511 10586.545 2- Win10 Pro - V.1511 10586.545 2- Win10 Pro - v.1607 14393.105 Win10 v.1511 Home, 2 - Win10 Pro V.1511, and 1- Win10 Pro v.1607 are all hard wired Ethernet. 1-...
Hi there I usually run a LINUX HOST for testing Windows VM's - but I need to test some new releases of various Linux distros so I've created some VM's --easy enough and running them on a Windows Host. However I can't attach a USB drive with a...
At my work, we are upgrading all computers from Windows 7 to Windows 10 (roughly about 12 computers total). So far 6 of them have been upgraded successfully with not network issues. There is a company domain in place. After upgrading the 7th...
Can't Connect To Shared Printer in Network and Sharing
Hi, I have a 2 desktops and a laptop all running Windows 10 Home. I have a Homegroup that is working and I can see and access the shared folders on each machine. I can see and connect to the printer on Desktop 2 from the laptop but not...
Hi there... I have 2 machines connected via a switch. They both have shared folders. They both run a piece of software. One machine acts as a master the other connects to it for data. The issue is that the "Server" service is randomly stopping...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:06.
Find Us