Windows 10: Broadcom 802.11 + Realtek 8188EU wireless issue on Windows 10 Solved

  1.    28 Sep 2016 #1

    Broadcom 802.11 + Realtek 8188EU wireless issue on Windows 10


    Hello all,

    I got serious issues with the HP G4 250. When I bought it the integrated Broadcom 802.11 device catches the wireless signal really bad. Even with my phone hot's spot on the distance should be not more than 20 centimetres away from the laptop. Now I'm using this wireless card 1.5 meters away from a router with an external antenna.

    Ping statistics for 8.8.8.8 :
    Packets: Sent = 167, Received = 132, Lost = 35 (20% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 2562ms, Average = 98ms


    So instead of troubleshooting I just boght a mini USB Realtek RTL8188EU device for $10, which worked fine until today I upgraded Windows 10 with the automatic updates. Now the Realtek doesn't show any network. I tried restarting few times and different USB ports. I tried disable/enable. Install/Uninstall from the device manager. Nothing helped.

    Could you please help me find working drivers for both (or at least for one) of the cards?


    1) Broadcom 802.11 - current driver version 6.30.223.256
    2) Realtek 8188EU - current driver version 1030.6.1201.2015

    Thank you in advance!

    Cheers,
    Nick
      My ComputerSystem Spec


  2. Posts : 3,735
    Mac OS Sierra
       28 Sep 2016 #2

    802.11 is just a standard. What type of Wireless Connection are you using? b, g, n, ac? If you are using a cellphone as a hotspot, the hardware could just be cheaply built for the wifi portion. Also the speeds are not going to be that great, same as latency.
      My ComputerSystem Spec

  3.    29 Sep 2016 #3

    Hello bro67,

    Thank you for your reply! Please note that I'm a CCNA and CCNA Security engineer so I do understand that 802.11 is just a standard. However I took 802.11 as the name of the card, because there is no other name on the broadcom site itself or in the device manager.

    I don't really think that the issue is with the network connection itself because I'm using different routers in a coffee shops, friends, at my parents and so on.

    Any other ideas?


      My ComputerSystem Spec

  4.    29 Sep 2016 #4

    I think I just found the solution.

    I just got here:
    Drivers Software for HP 250 G4 Notebook PC - HP Support Center.


    And downloaded the original Broadcom drivers for the HP G4 250. Now the rRealtek is not needed.

    Steps:
    1) Download the 45.3 version (7.35.344.0) from 1/26/2016
    2) Uninstall the old driver from the device manager
    3) Just start the setup and enjoy

    The result:
    1) Full network coverage - even in another room.
    2) More networks available in the windows menu
    3) No network losses toward to router itself:

    Ping statistics for 192.168.1.1:
    Packets: Sent = 143, Received = 143, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 135ms, Average = 5ms

    Thank you for your help!

    Nick
    Last edited by Nick887; 29 Sep 2016 at 02:47. Reason: exact troubleshooting steps added
      My ComputerSystem Spec


  5. Posts : 3,735
    Mac OS Sierra
       30 Sep 2016 #5

    Keep the Realtek in case you need a second wifi dongle for sharing the connection through the laptop. The Broadcom drivers have always been really restrictive, since they are not as open as Realtek and Intel are with theirs.
      My ComputerSystem Spec


 

Related Threads
Yooooo! I have a Lenovo Y510p with modified BIOS so I could replace the crappy Intel wireless card that came with it (Intel Centrino N2230) for an Azurewave - Broadcom 4352. The experience has been good so far, the only problem I'm having is the low...
hi, My asus t200 transformer book has the Broadcom 802. 11abgn wireless sdio adapter. Recently, my PC started having serious issues with connecting to public wifi. Everytime I try, my PC says my wireless adapter is experiencing driver or...
Hey Guys, ~Per a moderator's request, I have created a new thread. I had initially commented this post in another thread. ~ I did a bare metal install of Windows 10 on a Dell E7250 (touch). While docked at work, no issues at all. As soon I...
Realtek Wireless lan utility AP mode in Network and Sharing
In windows 8.1 I could setup an access point trough realtek lan utility and set a network authentication but since I installed windows 10 the only option I have is open system: 27320
I have a dell inspiron N4010 W7 SP1. I am trying to download W10 and message from W10 indicates that I need to download a driver for this adapter; opened the device manager and located the adapter and then tried to update the driver and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:52.
Find Us