1.    28 Sep 2016 #1
    Join Date : May 2016
    Posts : 9
    Windows 10 64bit

    Prefered DNS Resetting


    Ok so recently bought I wireless card for my pc and I re-setup my static IP which I need for port forwarding, This worked fine for a while until I started getting DNS_PROBE_FINISHED_NXDOMAIN errors on my browser, So I check my DNS and my Prefered and alternate DNS Boxes are empty, so I type in 8.8.8.8 and 8.8.4.4 and leave, I still get the same error so I go back and the boxes are empty again, this happens every time so people can't join my server and I can't use the internet. So I have to use a dynamic IP, which won't let people join either. Anyone know how to fix the DNS problem?
      My ComputerSystem Spec
  2.    28 Sep 2016 #2
    Join Date : Oct 2013
    Newport, South Wales, UK
    Posts : 1,698
    Windows 10 Pro x64 FCU - XP/Vista/Win7/Win8.1 in VM for testing

    Are you setting the DNS servers in the device or in the router?

    If you have the DNS server address in the router, (or the server if this is used for routing), then leaving the device entry blank should default to the Router/Server address

    I have actually pointed devices to the local router which is itself pointed at the actual DNS server, where the device has to have an entry, so that I only have to update one location should I need to alter the server address in use
      My ComputerSystem Spec
  3.    28 Sep 2016 #3
    Join Date : Oct 2014
    Trnava
    Posts : 2,746
    Windows 10.4 Home 1709 x64

    Try using NetSetMan, it should be able to lock the current profile.
      My ComputerSystem Spec
  4.    28 Sep 2016 #4
    Join Date : May 2016
    Posts : 9
    Windows 10 64bit
    Thread Starter

    I'm setting the DNS servers on my device because I'm trying to host a game server, and I tried using NetSetMan and the DNS still changed.
      My ComputerSystem Spec
  5.    28 Sep 2016 #5
    Join Date : Oct 2014
    Trnava
    Posts : 2,746
    Windows 10.4 Home 1709 x64

    Try to temporarily disable your security software. It might be trying to prevent changes for security reasons.

    But as Barman58 stated, when you setup DNS servers in your router, it will automatically use router's DNS.

    One more thing, try to disable DNS Client service, but if it switches back to automatic, you will have to enable it.

    To disable, run CMD as admin and copy/paste:
    sc config Dnscache start= disabled
    net stop Dnscache /y

    To enable, run CMD as admin and copy/paste:
    sc config Dnscache start= auto
    net start Dnscache
      My ComputerSystem Spec
  6.    28 Sep 2016 #6
    Join Date : May 2016
    Posts : 9
    Windows 10 64bit
    Thread Starter

    I tried disabling DNS client and the only difference it made was that the DNS would stay for about 20 seconds and then disappear, this is with avast disabled. Also when I enabled DNS client I get this message: "The requested service has already been started" Does this have something to do with it?
    Last edited by Atromix; 28 Sep 2016 at 20:25.
      My ComputerSystem Spec
  7.    29 Sep 2016 #7
    Join Date : May 2016
    Posts : 9
    Windows 10 64bit
    Thread Starter

    Ok so I did some more testing and It seems that if I disable DNS Client service, It works fine but then the DNS client enables itself and it stops working again. Why does this happen? The system also states sometimes that the service has already been enabled when I try to enable it even though it is disabled and that it is already disabled when I try to disable it even though it has just been enabled.
      My ComputerSystem Spec
  8.    30 Sep 2016 #8
    Join Date : Oct 2014
    Trnava
    Posts : 2,746
    Windows 10.4 Home 1709 x64

    Quote Originally Posted by Atromix View Post
    Ok so I did some more testing and It seems that if I disable DNS Client service, It works fine but then the DNS client enables itself and it stops working again. Why does this happen? The system also states sometimes that the service has already been enabled when I try to enable it even though it is disabled and that it is already disabled when I try to disable it even though it has just been enabled.
    It seems, that whatever is changing DNS is also starting the service, even when it is disabled.
    I have never seen Windows do this, to this service anyway, so it has to be some other software.

    You said, you have tried disabling Avast, but I guess, you have only disabled virus protection?
    It has tons of modules, even free version, which could do this, like Home Network Security.
    Disable all its modules or uninstall it temporarily to exclude it as a cause for good.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Pc resetting at 10% and freezes
I had to do a pc reset on a diffrent pc. Everything went ok and pc reset froze at 10 % for ages.So i turned off pc and restarted it hoping this should be ok.Pc restarted ok but a box appears stating windows installation encountered an unexpected...
Performance & Maintenance
Solved Help Resetting Windows 10
My problem is that I cant set a restore point as Windows says some files are missing. So when I try and reset Windows it says it can't find the reset environment. What are my options?
Installation and Upgrade
Resetting / refreshing pc almost every day
Hello i seem to have what may be some compatibility issues, because I basically have to reinstall windows once a day rig now. Sometimes the refresh function does the job, often it will just say "there was a problem, no changes made" - very...
BSOD Crashes and Debugging
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:29.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums