Windows 10: VPN connection not recognizing the computer hosting the connection

Page 1 of 2 12 LastLast
  1.    15 Sep 2016 #1

    VPN connection not recognizing the computer hosting the connection


    I recently followed a tutorial for setting up a VPN connection on Windows 10. I set it up so only a specific username and password could access it, and I port forwarded it and allowed the port through Windows Firewall. On a different network, I added the VPN connection, signed in, and it connected flawlessly. On my desktop which is hosting the VPN server, the account I created shows up as being connected. I tested the connection by accessing 192.168.1.1 on the remote computer, successfully accessing the control panel for my Netgear router, which is only accessible on the same network as the router. However, when I view the status of the connection on the host computer, it says "IPv4 Not Connected" and I cannot access shared folders on the remote computer (I tried mapping one of my shared folders to the remote computer, only to recieve the message that "Windows cannot access DESKTOP-LJ6M9J0"). This is providing me with a huge headache, as accessing my shared folders and files is my whole purpose for setting up the VPN server. If someone could assist me in this matter, I would greatly appreciate it.
      My ComputerSystem Spec


  2. Posts : 3,593
    Mac OS Sierra
       15 Sep 2016 #2

    Firewall rules on your Gateway need to be rechecked. If you are using the Windows Firewall behind your own Gateway, disable it, since your Gateway is hardened enough with the Linux IPTables rules.

    I would suggest using a real VPN client. What VPN Server software are you using and what OS are you using to run that server?
      My ComputerSystem Spec

  3.    15 Sep 2016 #3

    I just setup a basic VPN connection within Windows 10. Not exactly sure what you mean by gateway or Linux. None of my computers run Linux
      My ComputerSystem Spec

  4.    15 Sep 2016 #4

    For further clarification: every computer involved is running Windows 10, and the VPN server was setup from Control Panel. Windows Firewall has been configured to allow the port through, and the port has been forwarded on the router and confirmed to be open. The remote PC can successfully connect to the host PC and access the network, but it cannot see network devices or shared files and folders.
      My ComputerSystem Spec


  5. Posts : 3,593
    Mac OS Sierra
       16 Sep 2016 #5

    Again you need to update your System Spec's before any further help can be done. Also talking about what it is, is not going to be of any help for anyone trying to assist you with troubleshooting. Fill out your System Spec's, post in response to those items I asked you about. Not some ongoing story about your setup or how it can or cannot connect.
      My ComputerSystem Spec

  6.    16 Sep 2016 #6

    And I'll say again, I'm not entirely sure what you mean by that. System Specs? Are you asking me to upgrade my computer hardware? To what? I need more information than that. I also did respond to your question: basic Windows VPN and Windows 10.
      My ComputerSystem Spec

  7.    16 Sep 2016 #7

    I have the same problem. I have a Windows 10 computer set up as a server on a LAN. Remotely I have a Windows 7 machine as a client vpning in.

    The vpn is just the Windows 10 default vpn (pptp). I am not using the LAN router as my remote computer's gateway, so the Internet traffic on my remote computer does not go through the VPN.

    There are a variety of computers on the LAN. I can successfully ping all of them as well as the LAN router from my remote computer EXCEPT the host. Basically, everything is working great, except I cannot reach the one computer that's being used on the LAN side as the vpn server. Kind of maddening, as it happens to have the files I need access to.

    I found this thread that seems to describe the same problem I am having: How to I set the Network Location for an incoming VPN Connection in Windows 8? - Super User

    According to the thread, the problem is that the RAS dial-in network connection is public while the LAN is private (and, regardless of whether this is the problem or not, this is the case on my setup as well). However, the thread's fix didn't work for me (i.e. it did not change the RAS dial-in from public to private; don't know if that would solve the problem or not, but still seeing the different network types, same as in the screenshot in that thread).

    Here is a Tom's Hardware thread also describing the same problem, with the conclusion that changing the RAS dial-in network status also fixed the problem: Windows VPN Problems Can ping everything but the VPN host. [Solved] - VPN - Networking

    Any help is appreciated - thank you. I suspect generic knowledge of vpns alone isn't going to be too helpful here; I think this is a Windows 10 quirk specifically, one that Windows 7 did not suffer from. The vpn is working - it's just got this one issue.
      My ComputerSystem Spec

  8.    16 Sep 2016 #8

    Hahaha - I'm a fool.

    The link I found changing the network from public to private totally worked for me. I just accidentally typed it into my remote machine instead of the Windows 10 server... Too many windows open at the same time I guess and I got confused.

    This fixed my problem; I hope it solves yours as well. (After changing the RAS (Dial In) Interface from public to private, I can now ping & access the computer being used as the vpn host.)
      My ComputerSystem Spec

  9.    16 Sep 2016 #9

    So, to be clear, do I enter the commands on the VPN Host or the connecting PC?
      My ComputerSystem Spec

  10.    16 Sep 2016 #10

    Well, first make sure this is your problem (go look at the Network & Sharing Center on the host computer and see if your screen looks like the screenshot in the link - mine did). Then, yes, open powershell on the host computer and copy in the 2 commands from the link. Fixed the problem immediately for me, and changed the network from "public" to "private."
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
I have 3 computers that are connected to internet and are also connected to network printer. I have another computer that has financial data. In order to prevent any copying, I want to turnoff internet and block all USB ports on this 4th computer...
Dear all, I generally have good WiFI connection, but in two rooms so I am running a TP-Link system for Wifi through my powernet, which provides me with WiFI in our working space. No problems here. I have been noticing that on my laptop, when I sit...
Hi my name is Lukasz and I need help, I need a free web-host 1 GB, webhost has to have a cpanel phpmyadmin and mysql and php extension and a ftp. I also need a free host for unrealircd server, I also need a tutorial on how to setup unreal ircd...
Computer sees the router but there is no connection - ran diagnostic ... Troubleshooting says 'One or more network protocols are missing on this computer' This is a new computer, first set up. I am over 50. I have a satellite modem connected to a...
I have been having an extreme problem with connecting to the internet. After upgrading to windows 10 from windows 7 home version (I assume windows 10 is the problem) I had connectivity for over a month. Thus I cannot roll back to windows 7 anymore....
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:52.
Find Us