Windows 10: 5 ghz network takes forever to connect

  1.    13 Sep 2016 #1

    5 ghz network takes forever to connect


    my 2.4 ghz connection would connect instantly when i boot my computer... but it takes about 5 minutes for windows to connect to my 5ghz connection... whats causing it?

    i checked and the 5ghz connection doesnt show up on the list of wireless connections for the first five minutes after booting my computer... also it seems windows has made two types of connections, one is called Wi-Fi and the other one is called Wi-Fi3... what gives?
      My ComputerSystem Spec


  2. Posts : 901
    Windows IP 16199 Windows 14393.1198
       13 Sep 2016 #2

    Hi,
    It happened to me as well, to rectify this I have gone to Device Manager, Properties and changed "Preferred Band" to No preference in Advanced tab.
    Click image for larger version. 

Name:	Capture.JPG 
Views:	19 
Size:	38.7 KB 
ID:	101211
      My ComputerSystem Spec

  3.    13 Sep 2016 #3

    hello

    i just went into device manager and set preferred band to no preference.. but it still takes a few minutes for windows to connect to my wireless 5ghz network
      My ComputerSystem Spec


  4. Posts : 19
    Windows 10 Enterprise x64 Build 1607
       13 Sep 2016 #4

    Make sure you are running the latest drivers. Especially if you have an intel wireless adapter. Get the latest from intel directly. They release driver constantly for WIFI to fix these issues.
      My ComputerSystem Spec

  5.    14 Sep 2016 #5

    its a TP-LINK archer t9e wireless networks card, the signal strength is about 78% (rated excellent by the tp link software) the modem is a netgear ac1600... my computer is about 3 feet away from the modem... i have the latest drivers....
      My ComputerSystem Spec

  6.    14 Sep 2016 #6

    Hi there

    I have connection that is really good (0.5 Gb/s - upgrading to 1 Gb/s later this year - Isl. is a small country but has superb internet -- really miss it when I'm back in the UK and have to use things like BT (Bovine Scatology) Telecomm for a piddly 12 mb/s !!!!!.

    Try changing channel width to WIDE / 40 MHZ / upper (depends on your Menu) and selecting different set of channels and alter the lease times on your DHCP server / Router / Cable box.

    You might also be getting a lot of things like mobiles trying to connect or just scanning - I'm surprised the 5GHZ is not working for you though.

    Check also router is in ac mode as I think the old "n" protocol can also connect to 5GHZ. (not sure about that but check it anyway).

    Cheers

    jimbo
      My ComputerSystem Spec

  7.    14 Sep 2016 #7

    Did you try to move the Modem further away from PC, say around 10feet?
      My ComputerSystem Spec

  8.    14 Sep 2016 #8

    jimbo45 said: View Post
    Try changing channel width to WIDE / 40 MHZ / upper (depends on your Menu) and selecting different set of channels and alter the lease times on your DHCP server / Router / Cable box.

    Check also router is in ac mode as I think the old "n" protocol can also connect to 5GHZ. (not sure about that but check it anyway).
    how do i do this?

    Adalwar said: View Post
    Did you try to move the Modem further away from PC, say around 10feet?
    yes... doesnt solve the problem
    Last edited by todd24; 16 Sep 2016 at 12:34.
      My ComputerSystem Spec

  9.    16 Sep 2016 #9

    bump
      My ComputerSystem Spec


 

Related Threads
Solved Update Takes Forever in Installation and Upgrade
This is more of a curiosity question, but why does it take hours to update from one build to the next? I'm going from 10041 to 10049 and it's been running for about two-and-a-half hours now. It's currently at 20%. Seems like the update to...
Hello, Whenever I launch MS Edge, it takes about a minute to bring up the home screen (default). Also, when I click to create a new tab, it takes as long for a new tab to come up where I can type in a new web address. I've searched the web...
Startup takes forever. in Performance & Maintenance
I recently upgraded to Windows 10 and since then my PC (HP Envy i7) takes approximately 5 hours to boot. This really is frustrating. Please assist in resolving this issue.
Solved Computer takes forever to shut down. in Performance & Maintenance
My computer is a Lenovo Y400 8GB RAM Windows 10 Home Intel Core i7 Nvidia Geforce GT It has been exactly 2 weeks since I upgraded to Windows 10 but one thing I noticed about my computer ever since the update is that it has a very long shut down...
Windows Defender takes forever to scan in AntiVirus, Firewalls and System Security
Windows defender used to speed by, now it is slow as a snail. It got stuck 2x at a file. I had to cancel the scan and start all over. Now it is going but slow as can be, it has been scanning for 20 min and only half thru. anyone seeing this?
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:09.
Find Us