1.    08 Sep 2016 #1

    Epson Printer Mem card slot will not delete


    I added an Epson WF-3640 printer several days ago. The printer has a USB slot and a memory card slot. Several associated, network problems arose.

    1. I had flash drives in both of the two available Netgear Nighthawk USB ports. The network had designed those drives as Z and Y.

    2. Remarkably, after installing the Epson, the network named the Vacant Epson memory card port Y.

    3. (Not realizing this at the time) I inserted a flash drive in the Epson's USB port. The network named that drive Z.

    4. I unplugged the Epson, rebooted the computer and the router with the following results:
    a. When I reinserted the flash drives into the router, although the router's corresponding status LED's light up, explorer does not see the drives.
    b. If I plug either of the two 'router' flash drives into the computer explorer sees them.
    c. Despite the Epson still powered off, the router and computer being rebooted twice, explores still sees the Epson memory card as drive Y. Clicking on or attempting to disconnect the memory card apparently just confuses the OS (screenshots attached).

    My easiest solution although not preferred is to buy an Anker powered 9 port USB hub and forget using the router. However, that still leaves the problem of the 'phantom' Epson memory card appearing on the network as a drive?
    Attached Thumbnails Attached Thumbnails Epson MemoryCard Removal_Connection Error.PNG   Epson Phantom memory card.PNG   Epson USB Error.PNG  
      My ComputerSystem Spec
  2.    08 Sep 2016 #2
    Join Date : Jun 2016
    Posts : 1,462
    Win10 1607

    Don't delete the Epson Memory Card Reader , Windows just finds it again....

    Windows has MAPPED it as a Network Drive , just RC on it and Choose Disconnect , with luck there is a checkbox to also uncheck called Reconnect at Logon/sign in (or something like that)

    You can also in Disk Management assign Drive Letters to any flashDrive/CD Drive/External Drive etc it Finds and windows will remember those Assigned Drive Letters each time you plug them in. Eg I always make my CD/DVD Y: and Z:

    It may take some time for the Router to Find and "tell" the network the Flash Drives are there and usable again. I am guess they were not plugged into the Router when you plugged in the Epson ? as Windows should not of allowed drive letter changes if they were plugged in, if they weren't plugged in the windows just cycles through available Drive letters , unless you have defined them as above.


    KB
      My ComputerSystem Spec
  3.    09 Sep 2016 #3
    Join Date : Aug 2014
    Forever West
    Posts : 3,913
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint

    Also keep in mind that the last few versions of Windows will, by default, assign Z: to the first Network-attached drive it finds and work back up the alphabet. I have 2 NAS drives attached to my Router and they were automatically lettered Z: and Y: according to when I actually plugged in the Ethernet cables.
      My ComputerSystem Spec
  4.    09 Sep 2016 #4
    Join Date : Jun 2016
    Posts : 1,462
    Win10 1607

    My Synology NAS does not work like that I am not sure why , it is attached to the network via the TP Link C7 Router and I access it it via Network > it's Folders .............. Unless I map the Folders on the NAS to Drive Letters ...... My NAS is rather old though .....

    are they Network Attached or USB attached ...maybe that's the difference ? mine is Network Attached.

    KB
      My ComputerSystem Spec
  5.    09 Sep 2016 #5
    Join Date : Aug 2014
    Forever West
    Posts : 3,913
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint

    Quote Originally Posted by Kbird View Post
    My Synology NAS does not work like that I am not sure why , it is attached to the network via the TP Link C7 Router and I access it it via Network > it's Folders .............. Unless I map the Folders on the NAS to Drive Letters ...... My NAS is rather old though .....

    are they Network Attached or USB attached ...maybe that's the difference ? mine is Network Attached.

    KB
    Mine are Ethernet cable attached, don't yet need the USB port on the Router.
      My ComputerSystem Spec
  6.    09 Sep 2016 #6

    The 'D' drive you see in my explorer snapshot is 1 of the 2 SD's from the router USB's that I plugged into the only open port of the computer's USB hub.

    To your responses:

    1. Both SD's were plugged into the router when I installed the Epson. I realize that I'm just going on coincidence but it does seem as if the install of the Epson 'ate' the two network names of the two router flash drives and somehow rendered any subsequent entrance of a router SD as 'persona non grata' ;-)! Btw, the flash drive that I removed from the Epson was named Z. You also understand that I have never inserted a memory card into the Epson slot--so how a memory card is even showing up is odd.

    2. I cannot do anything about the Epson memory card. If I right click and attempt an action or double click same in explorer view, I get the 'catastrophic error' per one of initial screenshots.

    3. On one of the occasions that I reinserted the FD's in the router's USB ports and the router light acknowledged presence but explorer did not show I ran Window's network troubleshooting which came up clean.

    Okay, the following is flat bizarre. While writing this message I clicked open Network and it showed \\ReadyShare USB, I clicked and the rear FD appeared and I could display contents (the front USB is empty w/the FD in the hub. BUT after I removed the FD from the hub, stuck it in the front USB Network lost any trace of seeing either device. I open/closed explorer, I unplugged the front FD all nada, zip, zero--back to where I was with the router's FD's not appearing????

    Hating (not a strong enough word) the network setup (due to never getting same right and getting p****d in the process) haven't set anything up since firing up my new laptop some months ago (apart from 2 wireless printers there's my wife's desktop, laptop and my retired laptop). Whatever shows under Network appears to be what Windows and router have decided will show calling same 'Springsnow' which is the name of the WiFi network.

    Mark
      My ComputerSystem Spec
  7.    09 Sep 2016 #7
    Join Date : Jun 2016
    Posts : 1,462
    Win10 1607

    The extra copy of removable drives being shown in explorer can be stopped with this .reg file , in this tutorial , I use it all the time....

    Drives in Navigation Pane - Add or Remove in Windows 10 - Windows 10 Forums


    1. It is not the memory card that is shown in the Epson, but the Card Reader , personally I assign T: to it so it doesn't interfere with USB drives etc letters every day as I only use it the odd time I insert a CF card from My Cam.

    2. The right click disconnect what was what works for my Friends Epson 630 , he was complaining about it always showing up too....perhaps a bad Printer Driver Install?

    3. Check the setting in the Router's Web interface perhaps especially for USB....
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Unable to install Epson printer or Brother Labeller
Hi since changing to W10 I am unable to install the above on my lap top, both worked fine on my old vista machine, little notice comes saying something like ..incompatable with the O.S, is there away to get around this ? The printer, an Epson...
Drivers and Hardware
Epson Printer Drivers for Win 10?
Hi does anyone know or think the 64 bit 8.1 drivers for my printer may work for Win 10? (64 bit) Epson does not offer Win 10 drivers Some sites offer the drivers but I try not to download things from sites I do not trust It could be the 8.1...
Drivers and Hardware
epson printer driver wont install
i've updated to windows 10 on my pc and i'm unable to download the driver for my epson sx235w printer to my pc. i've tried the install disc and also via the drivers online. each time it starts to download the drivers it gets stuck on the download...
Drivers and Hardware
cannot uninstall Epson Printer
Following upgrade to 10 I need to uninstall Epson Printer and reinstall. have initiated uninstall but it will not complete the process. Anyone any ideas how to achieve this please?
Drivers and Hardware
Solved printer help epson dx8400 not recognized by windows 10
hi I have recently took the free upgrade to windows 10 from windows 8 how ever now my Epson dx8400 all in one printer will not be recognized by 10 worked fine on 8 just plugged usb in and set up automatically 10 wont pick up at all ive downloaded...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:51.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums