Windows 10: Lenovo y50, Unstable wifi, Potential faulty hardwar Realtek RTL8723BE

  1.    04 Sep 2016 #1

    Lenovo y50, Unstable wifi, Potential faulty hardwar Realtek RTL8723BE


    I am having some issues with my wifi on my personal laptop, and I would need if possible some advice

    - Base OS : Windows 10
    - hardware wifi : Realtek RTL8723BE Wireless LAN 802.11n
    - Driver 2023.30.0301.2016 (Latest version was installed before reinstalling my base os)
    - Motherboard : wmic baseboard get product,Manufacturer,version,serialnumber gives me LENOVO y50-70 does not make a lot of senses for me, but otherwise I just get the serial number and version

    Problem Description
    My wifi is very unstable, I can connect to the router, sometime it works properly, some time I don t internet connection. The error i get can be DNS resolution or web site not reachable.
    I get the same problem with different routers
    Interesting and make investigation very difficult for me is that I almost don t get any events

    the only events related that I get sometime is 3 WLAN Auto Config (Errors)
    EventID 40003
    Description WLAN Autoconfig detected limit connectivity, performing Reset/Recover,adapter
    code1 0xC 0x4
    code2 0xDEADDEED oxEEC (really did not like this one as i believed I was being pwned, but looks like it is the drivers that return that)
    Code 8 0x0 0x0

    Usually it happens once when I reboot, and I get informational WLAN auto config entry saying that it went well, so I don t think it is the problem.
    From there, it changes between working and not working
    The only other event I get are for example warning because DNS failed, but it makes sense to me.

    What I have done:

    - Investigate events
    - reinstall drivers
    - flush DNS. route tables
    - search on the internet for similar issue
    - Reinstall base os

    I am just done reinstalling, and I have the same problem.

    What I think

    I have a computer science background but windows is not the OS I work with, and don't know much about hardware. Lack of event does not really help me to investigate. I think that my wifi card is dying (It is a good computer, but it is not the first time i get hardware failure ...), but before buying a new one i would need your advice:

    - Do you think of other investigation that would reveal a software problem.
    - Based on what I said, do you think I am right to think about hardware failure, for me it would explain why it is not just not working, but it is unstable. Also for what i have seen, this wifi card is shit....
    - Do you have any advice, that is the more important as I am not sure if a wifi card can be changed easily, if any wifi card can be used, if you have any advice for a good one.

    Thank you very much for your answer, if you need any other information i will provide them

    Have a good day
      My ComputerSystem Spec

  2.    04 Sep 2016 #2

    I did some searching and came across other people having the same issue with that specific model wifi chip. Some of them have gotten it to work by either A: enabling their router's IPV6 or setting the IPV6 to auto, or B: checking that the antenna wire connected to the wifi chip in the computer isn't loose. By no means a guarantee, but worth a shot.
    Last edited by bookfox; 04 Sep 2016 at 10:50. Reason: Corrected misspelling of 'guarantee'.
      My ComputerSystem Spec

  3. TairikuOkami's Avatar
    Posts : 3,326
    10.5 Home 1803 x64
       04 Sep 2016 #3

    I have always managed to fix failing WiFi with these steps (plus disabling DNS Cache service to prevent caching):

    Uninstall all protocols except IPv4, uncheck IPv6 and disable IPv6:
    netsh int ipv6 isatap set state disabled
    netsh int teredo set state disabled
    netsh interface ipv6 6to4 set state state=disabled undoonstop=disabled
    reg add "HKLM\System\CurrentControlSet\Services\Tcpip6\Parameters" /v "DisabledComponents" /t REG_DWORD /d "255" /f

    Disable LMHOSTS Lookup
    reg add "HKLM\System\CurrentControlSet\Services\NetBT\Parameters" /v "EnableLMHOSTS" /t REG_DWORD /d "0" /f

    Disable NetBIOS over TCP/IP

    wmic nicconfig where TcpipNetbiosOptions=0 call SetTcpipNetbios 2
    wmic nicconfig where TcpipNetbiosOptions=1 call SetTcpipNetbios 2

    Setting up reliable DNS servers:
    wmic nicconfig where DHCPEnabled=TRUE call SetDNSServerSearchOrder ("","")

    Lastly, setting up IP manually, it can be a bit annoying to set up, but it should provide a rock solid connection.
      My ComputerSystem Spec

  4.    04 Sep 2016 #4


    Thank you very much both of you.

    @Taikaru I disabled DHCP, run the command you talk about (Thanks for the tricks), and disabled DNS caching. atm, it is working well, but I will try to stress a bit the network to see if it last.As I told you, it is unstable, so cannot be sure yet. I will keep you updated @bootfox, Thanks for the tips, yes if it is not fixed now, it will be definitely my next step, to open it and try to see if the antenna is not loose.

    If it works I am not sure to really understand the root problem though, if the problem came from services that I disabled, some events messages would have been created isn't it ? same for ipv6 if it cannot get an address or whatever
    Thank very much, I will confirm later.
      My ComputerSystem Spec

  5.    04 Sep 2016 #5


    So I know a bit more.

    the configuration did not fix the problem, it worked for 30 minutes, and then it started again to do random stuff.

    I followed the hardware check, by opening the laptop and located the wifi card.
    I believe I found it (i will send the picture, i am 90 % sure but if I am wrong better appear dumb than chasing a ghost)
    I played with the 2 antennas plugs, disconnected the card etc.

    Just to be sure I understand, the antennas must be plugged to the ship, but the other side does not really matter ? I tried to fellow the wires, but they were going in some shell that I could not open.

    So it is not working, but I noticed something.
    I said that I don t get any error message, but it was false. When I booted, the bios told me that "the check for the wifi component failed, and to check the cables". after playing with the card, it does not show this error message anymore. which is weird. (Sorry I don't remember the full message and it does not appear anymore)

    The wifi card is detected by the OS.
    but I barely can connect to the router and when I do, I don t have internet access
    I could not connect to the internet, so it looks like I made things worse, but it may have helped to locate the issue

    Does anyone manage to make sense of it ?

    Thank you very much in advance
      My ComputerSystem Spec


Related Threads
Hi good people, So, I'm on here like thousands of others with intermittent wifi issues. I upgraded from 8.1 to 10 yesterday and everything works very well except for losing my wifi connection every 30 minutes to an hour. My wireless adapter...
Just before the July 29 deadline I updated my Lenovo G40 IdeaPad to Win 10. Everything appeared fine except that I couldn't get a WiFi link! Eventually Lenovo "support" advised that there was no available WiFi driver for the G480. Desperately, I...
So i was given a laptop to repair, a Lenovo Z50-70 to be precise. So the guy said his Wifi and Ethernet weren't working (Error 45 in device manager (seems to suggest they arent connected which i don't understand considering its a laptop)). later, it...
Lenovo Y50-70 wifi issues in Network and Sharing
I have Lenovo Y50-70 UHD and i have installed Windows 10 64-bit version. Everything is perfect except for the wifi. I have installed these two drivers that lenovo suggests but still my connecition is extremely slow. My...
Lenovo WiFi in Network and Sharing
I have an ex NSW schools laptop i purchased, its all legal. I am unable to get wifi working. I have put Win 10 on it. When i go to Network and Internet i push the slider over to put wifi on but it immediately slides back to off. I have updated...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:40.
Find Us