Windows 10: Cannot connect to Microsoft account remotely via either FTP or VNC Solved

  1.    03 Sep 2016 #1

    Cannot connect to Microsoft account remotely via either FTP or VNC


    I had a local account on Windows 10 running on my old PC and set it up as an ftp and vnc server. (Sysax Multiserver for ftp and UltraVNC for vnc) That worked fine.

    Now I got a new PC running Windows 10, and I let Microsoft talk me into using a Microsoft account.

    But those same server applications do NOT seem to work with a Microsoft account. I can't even log in from inside my own LAN. I can think of two reasons for this:

    1. They don't accept my user name with a space in the middle. I don't want to give my real name on this forum, but let's say my real name is "John Smith." Then my Microsoft account was named "John Smith" and that's how I log in. But the ftp and vnc clients don't seem to accept a username with a space in the middle like "John Smith." (My old local account name didn't have a space in the middle.)

    2. Some kind of security problem. I turned off the firewall completely but I still can't get connected.

    Has anybody here tried to set up a Microsoft account as an ftp or vnc server? How did you do it?
      My ComputerSystem Spec


  2. Posts : 11,206
    Windows 10 Pro
       03 Sep 2016 #2

    Try the long username instead of MS account name. It is given as COMPUTER_NAME\USER_PROFILE_NAME.

    Check first your user profile name. It is in 99.9% certainty the same than your user profile folder's name, which is different than your Microsoft account name. If you want to be absolutely sure, use command $env:username in PowerShell to show your "real" user profile name instead of Microsoft account name:

    Click image for larger version. 

Name:	image.png 
Views:	1 
Size:	41.7 KB 
ID:	99605

    In my case now it shows my user profile name as Kari although I have logged in to Windows with a Microsoft account and username containing my first and last names, with space.

    Further, let's say my PC name was MyMonterRig. In this case now I would use long username MyMonsterRig\Kari in everything network and remote control related instead of my Microsoft account email.


    (Video from Ten Forums video thread.)

    Kari
      My ComputerSystem Spec

  3.    03 Sep 2016 #3

    I re-edited this post because your suggestion does work--inside my LAN but not outside.

    But now I'm still having trouble connecting to the ftp server from outside the LAN.

    The only thing I changed from my old PC to my new PC is that I gave my new PC a static IP address inside my LAN, but I forwarded the ports to that new static IP address.

    Turning off the firewall didn't fix it.
      My ComputerSystem Spec


  4. Posts : 11,206
    Windows 10 Pro
       03 Sep 2016 #4

    Static IP should not have nothing to do with your issue. Quite an opposite, in fact, you will need a static IP to get port forwarding to work without sudden "IP not found" and such errors.

    One variation of the so called long username trick: try if WINDOWS\User_Profile_Name works (in Windows networking you can in most cases replace computer's NETBIOS name with word WINDOWS).
      My ComputerSystem Spec

  5.    03 Sep 2016 #5

    I still can only connect to VNC from inside my LAN, not outside, and I cannot ftp at all, either inside my LAN or from outside.

    This is why I asked if anyone had actually gotten VNC or FTP to work with a Microsoft account. I'm getting error messages in the VNC log that I don't recognize and didn't see with local accounts.

    Sat Sep 03 12:12:10 2016
    vncmenu.cpp : ############### Usernames change: old="sdlit", new="sdlit"
    Sat Sep 03 12:12:15 2016
    vncmenu.cpp : ############### Usernames change: old="sdlit", new="sdlit"
    --The system cannot find the file specified.
    Sat Sep 03 12:12:20 2016
    vncmenu.cpp : ############### Usernames change: old="sdlit", new="sdlit"
    --The system cannot find the file specified.
    Sat Sep 03 12:12:25 2016
    vncmenu.cpp : ############### Usernames change: old="sdlit", new="sdlit"
    --The system cannot find the file specified.
    Sat Sep 03 12:13:03 2016
    vncserver.cpp : authhosts set to ""
    vncproperties.cpp : ***** DBG - Load User Preferences
    vncproperties.cpp : clearing user settings
    c:\users\rudi\desktop\ultravnc_1211\winvnc\winvnc\vncpasswd.h : PASSWD : FromClear called
    vsocket.cpp : VSocket() m_pDSMPlugin = NULL
    vsocket.cpp : VSocket() m_pDSMPlugin = NULL
    vncsockconnect.cpp : started socket connection thread
    vncproperties.cpp : $$$$$$$$$$ ApplyUserPrefs - Plugin NOT enabled
    c:\users\rudi\desktop\ultravnc_1211\winvnc\winvnc\vncpasswd.h : PASSWD : ToText called
    vnchttpconnect.cpp : started HTTP server thread
    vncmenu.cpp : IsIconSet
    Sat Sep 03 12:22:36 2016
    vsocket.cpp : VSocket() m_pDSMPlugin = NULL
    vncsockconnect.cpp : accepted connection from 198.199.98.246
    vncserver.cpp : AddClient() started
    vncclient.cpp : vncClient() executing...
    vncclient.cpp : TEST 4
    vncserver.cpp : AddClient() done
    vncclient.cpp : client connected : 198.199.98.246 (1)
    vncclient.cpp : DSMPlugin Pointer to socket OK
    vncclient.cpp : Repeater connect
    vncclient.cpp : Repeater connected, waiting viewer
    vsocket.cpp : zero bytes read2
    vncclient.cpp : Reconnect to repeater
    vncserver.cpp : removing unauthorised client
    vncserver.cpp : RemoveClient() done
    vncclient.cpp : ~vncClient() executing...
    vncclient.cpp : deleting socket
    vsocket.cpp : closing socket

    If anyone has actually done it successfully, please let me know. Otherwise, I'm giving up.

    In my past experience, whenever I've fooled around with a mysterious problem for a day or more, it has usually turned out to be a Windows or Office bug or limitation that I have no control over. I'm suspecting that's the case here. So there's no point in my struggling with it on my own.
      My ComputerSystem Spec

  6.    03 Sep 2016 #6

    I checked the ports with a separate tool. The ports are open, but the server is still not making the connections.

    I give up.
      My ComputerSystem Spec

  7.    05 Sep 2016 #7

    Looks like a couple of application bugs--solved


    Kari,

    First of all, let me apologize for having been a little dismissive of your advice. It turned out that you were right--but the applications were wrong.

    There seems to be some fundamental incompatibility between Sysax Multiserver and Windows 10 Microsoft accounts. I switched to FileZilla as an FTP server and that worked the first time with your advice on naming. No bugs, no glitches, even with a Microsoft account. So I'm satisfied.

    I'm going to mark this thread as solved. From now on, I'll just log in with "PC name\username" whenever just the username doesn't work.

    Thanks for your help!
      My ComputerSystem Spec


  8. Posts : 11,206
    Windows 10 Pro
       05 Sep 2016 #8

    No problems. Windows networking can be a bit tricky when third party applications are involved. Main thing is you could resolve your issue, at least for some extent.

    Kari
      My ComputerSystem Spec


 

Related Threads
Network & Sharing RDC - Connect Remotely to your Windows 10 PC in Tutorials
(Source: Wikipedia) A remote connection from a Windows PC to another Windows PC is easy and can be done without installing any additional software. The connection uses Remote Desktop Protocol (RDP) to let two computers, a remote host and a remote...
Can't connect to Microsoft account in User Accounts and Family Safety
First of all, it's my fault. I accidentally deleted 'Microsoft' subfolder from Roaming folder, and after that, I just can't link my local Windows account to my Microsoft account. It always says the basic failure messages. What should I do? How could...
When I first upgraded to Windows 10 I set up my gmail and hotmail accounts in the native Windows 10 email app. Both were working when I first set it up a long time ago. Quite a while ago now, though, the Hotmail account ceased to work. I tried...
hi i add google account to Windows Calender . but error : we can't connect to the service you need right now . check your network connection or try this again later . 71168 Setting > account > add account > Google > " Rais Error : we can't...
Hello everyone. Normally, I am no slouch in trying to find a solution to a problem with searching the net, but so far I haven't found a solution to my problem. Upgraded my Windows 10 from Win 7 Ultimate. So I started Win 10 with a local...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:52.
Find Us