Wi-Fi no longer working, out of ideas on how to proceed


  1. Posts : 3
    Windows 10
       #1

    Wi-Fi no longer working, out of ideas on how to proceed


    Lenovo Y480 Ideapad (late 2012)

    Issue: Attempting to connect to Wi-Fi, status is "No Internet, secured"

    Wi-Fi works fine for iPhone and MacBook

    Device Manager-->USB-IF xHCI USB Host Controller (Intel WiUSB) "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)"

    The driver was from 2012 and according to Windows there were no updates. Intel Driver Update did not bring up an update either. I removed it completely with the intention of attempting to reinstall it but there does not appear to be any way of doing that. Where do I proceed from here?

    RESOLUTION: The issue has been resolved thanks to a user on another forum. I had to install this driver, restart, and then I was able to connect to WiFi again. My internet still wasn't working ("dns_probe_finished_bad_config" error message on every website) but was able to get that resolved quickly with this.
    Wi-Fi no longer working, out of ideas on how to proceed Attached Files
    Last edited by Golden Kiwi; 23 Aug 2016 at 20:40.
      My Computer

  2. dalchina's Avatar
    Posts : 29,909
    Win 10 Pro (1903)
       #2

    Considering the driver alone:
    These appear to be from 2013, Win 8.1 64 bits, if these are the correct ones:
    http://support.lenovo.com/gb/en/prod...are&beta=false

    1. Presumably you have tried a restart.
    2. Do you have a system restore point?
    3. Further ideas common to Code 31 here:
    How To Fix Code 31 Errors in Windows
    http://www.wintips.org/fix-network-a...king-properly/
      My Computers


  3. Posts : 3
    Windows 10
    Thread Starter
       #3

    dalchina said:
    Considering the driver alone:
    1. Presumably you have tried a restart.
    2. Do you have a system restore point?
    3. Further ideas common to Code 31 here:
    How To Fix Code 31 Errors in Windows
    http://www.wintips.org/fix-network-a...king-properly/
    I've restarted the computer a couple times since I've had the issue, and I do not have a system restore point (at least I've never made one).
      My Computer

  4. dalchina's Avatar
    Posts : 29,909
    Win 10 Pro (1903)
       #4

    So try the fixes in those articles.

    These drivers appear to be from 2013, Win 8.1 64 bits, if these are the correct ones:
    http://support.lenovo.com/gb/en/prod...are&beta=false
      My Computers


  5. Posts : 3
    Windows 10
    Thread Starter
       #5

    dalchina said:
    So try the fixes in those articles.

    These drivers appear to be from 2013, Win 8.1 64 bits, if these are the correct ones:
    http://support.lenovo.com/gb/en/prod...are&beta=false
    Which one is it? The Intel WiUSB is not on here.

    EDIT: I was thinking it was the WiMAX driver, but apparently not:
    "This setup program installs software for the Intel Centrino Advanced-N + WiMAX 6250 or Intel Centrino Wireless-N + WiMAX 6150 adapter, but no WiMAX was detected on your computer. Do you want to continue anyway?"

    EDIT 2: The following drivers did not work (after restarting):

    Intel PROSet/Wireless Software and Drivers for Windows 10

    Intel WiMax Driver for Windows 8.1(32-bit, 64-bit) - IdeaPad Y480,Y580
    Last edited by Golden Kiwi; 23 Aug 2016 at 17:12.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 03:09.
Find Us




Windows 10 Forums