Windows 10: HomeGroup is asking to join on PC that should have created it.

  1.    16 Aug 2016 #1

    HomeGroup is asking to join on PC that should have created it.


    I am gonna be blunt here. I did post this in a HomeGroup thread already and no luck with a reply. So I am going to start a new thread.

    So I did the final 10 upgrade about 2 weeks ago on 3 of my machines. Now Homegroup is not working. I have gone through steps from multiple sites with no luck at getting this working.

    Here is the break down.

    Laptop Sony Vaio. Basic specs. Running 64 bit 10
    Media Center Nothing special. Running 64 10
    Main PC Really not special. Running 64 10

    I want the Main PC to be the creator of the Home Group.
    For some reason the laptop wants to be the creator of the home group. So I shut it down.

    Now I went to create the home group on my main pc and it says its already created. The twist is that it says that my Main PC is the home group creator and that the only options is to join or close. This is on my pc that I want it to be created on.

    I have gone through with stopping and restarting services for the HomeGroup. I have deleted all the files files out of the C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking folder. I have shut down all machines. But still says that Main PC has created the group already.

    I am Stumped.
      My ComputerSystem Spec


  2. Posts : 3,439
    EL Capitan
       17 Aug 2016 #2

    It probably got created during the upgrade. In other words, someone clicked to create a Homegroup. You just have to right click on the Network Icon where the clock is and open up the Network window, then go to Homegroup and tell it to leave the homegroup.

    Also a PC does not create the homegroup, a human has to create it by enabling it. No one really uses that feature, because if anything happens to the computer that is considered the Master or Slave, you run into headaches to remove all home group settings and set back up for the new computer.

    Just use standard Network sharing. It has worked for decades.
      My ComputerSystem Spec

  3.    17 Aug 2016 #3

    Totally understand what you are saying. But as for create home group It was never an option after I went from 7 to 10 on the pc that I want to create the homegroup on. It just keeps saying that the home group that is there is hosted on the machine that it is supposed to be created on. I will screen shot it so it is easier to understand

    Basically just want to reset this so it will create the homegroup. Not say it that it is being invited.



    Click image for larger version. 

Name:	Main PC.png 
Views:	5 
Size:	582.4 KB 
ID:	96703
      My ComputerSystem Spec


  4. Posts : 3,439
    EL Capitan
       17 Aug 2016 #4

    If it was on a Home Group with Windows 7 before you upgraded to Windows 10, I would say that it remembered the Home Group when it was Windows 7 and the difference between the two OS's are the problem. Have you tried the steps in the Tutorial section to remove the Home Group on each machine if the OS will not let you do it from the Network screen when you right click on the network Icon in the Tasks area.
      My ComputerSystem Spec

  5.    18 Aug 2016 #5

    I think you are right. Going from 7 to 10 is the error. My laptop and my media machine will allow either create or join. Its only this machine that thinks it has already created a homegroup and is asking to join what it thinks it created.

    I looked at the tutorial and yes. I have done that one. And many others like it or similar to it. I am now thinking its gonna be deeper than just files and folders. Probably Registry Edits to accomplish this simple task.
      My ComputerSystem Spec


  6. Posts : 3,439
    EL Capitan
       18 Aug 2016 #6

    It happened with Vista and 7 also. It is one of those small items that we tend to do as housekeeping, before upgrading. The only way that we learn is by error.
      My ComputerSystem Spec


 

Related Threads
46244 I have 3 computers running Windows 10. Two were upgraded from Windows 7, and one from Windows 8. May not have had the Homegroup working properly before, and I think I had created one some time ago. I don't know what the password was. But,...
Unable to Join HomeGroup in Network and Sharing
Hello everyone. I set up a homegroup years ago.. and had it set to two computers linked up and ready to go. Now we moved, got new everything and trying to set it up again but its showing my old homegroup. I can ether click on (Change Adv...
Network & Sharing Join Homegroup in Windows 10 in Tutorials
How to Join a Homegroup in Windows 10 A Homegroup makes it easy to share pictures, music, documents, videos, and printers with other Windows 7, Windows 8, Windows 8.1, and Windows 10 computers on your local home network. You can also stream media...
Can't Join or Delete Homegroup in Network and Sharing
I have a 3 PC ("Server" and two others) home network. On my Server, OLDLOCALUSER created a Homegroup in Win7. I upgraded all 3 PCs from Win7 to Win10. On my Server, I changed my OLDLOCALUSER to NEWMSACCOUNT. I also created NEWMSACCOUNT on the...
since I upgraded to the 10162 Build I cannot connect to my Home Group like before. The p2p.svc,PNRP svc and the Peer Networking Grouping svc is off!! as a matter of fact there is no " idstore.sst " in the folder that it normally is in....
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:47.
Find Us