Windows 10: No Network Adapter Detected Solved

Page 1 of 3 123 LastLast
  1.    05 May 2015 #1

    No Network Adapter Detected


    I decided to take the plunge and install win 10 on one of my machines. Used windows update to install build 10074 from windows 7.

    Everything seems to have worked fine except my network adapter (onboard Realtek thing) isn't being detected.

    Figured this might be a driver thing so I installed various versions of the realtek drivers both win 7 and win 8 ones and these seem to install fine but then cannot detect the card. The installer gives an error that the card may be in "Deep Sleep mode".

    Once installed the Device "REaltek PCIe GBE Family Controller" appears in device manager with no issues or conflicts, but nothing is in the Network Connections window when I go through Network and Sharing centre.

    I have tried booting to the trouble shooting menu and selecting load unsigned drivers but this has not worked.

    I rolled back to Win 7 and the card came back and all connectivity was restored. Re-installed win10 and back to the same issue.

    Any thought/ideas?

    Cheers

    Dave
      My ComputerSystem Spec

  2.    07 May 2015 #2

    Sorted this now, ended up doing a clean install. I tried many many things including all the drivers under the sun, wiping BIOS cache, clearing network stack with netsh and trying a USB wifi dongle i have (installed fine but never appeared in adapter settings). I can only assume the registry in win 7 was goosed and couldn't take the upgrade to win 10/was scrambled even further in translation.

    Clean install working beautifully and a definite speed boost too.

    Cheers
      My ComputerSystem Spec

  3. Dude's Avatar
    Posts : 8,135
    Windows 10 Pro X64
       07 May 2015 #3

    Thanks for posting back. A clean install fixes a lot of things. The upgrade route is getting better though I think.
      My ComputerSystem Spec

  4.    09 May 2015 #4

    Dude said: View Post
    ...The upgrade route is getting better though I think.
    Yes it indeed does. I went from 9926 to 10041 to 10074 via the upgrade route via Windows Update and everything went smooth as silk. I'm dual booting with Win 8.1 and Win 10 is much more responsive, much less resource intensive. Methinks MS will be more than ready for a July RTM & general release, it's been that good of an experience, at least in my case. YMMV
      My ComputerSystem Spec

  5.    01 Aug 2015 #5

    I am an amateur... I did the update on 7-29-2015. They must NOT have been ready. My network adapters are non-responsive. I do not know how to do this 'clean install'.

    Can anyone tell me how to do this as I NEED to fix my lap top.

    thanks,
      My ComputerSystem Spec

  6.    02 Aug 2015 #6

    I had the same issue with the network adapters not appearing when I upgraded from 8.1 to 10. The network icon on the task bar showed a red 'X' and the icons in the control panel settings were missing. Device Manager showed that my Realtek card was installed and working properly but I had no internet connection. I tried various solutions on other sites but they didn't work.

    My issue turned out to be down to Kaspersky Internet Security 2015. Once I uninstalled it the task bar icon changed to the yellow '!' mark and then showed it was connected. The network adapter icon also reappeared in the control panel settings. I then installed Kaspersky again and all is working well.

    For anyone else with this issue try uninstalling any antivirus / security software before doing a clean install as it might not be necessary. You can then reinstall your antivirus / security software if it solves the problem.
      My ComputerSystem Spec

  7.    12 Aug 2015 #7

    The only thing we could do is do a Windows 10 refresh. It removed the software on the computer but saved the data and the network adapters became available and working.

    We tried reinstalling drivers, uninstalling all antivirus/antimalware and still no luck. Even tried clean boot.. no love.
      My ComputerSystem Spec

  8.    12 Aug 2015 #8

    grapegummy said: View Post
    The only thing we could do is do a Windows 10 refresh. It removed the software on the computer but saved the data and the network adapters became available and working.

    We tried reinstalling drivers, uninstalling all antivirus/antimalware and still no luck. Even tried clean boot.. no love.
    did the refresh work atlast? i have the same issue, i have an option of refresh and going back to 7...i am a bit unsure how will refredh work if it can not access any network connection?
      My ComputerSystem Spec

  9.    13 Aug 2015 #9

    The refresh worked. However.. it does remove all your applications..
    I might suggest if you have a lot of software according to others.. is this:
    1. roll back to windows 7
    2. remove antivirus software
    3. try the Win 10 upgrade again
    If it works you save yourself from re-installing all your software AND your data will be preserved. Let us know if it works!

    If this does not work and your network adapters dont work when you get to Windows 10 (the second time), then you can do a refresh but plan on installing all your software again.
      My ComputerSystem Spec

  10.    20 Aug 2015 #10

    I have Windows 10 upgraded from 8.1 with Bitdefender 2015. After an automatic update my network adapters on wireless and LAN simply stopped working. I tried Bitdefender repair which corrected the issue until next restart. After completely uninstalling Bitdefender and reinstalling, everything works. Thanks for all the advice, very useful.
      My ComputerSystem Spec


 
Page 1 of 3 123 LastLast

Related Threads
Hello, every time I cold boot or restart windows I get an error code 10 on Broadcom 802.11n Network Adaptor in Device Manager. I'm forced to disable and then re-enable the Network Adapter. I have resetted my BIOS back to default settings as I...
So i have a Tp-Link mr3420 running dd-wrt. On my windows 10 machine in the network tab i can see computers that are not mine, hovever on my router in the dhcp table i cannot see any other computers than my owns. On my linux machine i do not see the...
Usb Wi-Fi adapter not working in Drivers and Hardware
I've recently bought a nano usb wi-fi adapter and on it's packaging it says it's only compatible with Windows XP/Vista/7. Indeed its drivers don't work on Windows 10 9879, the device is recognized but it doesn't work. Is there a way around this?...
Solved SSDs detected as CF? in Drivers and Hardware
I have 5 drives installed on my PC (1 HDD and 4 SSDs, the rest are just partitions). I am just wondering what does CF means on 2 of the SSDs. Does it stand for "compact flash"? How to fix this? Or should I just leave it alone? 6911
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:46.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums