Windows 10: .RDP files won't open (remote desktop) after Win10 Anniversary Update Solved

Page 2 of 2 FirstFirst 12
  1.    03 Aug 2016 #11

    No, not using RSAT tools; just Remote Desktop Connection Manager.

    Just read that someone who did a clean install is also having the issue. So, it may not be just an upgrade bug. Seems to be an issue with mstsc.exe. Until it gets fixed, you can still open Remote Desktop and click on "Load" and load your .RDP file. It will import the settings for that session.
      My ComputerSystem Spec

  2.    04 Aug 2016 #12

    BUG FIX - I received reports that this worked until MS addresses the bug.
    ****************************************************************************

    If you are experiencing this issue, you should be able to work around it by removing the custom scale factors you have set (a custom scale factor applies across all monitors).
    1. Hit the Windows key and then type "display".
    2. Tap on the "display settings" link that is found.
    You should see the following text in red: "A custom scale factor is set".
    3. Click on the text underneath which states "Turn off custom scaling and sign out".
    4. Sign back in.
    MSTSC should now work with an RDP file passed as a parameter.
    Last edited by Intrepid1; 05 Aug 2016 at 17:07.
      My ComputerSystem Spec

  3.    04 Aug 2016 #13

    Yes, this did work for me. I set my scale back to 125% after doing the above and things still work.
      My ComputerSystem Spec

  4.    05 Aug 2016 #14

    Thanks Intrepid1!!!!!!! turning off the custom scale factor fixed my RDP not starting issue. How in the world did you find that?
      My ComputerSystem Spec

  5.    01 Sep 2016 #15

    Wow, i only registered an account here to say much thanks to you
    Very helpful post
      My ComputerSystem Spec

  6.    27 Sep 2016 #16

    I just registered to also say thanks and add two things:
    If you use vmware workstation and have the VMware Tools installed the display settings are automatically set to a special scale level. So this is a really bad issue then. Either use the full potential of the vmware tools or use saved rdp sessions.
    But fortunately it looks like one of the Updates for Windows fixed it.

    Thanks so much for bringing me to the decision to check if there is another update avaialble!
      My ComputerSystem Spec

  7.    08 Nov 2016 #17

    I ended up using EasyConnect to work around this problem. Its great for remote connections:

    http://lstratman.github.io/EasyConnect/
      My ComputerSystem Spec

  8.    08 Nov 2016 #18

    Encryption is standard with Anydesk - http://www.Anydesk.com I've been using it instead of the ridiculously priced TeamViewer for connecting to client machines without the need for port forwarding.
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
Windows 10 Anniversary Update “RTM” Build 1607 Shows Up in Microsoft Docs Again Build 1607 is believed to be the final version of the update 84934 Read more:...
Hi folks. I've been noticing that RDP is a toss up on my Windows 10 machines. It hangs and I have to close the connection, then try again and get an error stating it's not available because it's busy, then try a third time after a few minutes and...
I have several laptops at home, and am trying to connect to an SSH connection at work for networking. To be fair, I am an idiot and had a techie friend of mine set everything up, however: At home, on the same wireless network on the same...
Hi. I just viewed Kari Finn's clearly explained Remote Desktop Connection on Win10 and how to connect to remote computer, thank you for that. Good job! In my case though, I use Win XP Home edition. Do I have to have Win XP Pro edition to connect on...
After Win10 update, some of office files won´t open. Some .docx and .pptx files especially. Any hints on this issue?
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 09:59.
Find Us