1.    01 Aug 2016 #1
    Join Date : Aug 2015
    Posts : 40
    Windows 10 Pro

    Mapping network shares on boot


    Is it only me, or is Win10 extremely buggy when it comes to startup scripts?

    In Win7 this worked flawlessly, but since I upgraded (and now installed fresh), when I give an user a logon script (and put it in the corresponding folder of course, incl. turn off the 5min delay), nothing happens. Like, never.

    If I then try doing things manually, things get even worse:
    - using net use under non-administrative CMD, sometimes is OK, and mostly the mapped drive does not show in This PC (but I can find it in CMD via "x:")
    - placing a script with net use x: \\server\share on the desktop brings similar results - sometimes OK, sometimes not

    I am simply unable to pinpoint where the problem really is. First I though it was something with non being "Administrator", but don't think so...

    It will be less problem with gpedit.msc but rather the problematic script execution.

    More-over, not even using map network drive via Windows Explorer is reliable. It may appear in This PC, or it may not (and only be accessible via CMD).

    Any ideas what's going on here???

      My ComputerSystem Spec
  2.    01 Aug 2016 #2
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,636
    windows 10

    If you run it as admin it won't show in explorer as that's not running as admin if it's a mapping you use all the time add persistent to the car so it's mapped all the time. Running via a script can depending on how it's run can mean it runs as system not the user running via at cmd has always done that
      My ComputerSystem Spec
  3.    01 Aug 2016 #3
    Join Date : Aug 2015
    Posts : 40
    Windows 10 Pro
    Thread Starter

    Does the running of script as a User which is part of the Administrators group make the script run as Administrator? I don't think so.

    I'll try adding persistent:yes.

    I can assign the script to a computer policy, but that doesn't run anything, funny enough. Usually it should... especially after gpupdate and reboot.

    So what should I do really?
      My ComputerSystem Spec
  4.    02 Aug 2016 #4
    Join Date : Aug 2015
    Posts : 40
    Windows 10 Pro
    Thread Starter

    Well, funny enough I managed to solve this.

    From what I read, MS is going away from GPO scripts. There is an article out there about that.
    So, as suggested I tried with Scheduler, and low and behold, it is mapped, BUT: only with persistent:yes. Weird.

    And additionally, the logoff script which does couple of cleaning tasks, is running fine from GPO.
      My ComputerSystem Spec


Similar Threads
Thread Forum
Windows 10 Login Password Use when Network Mapping
I have a Windows 10 Pro installed on a Vaio Z Canvas laptop and as the only user I do not use a password to login each time I turn it on. I have a Wireless and Ethernet network installed so that I can share files, printers etc. and do not use public...
Network and Sharing
Mapping a network drive using certificate but not a VPN - possible?
Hey, I currently connect to our office server by way of an installed certificate onto my PC and then using a VPN which is first established before I can map a shared drive and work with the files stores there. Is there a easier way of doing...
Network and Sharing
Going to make this short and to the point. I am on windows 10, tried to map my NAS using map network drive but says "Windows cannot access \\Nas102 check spelling or might be problem with your network. Next, I tried to map a specific folder...
Network and Sharing
Solved GPO Mapped network Drives mapping in Win 10 but not Win 7
I have a medium sized network running. We are currently migrating and updating our shared folder systems. The old system is running Win 2k8 R2 and still has the old mapped drives running what we haven't migrated. The new shared folders are on a new...
Network and Sharing
Solved network mapping in win explorer
:( Has anyone found any fixes for the several problems with network mapping?
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:04.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App

Windows 10 Forums